English

Black screen for incoming calls

Since a few days ago I have an issue when trying to answer incoming calls. The screen stays black while the phone rings. The only way to “answer” is to decline the call, wait until the number pops up in the list of missed calls and then call back… I recalibrated the proximity sensor a few times (eventhough I believe that this issue is not linked to the common black screen issue when trying to hang up the call), but with no effect.
Everthing else on the phone works as it should. I did all the updates and run on the latest released version.

1 Like

I Have the same problem - but my sreen is not allways black!

FYI, I just contact the support on this matter as I got exactly what Ivar describe.
I let you know if I got any news about it. Please, do the same :slight_smile:

1 Like

Hi,
Since 3 weeks, when I get a call there is nothing on the screen.
The phone ring but I cannot answer. When the person hang up, I’ve a missed call and I can call back but I can’t answer before.
I have no problem with rhe call from internet (messenger, skype).

I did the last update and reboot several times, but still not working.

Some ideas ?

Merci

Marion

@t_eowyn I moved your post here where this issue has been described before.

@all: Did anyone already file a report in the #bugtracker? If so please link it here.

Have the same problem. Someone recommended me to contact the support for a new sensor module. It will be sent to me (free). Hope this will work…? Or will an update solve the problem?

It is common with the FP2 that the screen is black during a call (after answering it) due to proximity sensor issues. Are you sure you have the same problem as the people who posted above you? When the call is incoming, the sensor shouldn’t be used yet.

@AlbertJP My problem is exactly as posted above. (It is not about “during a call”)
Since I see there are more people with this problem, I have douts about the solution with the module. If it’s a softwareproblem.I hope more people will report this, so a quick solution can be found.

No problem Stefaan. I think what you are experiencing is a software problem rather than a hardware problem so I was surprised that support told you to replace the sensor module. You could try it anyway if it is free, just make sure to let your fellow Fairphone users in this thread know whether it worked or not.

1 Like

Hey sorry @Stefaan_Coutereel, I think I gave you a bad recommendation. The issue discussed here does not have anything to do with the proximity sensor (at least no link is found yet). So please contact support again and make sure they don’t (like I did) misunderstood your issue. Otherwise the module will be sent to you for nothing.

I report it in the bugtracker today: #59.

Ok, I will contact them not to sent it. I hope a solution will be found quickly, it’s really important for me.
Could it be a problem that occured with the latest update? And if so, can I go back to the previous settings?
Does it help if I report it in the bugtracker?(have no experience in this)

1 Like

@FlavieC already reported it, so please don’t create another report. But if you create an account you can upvote the report to signal it’s important to you.

Apologies if someone already checked this, but could this be a permissions/notifications issue? Guessing (I don’t have the FP2) Settings > Apps > All > Phone (and/or dialler) would be the place to check.

4 Likes

There’s no “All” option anymore in the apps, memory usage has moved to a different place in the settings. It’s just Settings > Apps > Phone now.

Could you please give me the number, I couldn’t find it in bug tracker. How can I erase a bug in this app? thanks for your answer.

1 Like

More people having this problem? Really want a solution , urgent!

I had put some hopes to the last update, but unfortunately - no real change :frowning:
But at least I discovered a work around:

  1. Someone calls - the screen stays black
  2. Push the right top button (“power button”)
  3. The screen turns on
  4. In the center bottom of the screen a button turns up stating something like “go back to current call”. My telephone speaks German and states “Zurück zum aktuellen Anruf”
  5. Push that button
  6. Get to the usual swiping screen where you can either take or reject a call…

Nevertheless - getting back to the original status would be great :slight_smile:

@Ivar, I don’t even get on your 3th step. If I push the power button, the screen turns on, but the call stops. So I always have to call back.
Hope a solution come quickly!

Sounds like your power button is configured to decline incoming calls when pushed.