App does not see battery/firmware status of Fairbuds [Android]

Just got the Fairbuds and linked them to my phone.
The app recognizes that they’re connected but doesn’t seem to be able to get the status.
Trying to change the equalizer settings does not work either.

Images added below


After a first report of a serious issue with the latest Fairbuds firmware update, Fairphone reacted by halting the distribution of the update (and withdrawing the Fairbuds app from app stores temporily). See here:

I have indeed already read up on this. My issue seems to be unrelated to this however, that’s the reason I made this post.
I do not have any status from my Fairbuds in the app at all, they are usable without the app though.

1 Like

Hi Sakloui,

The Fairbuds have both a Bluetooth Classic (used for audio playback and calls), and a BLE connection (used to communicate with the app). What you are seeing now is a state where the Fairbuds are connected to your phone, but the app can’t connect to the buds’ BLE connection. This can be fixed in a few ways:

  1. Did you use the app to update the firmware, and can you now not see the status anymore? Unpair the Fairbuds from your phone (it could be that your BT settings even show 2 Fairbuds connections, the BT Classic and BLE, unpair them both).
  2. If you didn’t update it yet (please don’t until further notice). BLE requires your phone to have its location services turned ON. So please try checking that, and if all else fails: try reinstalling the app and re-pairing the earbuds.
6 Likes

After removing the Fairbuds and reinstalling the app I got it to work.
I already did these steps before but 3rd time is the charm I guess. Thanks!

4 Likes

Same here, brand new fairbuds, andriod app doesn’t show the percentages and the EQ doesn’t seem to be working. Latest app, the buds hasn’t been updated with any firmware.
I tried unpair, reinstall the app, location services on, but it doesn’t help. (Oneplus 10 Pro)
Any suggestion?

Update: It works in the updated app (2024.apr.17.)! Thanks!

I just paired a pair of Fairbuds both with an FP3+ running /e/OS and an FP4 running Fairphone OS (latest system version each). While the Fairbuds app version on both devices seems to be the latest, the Fairbuds app apparently cannot get the charging level nor the firmware version of the Fairbuds:


Now charging level isn’t that important (it’s shown as 100% in the device bluetooth settings). However, given the Fairbuds only just got out of the sealed box, I do not believe that this pair is on the latest firmware version. I also think the current firmware version should show. The information about both is missing both on the /e/OS FP3 as well as the Fairphone OS FP4.

Any idea how to make the app retrieve the information? Or do I need to wait a long time until this gets shown in the app?

As far as I recall, especially with the old firmware, there was the need to pair the fairbuds twice:
Once for the audio via “normal” BT and once via BT LE for the firmware and battery information. The LE functionality usually requires location permission on the phone. Have you tried that already?
If I understood correctly, this should not be required with the new firmware any more.
(@BobVI must have been the one mentioning this somewhere, but I can’t find it right now.)

5 Likes

you can search for people as well :wink:

4 Likes

We faced the same during our HH meetup

, so good to know. :wink:

1 Like

@urs_lesse do you have the latest version of the app?

Yes, 2.0 (15 April 2024). Will try the Reset thing later.
And I only allowed Location later, not upon the first launch of the app.

Curious, please let me know how it goes :slight_smile:

Unfortunately no change. Still the status as originally described and shown in the screenshots above.

I actually did a factory reset (10 seconds button hold on the Fairbuds case, then close the box for 5 seconds) before renewed attempts. I deleted the app, then reinstalled it (still 2.0) – from Murena’s App Lounge on the /e/OS FP3+, then from Aurora Store on the Fairphone OS FP4 (I do not have a Google Play Store account). I then tried the same (for the very first time) on the Fairphone OS FP5 with Fairbuds installed through Aurora Store. Same result. I also chose the most “permissive” settings for each attempt now (most generous permissions possible).
Just to mention it: I can listen to music with the Fairbuds, although I tend to think that it’s the pre-firmware sound (could be shinier in the highest tones).

It’s been my fault, of course.

I kept misreading this (although Bob actually spelled it out pretty clearly … :blush: ), just keeping thinking of and allowing location permissions while never thinking of the actual Location button in the quick settings. Once I – finally – activated the latter, it was a matter of seconds … :white_check_mark:

Just mentioning: Location Services need to be kept on to see charge level and firmware status in the app and to allow the Equalizer to work.


Curious: If BLE requires location services to be turned on, does this mean that my listening with my “old” TWS earbuds (with location services off) drew more energy than necessary? :thinking: Or would the extra energy for location outweigh this?

3 Likes

Do they have an APP as well? I understand BLE is only for the App and normal BT is used to connect and listen to music, so GPS on or off doesnt matter in this cas

1 Like

Just bought some new Fairbuds as well. I have the same issue here. I have location services on and gave it the right permission. Deleted and installed the app 3 times. Connected the Fairbuds multiple times but still no success.