After update to 1.8.7 google apps can't be installed!

I managed to upgrade to 1.8.7 but now everything gets stuck when I try to downlad google apps. “please wait” and then nothing happens and then it stops and then the updater closes…

AGAIN!! With every single update I had similar problems… I should have waited for the weekend to update so I would have time to try and fix it… :frowning:


I need google apps (unfortunately) so please help…

Similar problem here, google keyboard stopped and gmail app stopped as well. Browser no longer up to date to install google play store anew.

I had the same problem (can’t install Google apps) and I also get the message: Android-toetsenbord (AOSP) is gestopt.

Here is the solution:


Same problem here. Android-toetsenbord (AOSP) stops every time I try. And Google apps stops as well. Both giving a message everytime. Can;t write any textmessages or use the browser. Please help.

1 Like

Ah, it seems that the problem is gone. What I did: went to fairphone updater. There it was mentioned that I needed to install google apps (which I allready did yesterday). But nevertheless I tried. And this time it worked.
Have no clue why it worked today. But relieved!

1 Like

OK this is getting ridiculous… I can’t use my mail, my agenda or my contacts…!!! I need a solution ASAP!

I can’t have to deal with this everytime there’s an update…

Sorry can’t read this…

Same problem here. This really sucks.

You do not need the browser to reinstall the play store. Just open the Fairphone Updater App and choose to install Google Apps there. Make sure your screen stays on during the update.

1 Like

@evidemment: That’s the english Version of the tutorial.
Could you make it again step-by-step, and double-check each point (especially don’t forget to allow super-user rights, if necassary)?

Were that the SAME problems with GAPPS? If yes, could you remember how you solved this the first time(s)?

For sake of completness, here is a very huge thread about similar problems, but I could not figure out a “final” solution, just a lot of hints what people tried…
Cheers, Robert

The suggested link does not help to solve the problem at all!

After rebooting for the installation the phone is stuck in system recovery mode saying “no command”.

… updates should only be released if they work without causing trouble … !

@Irrelevant: Since you did not mention that you have the well known “no command” message before, you cannot blame recommending you non-helpful links (as they were adressed to @evidemment anyway).

You searched already for “no command” in the forum?
Then I guess you found already this links:
Trouble Shooting Article
Forum topic 1
Forum topic 2

Report back if you succeeded or not…
Cheers, Robert.


Hi, I had the same problem ad solved it!
First, I made Fairphone OS my standard homescreen (I had another launcher; in system settings >apps, I remove its Standard).
Then, I [manually reinstalled Fairphone OS 1.8.7][1], meaning the second time, the first was via the Fairphone updater (no worries, it still keeps all data and settings).
But this time, after the update, before doing anything else, as soon as I saw the Google apps install button, I pressed it and it started downloading (which it refused before).
It went smooth!
Conclusion: if any problems after FP OS update, do the OS manual update.

I hope this works for you too.

Kind regards,


A most valuable reminder. People with non-native launchers have encountered problems with earlier upgrades, so this is well-known (by some) as well as mentioned in earlier threads but of course easily forgotten. So: whenever a new FPOS version/upgrade arrives, those who have installed an alternative launcher should always revert to the default before running the update app - just to be on the safe side.


During install of gapps I get the message md5 error and if I ignore this , it can’t find file sdcard/updater/
How can I download new file?

Just to say, seems this was a problem with WLAN, when I tried again in different WLAN, everything worked fine.

I got the ‘can’t find file’ message, but a second attempt worked for me.
But the md5 error, which I didn’t have, sounds worrying. After the 1.8.5 upgrade, one user solved it by a factory reset, after which it was possible to reinstall gapps: see Google Apps can’t be reinstalled
This of course means that your personal settings and other things will disappear, so a backup (e.g. with Titanium Backup) is strongly advised.

1 Like

Yep that’s what I did… factory reset… it solved the problem alright but it’s the second time I have to do that, just after every upgrde. Don’t think it’s the way to go… it’s so fastidious.

Anyway, hope it’s better next time…

By the way, just before the reset I managed to installe gaaps again just by pressing the same button in the updater apk!!! Just like that it worked! so don’t despair, try it again a few times and then do a factory reset.

Why you finally did a factory reset, although you have been able to install GAPPS just right before?
What you mean by “updater apk”, just the normal updater app, right?

@evidemment: You mentioned in another topic (about the Android ID) that you chose to reset your Android ID to the old one when Titanium Backup warned you that it had changed. As I have learned today, this Android Device ID links the phone to the Google services. Maybe that’s why you’ve had these problems… try to keep the new one next time.

1 Like

I hope there’s not going to be a next time of hard reset!! but thanks, I’ll keep that in mind.