Google Apps can't be reinstalled

I can see why it might feel that way, but you don’t have to be tech savvy, you just need to look/ask (on the forum or support) for help if you run into trouble. For many people updating works without that little “stay awake” trick. And also it’s not a new bug that started happening now that FP2 is about to be released but it’s been around for quite some time.

Consulting the forum does not fix the problem, it just helps you to perform the upgrade manually, i.e. you need to be tech savvy in order to do so.

When the bug has been around for quite some time, it really baffles me why someone has not packaged the update to self-execute and to determine the right upgrade in the process?

It seems like people with the original batch of phones are not considered anymore with a working update, unless they have decided to unify the storage. Or perhaps not even those? Planned obsolescence?

What exactly is your problem? We can’t help you if you don’t tell us.
Usually a manual update is not necessary.

My problem is the same as the title of this thread, and as most of the posters in this thread.

There are many different problems and solutions described here.
E.g. the guy who posted before you said that this worked for him:

“Stay awake” was ticked and the phone was plugged in (to the electricity plug).

I also get the error message: The application Android-keyboard (AOSP) has unfortunately stopped (translated from Danish).

It would still be nice if you could give more information:

  • Did the update not work or can you just not reinstall the Google Apps? (in other words: if you open the updater app what does it say is your current OS version?)
  • Did you get any error messages? What did they say?
  • Do you have a unified storage?
  • The update did not work since I am not able to reinstall the Google Apps.
  • Error message: “The application Android-keyboard (AOSP) has unfortunately stopped” (translated from Danish)
  • No.

What I meant was if the update of the operating system work?

No, the keyboard crashes, hence the error message.

Ok let’s start from the beginning: Did this problem first occur when trying to update the operating system or out of the blue?

In the first case please go check if you are now actually running the new operating system (1.8.5) or if the update of the OS didn’t work. (The keyboard not working means that Google apps don’t work, not that the update didn’t)

  • The problem occured after I tried to update from 1.6 Cherry to 1.8.5 Kola Nut
  • I am running FP 1.8.4 according to the Fairphone Updater (if I am looking in the right place).
  • Well, the keyboard actually crashed when set in the Danish language. I have now changed it to English and it works.

Unfortunately, this has already taken far too much of my time, and I need to take a break to attend to things more important. My Fairphone is able to work, but Google Apps and Danish keyboard is out. I can live with that for now.

See you later.

Like others in this thread I’m trying to install the gapps to a fairphone. How it’s gotten in this state:

  • it was running 1.8.5 just fine
  • storage space was running out, so I switched to unified partitioning (and lost all the Notebook notes, the recommended helium backup doesn’t include them)
  • it could be that in the end I had to do the switch manually, it’s a while ago and I remember it not going that fluently
  • either way, I’m now unable to install gapps. I’ve tried every fix I could find in this thread, none of them successful:

. Wiping the cache partition
. Clearing the data of the updater app
. Reinstalling the OS via the updater (fails with ‘error’)

Trying to install the gapps always gives the same md5 error and afterwards an error about the file on /cache.

Is there anything else I can try? I saw somebody who solved it by flashing with the spk tool, but that link is broken.

md5 error??? I guess, this is new.

Ah, I think that’s just the german translation for ‘signature verification failed’.

I tried using the SP Flash tool, but it doesn’t start the ‘download’. So I’m going to try the adb sideload option. (all this effort just to get the gapps back :confused: )

This indicates that something is wrong. Did you use the right system image? After unifying the partitions, you have to use the images for the FP1U.

I confused some steps and the way in which they fail. Reinstalling the OS via the updater works, it just doesn’t fix the gapps issue. Trying to re-apply the partition upgrade (via recovery mode) fails with ‘error!’.

I fixed it! I didn’t think this would work, so I didn’t try it before, but resetting it to factory default worked! (still running 1.8.5, after the wipe I could finally install gapps. Now praying that titanium backup did backup all the things)

I’m thinking it might be that I broke being able to install gapps by restoring backups before (or probable while) installing the gapps.