Accidentally entered TWRP (Team Win Recovery Project) and no idea what to do

Is there any other way?

My computer can’t handle the size of the ZIP folder. Also, my phone still stays in the first screen even after starting it in fastboot mode. I see nothing ever else than the first screen.
I tried to connect anyway to my computer (only after I realized I cannot extract the files, because this PC has not enough space - Can’t free that much space), but it does not recognize the FP2…

… This is a nightmare really D:

1 Like

Oh, now a blue light blinks in the upper left corner… That’s all the change.

There’s not much more to fastboot mode than the Fairphone logo … ok, with the current firmware it additionally vibrates a few times and the LED flashes blue to indicate fastboot mode.

USB stick or some other external storage to the rescue?

So, fastboot mode works.

A general remark:
Keeping Volume - pressed while the phone starts or reboots should get you into fastboot mode.
Keeping Volume + pressed while the phone starts or reboots should get you into the recovery program (TWRP - Team Win Recovery Project).

Thank you for your efforts despite my slightly panicky mood!

I fixed it, but with a different attempt. Not fastboot was necessary, but recovery mode.

Then in ‘Cache’ I found the update and could install again. Then it restarted fine, even if it took a while longer.

Thanks anyway. Happy to not need to do it manually :slight_smile:


Hi, thanks for all your explanation, but I’am totally lost because I am a huge loser with computer and English. I’ve pressed the button reboot, and now my fairephone is stucked with the blue light on the left upper corner blinking… should I wait? I am totally lost… ;( Thanks a lot for your help…


Had exactly the same issue, thanks for your solution.

If someone have the same issue TWRP -> Install -> cache -> FP2 update zip file -> install


No. There’s nothing more coming.
This is called fastboot mode. You can do something with that, e.g. …

1 Like

Thaaaaaanks, I’ve finally managed it! Thaaaaaanks a lot!


hi everyone,
No luck for me.
The phone doesn’t wanna leave the TWRP mode.
I did download the update file on my PC, but as I try to run it, the Phone will not connect to the PC…

Yes I did start the phone in the boatloader, by holding the volume down bottom and start bottom together, and yes, it turns on the screen with just Fairphone black screen, but no, it doesn’t show up on the PC (windows 7 OS).

What’s next?!

Really annoying by the way.

this is the link that I followed for the instructions

You could consult one of the #fairphoneangels if there is one located near you, but your post history suggests there probably is none :cry: Did your phone previously connect to the computer or does it have a problem with the cable / bottom module?

Where does it say the phone has to show up?

" 5. Connect the Fairphone 2 to your computer
6. On your computer, execute the update script"

What does happen if you execute the update script?

1 Like

that’s what it says

1 Like

Yes, it did always connected to the PC. I tried different cables, but no luck.

1 Like

Did you get a blue light indicating fastboot mode?

1 Like

When I start this “flash-for-windows” batch-thing nothing visible happens. Should ther be any reaction on my phone? Or on my computer?

After a while you get back to the command line, so don’t disturb it. If there is no reaction, there are also no errors.

So as long as the blue light is on and the logo is shown, my phone’s silently working on ist own and has an invisible “do not disturb”-sign on its office-door? :wink:

As long as your computer is busy running commands. If you’re in a console, and it returns you to “name of directory >” then it’s done with the previous command.

So there should have been an black window like the one ilcrio posted some hours ago?

(20 characters)