Updating FP2 - TWRP screen

Each time I try to download the FP update, the whole process is fine, and presumably the update file is downloaded to my FP2.
But when I get to the TWRP screen it offers me Install, Reboot etc.
I’ve tried reboot and it just returns to the FP2 without the FP2 update done.
I’ve tried Install, and it takes me to the file menu. Where do I find the file and what file am I looking for?
I’ve looked in previous topics and it recommends manual install. But I use linux and there is no detailed information.
So, I’d prefer to use the proper system. What’s do I need to do instead?
(because of this i’m now a load of updates out of date and the phone is not working well at all).
Many thanks for any assistance.

Actually the Linux installation instructions and file are online now (for less than 24 hours, so maybe you checked before that):

The fact that you still have TWRP on your FP2 actually suggests it wasn’t on the final version before Android 9 (the final Android 7 update – 19.11.2 – actually removed TWRP).


Thanks, that’s great.
Actually I’m currently in OS 19.11.2 but - because the phone’s been working like pants - I factory-reset and probably reinstalled TWRP using the app backup and restore app.

1 Like

If I removed TWRP from the phone would not the phone update as per the intended automated system?

Worth a try when in TWRP …

A little more detail in between …

At least that’s what worked for users before when TWRP was still bundled with Fairphone’s OSes. I don’t know whether they changed the update procedure with the Android stock recovery now.


Really helpful, thanks so much :slight_smile:

Thanks for the advice, but it didn’t work - the TWRP didn’t have any files visible to me in cache or anywhere. So maybe it is no longer the repository for the FP updates since its use has been discontinued.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.