FP2 totally blocked after trying to install 19.05.3

Hi all:

I tried to update my fairphone to 19.5.3. That was a big failure. It didn’t work, I got the “Unable to find the partition for path ‘/system’" problem, then the “team win recovery project” thing and, after tryibng to reboot, now just a screen with “ fairphone powered by android” when I try to switch it on.

I tried then manual update as explained in the Fairphone web but when I launch the flash command the command (with windows 10 and my FP2 in bootloader mode with a USB data cable) says the following (whether with 19.5.3 or 19.2.1):

** Fairphone OS 19.05.3 Manual Flashing Script **

Validating files…
El sistema no puede encontrar la ruta especificada.
ERROR: Checksums do not match, try to download the manual update again.

Aborting now (press Enter to terminate).
Presione una tecla para continuar . . ."

I’m totally blocked. My FP2 doesn’t not start and I can’t install anything manually.

Any tips or solutions?

There was some user recently who fixed that checksum error message by extracting the files from the downloaded ZIP file again (something had gone wrong the first time).
If that doesn’t work, try to re-download the file.


Worth a try when in TWRP (you can get there by keeping Volume + pressed while starting or rebooting the phone) …

A little more detail in between …

This means that the command in the flashing script did not find the files to validate (the next message, the ERROR: Checksums… is misleading here).
The most probable reason is - as @Ingo has already mentioned - that the zip file is not really extracted to your disk but you started the batch file from the just opened zip file.
So extract the files to the disk first, then start the batch from the directory where you have extracted the files to!

Thanks i followed your instructions and it worked!

Now let’s see if the update will solve the reboot problems that appeared with android 7…

All the best

1 Like

I tried that first but it didn’t work. Then I used the manual installation with the advice of Volker and it worked.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.