Using LineageOS on the FP2

Does somebody using Lineage know if Camera API 2 is supported on Lineage?

Edit: When running Lineage on the Fairphone.

Google knows:

Whether a device uses the new or old camera HAL depends on the device-specific camera blobs. Some might also support both but have severe bugs that prevent using the newer HAL.

Thanks for the link, but that now i still don’t know if the Camera2 Api is exposed when running Lineage on the FP2.

That means: No. The blobs have to support it, but they don’t (We had this discussion here, maybe a search helps? :wink: ).

Does anyone know if there’s a way to use the checkup or proximity sensor calibration tool on LOS? Especially the second one, as with the new camera modules it’s said to be necessary to calibrate the sensor… Or does this not apply for LOS?

Hi, I’m getting a red rectangle popping up in my display covering the sides of it. Sometimes it seems to pop by itself and it pops op when tapping on a wide variaty of tapping options (such a opening a app or just tapping on whatever tap you can make in settings for example).

Did anyone encounter this bug? I flashed the latest modem and LOS OTA-zip file.

TWRP does not find any files on the external sd card… What am I doing wrong?

Update: Formatting the sd card did the trick. :slight_smile:

Did you perchance activate one of the display debug options in the developer options?

1 Like

Hi @lklaus, I don’t think I did that. Right now this problem is solved (I forgot to edit my post this morning). I wiped my phone and flashed the latest zip and modem file, but I’m not sure if I actually needed to do that.

Fortunately I still got some other problems :wink:. The PIN verification acts a bit weird. It flashes away and immediately another PIN verification pops up.

Besides that I can’t seem to get an internetconnection via LTE. It could be because of my AfWall+ settings. I tried a lot (different AFWall whitelist settings, different DNS settings f.e.), but nothings seems to work. After I flashed LOS again and de-installed Orbot it worked fine by putting AFWall and the browser on the whitelist. Later on I got a little x in the LTE-connection icon (after a restart). Maybe it’s because I disabled OneTimeInit and com.android.smspush, though I enabled those later again and still no connection. Calling and SMS works fine.

The pin verification thingy happens when unlocking, or when entering the pin for decryption? (I see this when entering the pin for description after boot)
What mode of afwall are you using? Blacklisting or whitelisting? The latter could be quite difficult, so i went for blacklisting, even though i consider me fairly experienced (but not experienced enough to feel sure about which subsystem does what better connection in Android besides standard definition. Browser is browser, and so on. But gcm push and so on gets complicated)
I also sometimes get the x and a dysfunctional network connection from time to time, but not very often
Right now i have the problem that alternating wifi and mobile data leads to mobile data not working any longer, but I’m on an intermediary build of los so I’m waiting for the next “official” before i complain

I had an issue with the APN settings fro mobile data being off for my provider, you can take a look at that as well.
For me there was a proxy set up, which I simply removed.

I allready ordered the new camera module, and i’m also concerned about the proximity sensor calibration.
My plan was to use the Fairphone 2 of my girlfriend (with Stock Android 6), insert the new camera module, calibrate the sensor and then remove the module and put it in my FP2 with Lineage.

But: does anyone knows if this could work? It could be, that the calibration data is stored in the Phone, not in the module. Or as Klaus mentioned, maybe it’s not necassary to calibrate…

Edit: Here are the first Lineage Camera expressions: New Fairphone 2 camera

Hi @lklaus, this happens when entering the pin for decryption. I understand the same happens on your phone?

I’ll try the blacklisting. Right now I use the whitelisting. I disabled OneTimeInit and smspush on advice of https://blog.torproject.org/blog/mission-impossible-hardening-android-security-and-privacy.

tnx :slight_smile:

Hi @dupdup, yes, entering the encryption pin regularly removed the keyboard, often after the keypress and immediately opens a new one, that then works

1 Like

@Nivve. Tnx! That worked :slight_smile:

For Orbot users: I get the following message in the Log:

“WARN: You Specified a public adress ‘0.0.0.0:5400’ for DNS Port. Other people on the Internet might find your computer and use it as an open proxy. Please don’t allow this unless you have a good reason.”

I can’t find any usefull information about this somewhere else on the web.

Just switched from Open OS to Lineage OS. Great result.

Compared with the previous OS, here are the improvements on my side :

  • all the system is much faster and smooth
  • the camera (finally) takes instant pictures
  • no need Gravitybox and Xprivacy, all the features I needed are there already
  • more options in the settings
  • no more overwarming of the hardware

So far, just got some trouble with :

  • I loose the 4G connection sometimes, the only way I found is to reboot
  • Didn’t find the way to grant r/w permission to the SD card

So I’m really happy about the result. If someone has a solution for my two problems, will be happy for any help :wink:

4 Likes

https://bugtracker.fairphone.com/project/fairphone-lineageos-on-fairphone/issue/11

The application that needs it should request the same grant-window as in android 6 (FPOOS). Works on my side.

1 Like

Is the dual SIM working on LineageOS? It would be great to have more feedback on this system.

See the startpost. Yes it is working. I would suggest starting here when you want to flash LOS:

1 Like

Thanks for your answers snevas. About the permissions issue, it is for Titanium which doesn’t ask for permission since it has root access. I’m going to open a new treat to develop.