Using LineageOS on the FP2

Hi @snevas I can’t see that any others have had the same issue (also checked the bugtracker) but I’ve noticed that I can’t Power Off without it automatically restarting.

I’m using the latest versions 14.1-20170911-UNOFFICIAL-FP2 and modem-17.09.3.zip

My phone is also encrypted and will let me Power Off properly once it reaches the encryption unlock screen. Should I be adding something like this directly to the bugtracker? Ps. I really appreciate all the work you and everyone else is doing on LOS :blush:

1 Like

I just checked and I can confirm this, same OS, same modem, encryption too, same behaviour.

Maybe this is related to the the new modem with the old blobs. I saw that there were also new blobs released. I’m gonna build a new testbuild when these new blobs are merged. If the problem still exists after that, please make a ticket.

2 Likes

Did anybody test if WiDi/Miracast is working with LineageOS? I believe it has never worked with Fairphone Open OS, so it would be interesting if it does.

1 Like

Now as you mentioned it, I tried to connect my LineageOS-Device (Build 20170911 / Modem 17.09.03) with Amazon Fire TV, and surprisingly it did not work anymore, it connects and I can see the very first screen, but then it’s freezing.

I re-checked that with my girlfriends FP2 with stock Android 6 and it’s working like charme.

So for me the answer is no, it does’nt work well with LineageOS.

1 Like

hi, can you post logcat and dmesg when it doesn’t work?

Chris

just error logcat: https://pastebin.com/1AwG94JT
raw logcat: https://pastebin.com/qPghdJJH

and raw dmesg: https://pastebin.com/71ksaDcm

Hi,

could you try the following file and report back if that fixes the miracast?

To install the file:

adb root
adb remount
adb push media_codecs.xml /system/etc/
adb reboot
1 Like

Hi, I installed the file, reboot, but still the same behavior.
But now the logcat looks a littlebit different:
https://pastebin.com/mrg7FaDF

hmmmm. this worked for z3ntu on anycast.

Looks more like a network problem now.

Can you try a few times?

I retry it, after the second connection try, the fireTV crashed and reboots now.
So after every connection the FireTV shows the very first picture.
FP says that it is still connected.
https://pastebin.com/iufTvQvr

can you try this file, too?

adb root
adb remount
adb push p2p_supplicant_overlay.conf /system/etc/wifi
adb reboot

1 Like

Still the same, connection established, first screen, freeze.
https://pastebin.com/dXyzh1G4

can you check what you have in file
/data/misc/wifi/p2p_supplicant.conf

disable_scan_offload=1
driver_param=use_p2p_group_interface=1
update_config=1
device_name=Android_55af
device_type=10-0050F204-5
config_methods=virtual_push_button physical_display keypad
p2p_ssid_postfix=-Android_55af
persistent_reconnect=1
p2p_no_group_iface=1
pmf=1
p2p_search_delay=100

network={
ssid="DIRECT-6z-Schmul’s Fire TV"
bssid=72:75:48:ad:dd:ce
psk=[some stuff]
proto=RSN
key_mgmt=WPA-PSK
pairwise=CCMP
auth_alg=OPEN
disabled=2
}

To come back to my own question, I installed Lineage OS today and Miracast is working perfectly for me. I’m impressed so far.

2 Likes

@max_seabrooke, @AnotherElk
Does this problem still exist on your phone?
I have the same problem with a new FP2, using the latest lineage-14.1-20171004-UNOFFICIAL-FP2 and modem-17.09.3.zip. The device is encrypted now (but the problem was the same without encryption) and behaviour is the same as described by @max_seabrooke.

5 posts were split to a new topic: Xposed on LineageOS