Using LineageOS on the FP2

Did you follow the the fastboot method link in the post? And did you on the linked page then follow the You will need the platform-tools from the Android SDK on your computer. link in the “Fastboot Install Method (No Root Required)” section?

Try fastboot instead of adb.
Or hold down volume down when turning on. The FP screen with the logo remains then.

adb (and probably fastboot) are not installed or are not on your path. Check whether your package manager has them for the easiest installation method (as this should add them to path). Look for android-tools, though some distros split them into e.g. android-tools-adb and android-tools-fastboot.

Hey! I also couldn’t get fastboot going, because I’d never used it before. Coming from Fairphone Open 5, I installed the TWRP app, and used it to flash TWRP_3.1.1-0-ota-fix.img to the recovery partition. Then I booted into TWRP to flash the modem zip, lineage, and opengapps, following the instructions from the forum. And it had been great since!
Has anyone else had success in doing this instead of fastboot? I think this helps open lineage to a wider audience :slight_smile:

@AnotherElk Hi :-). Yes, I think I did. I did download the platform tools on my computer, so I’ve got adb and fastboot. I did enable USB debugging on my phone. When I doubleclick on adb I get two terminal screens. One of those (named: --adb --80x24) had a lot of text and closes of with the wordt “Proces finished”. In the second screen (named: --bash --80x24) I can write command lines. That’s where I got stuck, like I wrote in my previous post.

I’m not sure if the connection with my phone is correct. Maybe that’s the problem?

@mase I tried fastboot, but I end up with the same problem as with adb.

@Johannes maybe you’re right. Should I find the package manager on my computer (iOS) or should I download it (f.e.

Or should I just try the method from @anthony first?

tnx already :slight_smile:

With latest build 0724 the auto brightness is removed, is someone else experiencing this?

1 Like

@dupdup: my mistake - somehow I had in my mind that you we’re doing this on a Linux system - I’m not sure whether there is such a thing in a Mac. If anthony’s method doesn’t work, here’s a couple of ways that should work around bash (=terminal) not finding the adb you installed:

  • Open a terminal in the location where you installed/unpacked the android-tools (i.e. where you double clicked), or navigate there using cd, as in cd /home/user/path/to/tools/. You should then be able to run adb and fastboot from bash without messing with the path if you put ./ immediately in front of it, like: ./adb reboot bootloader.
  • In a similar vein as above, you can tell bash where to look each time you run a command. The advantage is that this can be done from any location, but you have to type the full path each time, e.g. /home/user/path/to/tools/adb reboot bootloader
  • Bash has a list of places (=folders) to look for commands, you can add custom entries that only affect the current terminal session like so: PATH=$PATH:/home/user/path/to/tools/. After this just running adb reboot bootloader should work within that session.
  • As an addendum to the above, if you want this to set up to run at every terminal you open, then there’s usually a hidden file in your home folder where bash keeps its settings - I’m not sure which one mac uses: popular options that I know of are .bashrc, .profile, and .bash_profile. Verify that whatever you put in actually works first, as changing it in the wrong way can potentially have messy side effects.
1 Like

Confirmed, and brightness settings have no effect at all.


Thanks, rolling back to previous version :smiley:

Does anyone have a functionality and settings checklist to go through after an update readily available?

How do you switch back? TWRP Backup?

Dirty: Download out of the wiki from Porting Lineage OS to FP2 v14.1.4 and install it with TWRP over your existing build.

1 Like

I downoaded and updated and I also note the missing brightness behaviour.

Additionally Encrypting doesn’t seem to work. Whenever I hit ‘Encrypt Phone’, the phone just reboots and nothing seems to happen.
This happened on first install as well as after the OTA update.

Edit: At least, I expect the phone to mention it is encrypted in the settings menu. However instead, I can just do the scripting procedure again, with the same result.

1 Like

If you are on the OTA-update version, just download 20170708 from here.

I’ll remove the latest build.

1 Like

Hi, I succeeded to do the fastboot method as mentioned in “LineageOS 14.1 with OTA updates for FP2” :smiley::smiley:. Tnx to @Johannes!

Unfortunately now, after I tried to flash the modem zip and and the latest LOS zip (20170708), my phone fails to install. It says:

‘Zip file is corrupt!’
'Error installing zip file ‘external_sd/’

Beside that, it couldn’t find the MD5 file.

I presume I shouldn’t reboot my system right now?

tnx again…

ZIP and MD5 can be found here:

You can transfer files from TWRP with MTP and then retry flashing all the zips.

1 Like

tnx @snevas. I put the MD5 file on my sd-card, but when I put it back in my phone and tried to install again I couldn’t find the MD5. I still tried to flash again, but again I couldn’t flash.

I didn’t transfer the file from TWRP with MTP. I don’t know how to do that, although I tried to find out. Maybe that’s the reason that I can’t find the MD5 file on my sd-card in TWRP? Although, that would be strange, since I can see the other zip files in TWRP while I I didn’t use MTP to put those on my sd-card…

I hope anyone can help me out, that would be great :slight_smile:

Edit: Could this be the reason: ‘Android can choose the files it presents to you, and hide system files so you can’t see or modify them. If you attempt to delete or edit a file that can’t be modified, the device will refuse the request and you’ll see an error message.’? (

Edit 2: 27072017 - I tried to transfer the md5 file with adb push, but it didn’t succeed. I constantly get the following answer:

-bash: ./adb: No such file or directory

the last command I used was:
./adb push C:\ /sdcard1

I put the file directly on the Mac HD…

Edit 3: pfff… sorry guys, ofcourse the file was on my sd-card of my phone the whole time (I saw I could check it in TWRP via ‘Advanced’). Transferring via TWRP or adb wasn’t necessary. But well, I still got the same problem, which I wrote down in my previous post.

If anyone can help me out… tnx!

Edit 4: Problem solved!! :grinning::relaxed: I solved it in the end by NOT queueing the modem zip and the lineage build and then flash, but by flashing them one by one. So, in my case step 3 and 4 of ‘When coming form any other OS’ (LineageOS 14.1 with OTA updates for FP2) should be done differently as is described there.

I have a reproduceble bug in the latest Version from 8.7.2017 with dual SIM cards.

My config looks like this:
SIM1 = Telco1
SIM2 = Telco2

Mobildata = Telco1
Telefon = Telco2
SMS = Telco2

After every reboot the SMS is switched to Telco1 :frowning:

Can someone confirm this?

Same issue for me… with an older version: 14.1-20170626-UNOFFICIAL-FP2

Good to know that I’m not alone. Perhaps someone with more development skills like I do have the same problem. @chrmhoffmann @z3ntu