Using LineageOS on the FP2

I have the same setup, but this does not change at boot (so probably it’s dependent on the operator/sim)

I had an issue with UnifiedNlp not completing the self-check succesfully (The registration in the system never completed). I had this fixed by moving the backend and UnifiedNlp to system with the Link2SD app (suggested by Snevas).

An alternative is to use Terminal (with root permission), as suggested to me by dedareit. I have not tested it, so I am not sure it’s still 100% correct after I reformatted it in a more readable state:

  • Open Terminal with root permission
  • $ su mount -o remount,rw /system
  • $ mv /data/app/APP /system/priv-app/
  • $mount -o remount,ro /system
    (Replace APP with the name of apps directory, which you can look for with $ls /data/app)

I just thought I post it here in case anybody else encounters this.

The best way is to follow this:

Thanks to @Roboe.

This way, you do not have to worry about making unified Nlp as a system app after every update.

Works like a charm for me.


Did anyone flash the unofficial sdk25 zip file for android 7.1.2 from purify? I don’t understand why there are no zip files for arm / arm64 / arm86.

Edit: Can I consider it to be safe to flash the zip file? The other sdk’s didn’t do the job.

As stated in the article you linked to, I wouldn’t try it without making a nandroid backup in advance.

1 Like

Realy? Do you use SIM2 for SMS?

Same here.

My usual config is:
Cellular data: SIM1
Calls: SIM2
SMS messages: SIM1

For testing I switched SMS messages to SIM2 and did a reboot. Afterwards SMS was indeed switched back to SIM1.


@snevas I also switched the SIM cards to test if it depends on what SIM card is in which slot. But it doesn’t. I set SMS to SIM2 and again after reboot it was switched to SIM1.

I’ll look into this. I have removed some brightness properties from the overlay. Maybe too many :slight_smile:



Hi all,

Xprivacy doesn’t work like it should work. After installation I get the following text:

‘An internal check failed, do you want to send support info?’

Xposed gives me the following text: ‘could not load available zip files. pull down to try again.’

I tried to find out what could be the solution via and, but I really don’t understand it so I don’t know if there is the solution for my problem.

I thought the problem might be solved through a new installation of xposed, because Xposed installer (v3.1.1) gives me the following text: ‘could not load available zip files. pull down to try again.’

I installed the xposed framework (sdk 25 by Purify) again which didn’t help.
After that I did a reboot in Xposed installer. That didn’t work. I did a soft reboot. That didn’t work out either.

After that I made a factory reset, installed lineage again, installed xposed again and finally xprivacy (v3.6.19).

Could it be that Xposed Installer doesn’t support sdk25 right now? Is it a bug in Xprivacy? Or is it more probable that there is another problem which needs to be fixed?

Edit 19 08 2017: I installed x-privacy some time ago again to check what kind of permissions user and system apps do have besides the permissions Privacy Guard shows. I get the same message ‘An internal check failed…’, but It seems to be working fine.

  • There is no official XPosed for sdk25 for now. So neither the XPosed Installer nor XPrivacy “support” sdk25.
  • It was never a good idea to install XPosed on Cyanogenmod/Lineage OS. The Cyanogen Bugtracker didn’t accept bugs from devices with XPosed.
  • In my opinion there is no need to have XPosed/Xprivacy with Lineage. It supports everything I need. Which features are missing for you?
  • XPosed was always a crutch. It’s far better (also for security) to live without. I used XPosed with FPOS because there were so many advantages, but I don’t see any reason to install it over Lineage.
  • XPosed is very deeply integrated into the OS. I don’t trust a random developer from the internet, this unofficial version wouldn’t be an option for me (if I wanted to install it).


I had my doubts about that too. I wanted to use it, because of all kind of (personal) information apps can send ‘home’ and (sell it) to third (advertising) parties.

So, you just use Privacy Guard? Or do you use other privacy apps like Netguard / Net monitor, and/or a firewall (something like Afwall+)?

Edit: It’s a pity (?) that FPOS did not support App Ops in the end as one can read in this thesis of Maarten Derks ‘Fair Privacy: Improving Usability of the Android Permission System’

AFWall+ and the integrated privacy options in Lineage OS.

@retsifp ok, so you don’t need to flash Xposed to be able to use Afwall+… :slight_smile:

Yes. Afwall+ is available on F-Droid.

I used NetGuard* before switching to LineageOS. I now use the built in method for revoking wifi/mobile data permissions per app. Those options are under Data usage section, inside app’s screen in system settings. You usually can go there by tapping and holding an app’s icon on your launcher and swiping or selecting App info or similar (depends on the launcher you use).

In my opinion this integrated option is better (it’s integrated, after all, not a third party app which is unloaded on first steps of the boot process), but honestly it lacks a control panel to manage bulk app’s network state, similar to NetGuard’s. That brings a question for developers: would it be possible to make a third party app which list them, similar to Disable manager? (i.e. is this information exposed by an internal API an app could consult?)

*= F-Droid version, I don’t trust M66B because of his unfair statements about F-Droid and reproducible builds (F-Droid together with Guardian Project are the only organizations pushing repro builds on Android), because of his embracing of Google Play Services (talking about privacy with that gobble around?), and because no project match with open source methodology without an open “issues” mechanism.


I just moved from FP Open to Lineage and it works great. I have two questions so far:

  • I notice the proximity sensor drains battery bug is back. The moment I install / activate WaveUp there is a wakelock draining the battery. I used the modem files suggested in the installation instructions.
  • Is there a way to get a dark theme ? Many apps allow selecting a dark theme, but many - including Lineage itself don’t.
1 Like

I also moved from FP Open to LOS this weekend… I had some problems restoring from TiBu, it did not want to reliably install the apps. With a bit of manual work I’m now all set.
Looks good so far; I’m missing a few tweaks, but the rest looks good. No “new” bugs found except those already reported.
Do we have a bug tracker?


Has anyone had any problems with random reboots?

I’ve been using LOS for a while now but tends to reboot in the early hours of the morning and sometimes in the day. I am using the latest update (using OTA), encrypted phone and OpenGAPPs installed.

I am very glad to tell you, that I also moved from Fairphone open OS (Android 5.1) to Lineage OS. It went quite smooth, but something to do now to get it running as it has done before!
The first question: How do i get an usb cable contact to my Windows0 PC as I have had it before? At the explorer I still see the FP2, but no drives, no folders. So I can’t copy anything between pc and phone.

1 Like

Swipe from the top and tap for more USB options. Select transfer files.

More info: