Using LineageOS on the FP2

I had no random reboot since I installed LineageOS. On OpenOS I had time-to-time a reboot due to a buggy app, now on LineageOS this same app is still crashing but without forcing the OS to reboot! :grin:

The only known bug annoying for me is the loose of Data connection sometimes (usually after moving from a wifi connection), but usually switching flight mode ON and OFF again solve the problem…

1 Like

Thanks a lot; yes, I have read this before, but forgotten!

Using the same configuration and I don’t have the reboots.

Did you also experience this on FPOS / FPOOS? If yes: maybe it’s a hardware thing?

I think I had reboots on FPOOS as well but not as frequent. I’m guessing it’s a hardware thing then, the screen has also been playing up so might need to get a replacement for the second time.

I didn’t have a single reboot since I’m on LOS, but I didn’t have many before. ~1 per week.

Looks like that the SIM2 SMS bug will be fixed \o/


Network connectivity problem:
For the last few days I had an eye on network connectivity because apparently I was not reachable at times when I was at home, which didn’t usually happen before.

Turns out, indoor connectivity is considerably worse with my LineageOS installation than it was with Fairphone Open OS.
In my place it’s switching back and forth between no signal and mostly weak 2G when it was totally stable 2G before and Edge at the windows. In another place where I can compare, it now ranges from no signal up to Edge when it was stable Edge before and stable 4G at the windows.

I didn’t recognize such differences outdoors.

Did anybody else experience this?
Since the modem files should be the same, what else can be the cause of this? Is there something I could tweak to fix this?
If I don’t get this fixed, I have to go back to Fairphone Open OS (at least for confirming this). Don’t wanna :frowning:

1 Like

Let me know when it’s fixed, then I’ll start a new build.

1 Like

Perhaps it’s a good idea to compare the -dBm and ASU signal strengh of both OSes at the telephone status page. If there are noticable differences probably it has something to do with the RIL implementation on Lineage OS side.

1 Like

Can you get /proc/last_kmsg ?


But there are still two problems:

A) I can’t run “Titanium”. The app says ‘device is’nt rooted’ (Der Root-ZUgriff wurde leider verweigert!..Dieser Versuch wurde mit dem >>/system/bin/su<<-Befehl durchgeführt.)
But I have rooted the device in settings. I installed an app called “Root Checker” and it says as well, that the rom is rooted.


B) Over night I switched the phone off. In the morning after switching on it says:
‘SD-card from SanDisk corrupted’ and I shall format it But I didn’t have this problem yesterday. Do I really have to format the SD card??? Does this issue happen to other LOS users?
At the Windows explorer now I can see only the internal memory and no SD card anymore.

Problem A) solved: ‘BusyBox’ wasn’t running properly, installed it anew.

Hopefully I have solved this problem as well with running the ‘SD Maid’ app, but without formatting the SD! Now I do see my SD card again und hope, it will stay. But still I don’t know, wy I did run into that issue.

Yes, managed to get it! :muscle:

I’m not great with adb stuff but here is the txt file

I hope it makes some sort of sense, thanks!

I have no microphone input on Skype and Skype for Business (Lync) ? Video / Camera and incoming audio works. The microphone works fine all other apps, so it is no hardware problem. I tried to disable privacy guard, but did not help.

I ran into the same issue. Voice and video calls in Whatsapp work fine.

I upgraded to 31/7 version, but I’m having a few issues.

  • After a while the screen is all black when I’m calling. I notice it happens mostly after I haven’t used the phone for a long time.
  • I’m using the Do Not Disturb function with a schedule. Somehow the phone turns itself to DNB while the schedule is already over. I have to manually switch it back. In the evening it works according the schedule, but again in the morning when the schedule should be finished, it stays on DNB.

Hope you guys have a solution. Thanks!

I tried WhatsApp, microphone works but it seems to record only at a very low level. Partner says I’m extremely quiet…

Anyone knows if there is an official bug tracker for this Lineage OS port ?

I just found this:

I wonder how long it will take for the mentioned “nightly patch” to make it into our FP2 port. Hopefully not too long.