Using LineageOS on the FP2

I’m not shure if this is the right change, but it looks like the one the reddit guys talking from.
Sadly its only merged for a samsung device tree, though.

It should not be complicated to integrate it into other builds (like the one we use). I had a look at the patch and its just 7 lines of code in an XML-file that very likely will make us happy.
I posted the link in the “Porting Lineage OS” category.

1 Like

Acutally doing some more research and fiddling as root in Termux on my FP2 I found out that the file sits on FPs at /system/etc/mixer_paths.xml
I don’t mind editing system files (over 20 years Linux experience…), will probably give it a try soon.
OK, “soon” was now and the patch works on the FP2. Here is my modified mixer_paths.xml that gives the microphone back on Skype:
mixer_paths.xml.pdf (47.8 KB)
ATTENTION: If you dare to upload or change the file on YOUR FP2, you do it at your own risk!


I will try this and if it works for me, add it. Thanks a lot for finding this!



I use the Do Not Disturb schedule as well (workday and nights separately), but seems to be working fine for me.
Maybe it’s some specific setting you are using that is causing this.

On my device it did work, after I deleted downloaded updates (both done with this updater) before.

1 Like

Yup, the update function works if you are on every build except 20170730.

I’ve started a new build with the mixer commit for Skype for business in there. See progress here. Will be available in a couple of hours.

1 Like

Now I have it for three days at my Fp2 and I am pleased very much!!!
The Installation went smooth without reboots until now. No adjustments of apps, no high prosessor temperatures.
None. I have had some before with open Android 5.1, may be one in a week, but that’s much to much if you want to get waked reliably in the morning. Lets see, what comes in future?
When I set up my phone with downloading, installing and configuring apps the battery went down continuously although the device was connected to the charger.
Last night I measured 3% of energy loss within 7 houres from 82% to 79%, with WiFi on, no flight mode and “Greenify” installed.

Off course without charging and using it in that time. That would mean, it stays for more than a week, incredibly!
All apps I tried do work properly (didn’t try all! in that short period!).

Fantastic work with the big chance,that it goes on in that way! A huge step to a much wanted software longevity!
I compare it to my Nokia C7, which I had to give up after 8 years because of missing software updates. The hardwaew still is working!


So I went back to Fairphone Open OS.
I can hereby confirm that for my phone indoor network reception is much better with Fairphone Open OS than it is with LineageOS.

Having a look at it much more often I noticed that indeed I occasionally get no signal in Fairphone Open OS, too, but somehow whenever I see that, reception is being restored right away, so I didn’t notice that until now.
So Fairphone Open OS does something different there with the same modem files.

Theoretical question is: Is this an Android 7 thing or a LineageOS thing?
Practically I have no other choice than to stay with Fairphone Open OS now as long as I find no tweak for this.

Can you be more specific on the issue:
Which build are you on? What are settings you are using (screenshots)? What is the expected behavior and what is the faulty behavior you are seeing? Did you see it working in a earlier stage / build?

OTA has nothing to do with it, this is just a delivery method of the updates. If we can track where this goes wrong we can fix the code and push a new version through OTA.
Btw: I use wifi triggers to switch to a silent profile for work and during workdays my phone switches to DND (priority) every workday at 22:00 until 8:30 (or alarm) without any issues on build 20170731.

I also have the impression mobile network rescription is somewhat worse. I’m on the modem from 17.07.6. Have been riding in train and had more drops and no mobile data than on fpoos
Also, at home I’m using 5HHz WiFi. It readily disconnects and immediately reconnects. This did not happen on fpoos


1 Like

That’s interesting.
I’m going the same way by train quite often and of course I had a look at the reception along the way when I exactly know where gaps without reception and areas with 4G are … and reception was totally comparable there, I only have problems indoors.
And I don’t have problems with WiFi (5GHz) at all.
Strange things happen in Android :slight_smile:

1 Like

Yeah. It’s software and hardware after all, totally reproducible :joy:
I have one of the first fp2’s, maybe there’s some hardware difference (#4429)

Hey everyone,
I just ran into a question in the data security settings. What is the difference betwenn the opened lock and the locked lock? I tested it with “open camera” and disabled the camera usage for this app. Both times with an opened lock and a locked lock I couldn’t use the camera with “open camera”.

This time the update didn’t work on my FP2 /with installed update 20170731 on it). I tried three times, it stoppt each time after having done the update and doing something with it. No error message. Will tray it again with the coming one with security updates.

Edit: @Charley_P It worked afer having rebooted, thanks!!!

For me rebooting the phone and then doing the ota update did the job every time. Worth trying it.

1 Like

Switched to, with latest modem files (, just now:

  • DualSIM works, but I am not able to disable/enable sim slots. The switches are missing.
  • Everything else works so far wonderful.

Thank you guys so much.

Stupid question maybe, but how do I lower the volume of calls?
(so not the ringer, but the voice of the caller after I answer the phone)

During a call it appears I can lower the volume as it shows a lowering volume bar, but there is no noticable reduction in volume. It’s quite annoying as it’s too loud to the level that other people in the room can hear the person calling me.
I also tried the Sounds setting page, but there I only see ringer and notification sounds, not the sound of a call itself.

you can not do it. it is a bug/problem that I face too. It does not have anything to do with Lineage. It is a problem that some do experience ever since the upgrade from 5.1. Fairphone said that they are investigating the issue and would rectify it in a future update. So far, the problem has not been fixed.
May be, it is a hardware issue? i doubt it. But let us wait for Fairphone to fix this issue. And when they have done so, we could then flash the latest modem File zip (with the issue fixed). This is what I am hoping for and waiting for…a long time…


This one is merged now!