Low charging current under Lineage?

Meanwhile I have measured the charing currant under Lineage 14.1 and it seems to be only half as much as under the open Android 5.1 OS:
I measured with a small meter, you can put between the charger and the phone, it measures currant and voltage alternately. The results:
On desktop USB (Dell Laptop): 0,25 A, 463 mV, battery is loaded 70%,
On a stronger wall charger (EasyAcc): 0,5 A, 480 mV, battery is loaded 70%.

This means probably, that I can’t use the device under Lineage for navigation, which needs a energy input at least as strong as the power needed for GPS, screen and navigation.

The energy input under Android 5.1 was nearly twice as much, if I remember correctly. Does anybody else experience something like that as well? Is it possible, to influence the power reception under Lineage by different settings somewhere?

This afternoon I will do a test run with the Lineage FP2 running on the “Forumslader” (a specal charger for hub dynamos with buffer battery) at a bikes hub dynamo. I will report.

I don’t have a meter to check. So I used an app for this (AccuBattery):
On a Qi Charger: 550mA, battery is loaded 70%
In the hotel with their wall charger: 1000mA, batter is loaded 45%
With my Power Bank (from xiaomi): 1250mA, batter is loaded 80%

I am on the newest Linage OS version available.

So this seems to me absolutely normal.

Yes, it looks like normal. Also the test I did with my bike charger meanwhile:
I have driven 30 km with an average speed of 25 km/h, just to see how much the charger gives:
15 km/h = 3,5 W
20 km/h = 5 W
25 km/h = 7 W
30 km/h = 9,5 W
45 km/h = 8 W
It doesn’t make sense for harvesting energy to go quicker than 30 km/h; the output drops if you go faster!
When I started my test run, my phone battery was at 99%, it was loaded very quick by the chargers battery, which started at 52%. After the run the phone showed 100% and the charger battery 71%.
My hub dynamo is a “SON”, but the output should be very similar with an usual Shimano hub.
I did a second test with running the OSMand navigation over 20 km with the same average speed. At this test the phone battery dropped a little to 98% and the charger battery rose on 74%.
Conclusion: The “Forumslader” charger* works quite well in combination with the FP2 (with Lineage OS). If you don’t go to slow, you never will get into energy trouble! I didn’t test it with other OSes.
*I have got the newest one with bluetooth version V2.1 BLE.
Some further results: To protect the phone from rain and to have a storage for the charger I have put it into a bag with a transparent plastic window on top of the handlebar. This window made it difficult to recognize the phones screen because of reflections of the light sky, and the phone got hot because of missing ventilation. So I will cut some holes, but what to do against the reflections?

I tried the app as well, just to find out: The currant shown at the app is about 30% less than at the meter. Something quite imprecise, unreliable!
In German we have a play on words for such results: “Wer mißt, mißt Mist” = “All what you get with measuring is muck”.

1 Like

I am using the m kernel for lineage and also the power.xml from stock, so I don’t know why the device would charge less.

Have you tried to use your charge meter with official fp M ROM to get an official result on M?


Some (most?) phones, such as my Nexus 5x¹, charge much slower when the screen is on.

Nexus 5x oem charger puts a maximum of 3000 mA current, but when screen is on and using Ampere app to check charge current, it drops below 500 mA in few seconds.

Same thing probably happens on this Google Pixel vs. OnePlus car charging advertisement video.

¹ Gave up on my Fairphone 1 six months ago :cold_sweat:

No, I switched from the last Lollypop FP OOS to Lineage. But I really don’t know, whether my low-cost V/A meter works reliably.

I am experiencing the same problem - and not only on my FP2. My Galaxy Tab S2 tablet that runs on Lineage 14.1 as well is not charging fast even with an “intelligent” charger and the main OS not running.

Just contributing my values from the latest lineageOS build :slight_smile:

It’s varying between 0.5 and 1 ampere.


With the BatteryBot Pro from the f-droid store you can see charging current (in mA). For that you have to enable Current (mA) hack option.

Tested with 14.1-20171205-NIGHTLY-FP2.

My charger charges with a current between 1A and 1.3A.


This topic was automatically closed after 183 days. New replies are no longer allowed.