Using LineageOS on the FP2

I thought I solved my problem, but it is still existing. When I make a call the screen goes black and it is not responding anymore. I tried all the modem firmware and using build 08/03 now. The first time when it reboots it works fine. But after some time, the problems happens. I cannot pinpoint exactly when it happens. Anybody any idea what can be the problem?

Anybody else has problems with FasterGPS? It tries to read /data/local/RootToolsMounts and gets a SELinux denial:
08-05 15:47:37.963 27308 27308 W org.fastergps: type=1400 audit(0.0:1578): avc: denied { read } for name=“RootToolsMounts” dev=“dm-0” ino=1635203 scontext=u:r:untrusted_app:s0:c5
The file itself is u:object_r:system_data_file:s0 /data/local/RootToolsMounts and contains basically the mount tab

At first for the non German speaking forum members: This question is about “Privacy Guard”
“Privacy Guard” is a feature that controls how apps access specific hardware or software phone features. Tap and hold your finger on one of the listed apps and a detailed list of permissions and how they are handled pops up. Usually you can choose between “allow”, “always ask” and “ignored”. The padlock symbol beside the apps listed under “Datenschutz / Privacy Guard” enables / disables Privacy Guard in general for the app.

I had this problem before with fairphone open os and in my case it was a problem with the proximity sensor. I solved it using the proximity sensor calibration app. For a while as a workaround I used a setting to hang up a phone call using the power/screen lock button. Hope that helps.

1 Like

Thanks, that is the problem. My sensor seems to work fine when I test it. Sometimes it stays on, rebooting solves this. Is there a bug with the firmware?

– update
I just cleaned the whole phone and did a new calibration of the proximity sensor. It’s been working fine for now. Will see what happens after 1/2 days.

– update 2
Working for 1 day now, its fixed by recalibration and clean the phone physically

How do I disable any app in Lineage OS ? I notice that when I go to “Settings / Apps”, that the “Disable” button is only visible for very few apps. With older Android versions I was able to disable almost any app.

I can still disable most apps. Only apps like fused location and fm radio can’t be disabled, but they never could be.

Can you tell me how you disable apps ? Maybe I am wrong, but I open the settings, choose “Apps” and when I touch a listing the “App info” screen pops up. I am used to see a “disable” button there, but since I am using Lineage OS, most Apps only show two buttons: “Uninstall” and “Force Stop”.

If the app shows uninstall instead of disable, than it’s a user app. Disabling is a function only necessary for system apps because they can’t be uninstalled.


Not sure if this is the right post thread but I just wanted to thank everyone involved for the great work with lineage os! ITS AWESOME! Finally I got the phone I wanted from the start! :smiley:


I’m using LOS for about two weeks now, and it’s great. No xprivacy/xposed, which leads to more scrutiny before installing an app, but otherwise everything is fine (for me)
I noticed better battery behavior, maybe because nougat it’s better than marshmallow, maybe because LOS is better than FPOOS. at least i could see that with LOS up to three cores were switched off, while otherwise this were only two



I have just receive my fairphone.

When i try to flash twrp and restart in recovery mode, i have a blue screen.
I have try fastboot, twrp in root mode… same result.
If I flash system witz LOS, same screen.

Do you have any idea ?


You are not alone!

Dear all,

I am interested in trying LOS. However, a technical question, do I have to install OpenGAPPS to have WhatsApp? Also, when installing OpenGAPPS, can I chose to install only the ones I am interested in (say, PlayStore), or is it installing the whole bunch of them?
I tried Ubuntu touch a few month ago, and found it good enough, but too limited in term of app repertoire (I was mainly missing WhatsApp actually).

I can’t say anything about WhatsApp requirements, since I don’t use it.

Concerning Open GApps: There are different packages for different amounts of Google Apps.
Just go to and choose your desired package, there are explanations right beside the package name, e.g. the “pico” package is explained as “The bare minimum to get Google Play functionality”.
Here’s a comparison of what the packages install.


OK, that’s great thanks a lot! that’s the kind of info I was looking for.

I think whatsapp does not need gapps. You can download the apk-file from the whatsapp website. If you want to get live notifications when they are sent to you, you need to have google services otherwise you can set a time interval that whatsapp does a polling request an checks for example every 5 minutes if you got a message (same as for threema without google).


I had a look at the procedure to install LOS, but I have to say, I am a bit lost and don’t have enough confidence to take the jump. Coming back from Ubuntu touch was already kind of a hassle last time for me. I just hope Fairphone will officially support LOS and come with a simple way to install it (like the magic device tool for Ubuntu Touch) if that’s possible.

I experience a strange effect after two or three days uptime: even with normal usage the phone gets hot and eats battery. I checked cpu frequency and saw that the frequency runs constantly at 2GHz (switching off of correct does work, though)… After a reboot everything is normal again, and the phone runs at lower frequencies most of the time. Does anybody else see this?
(Switched the profile to “efficient”)

Another thing i noticed: in notification settings, advanced, i have the possibility to define a special pulse setting for led notifications per app. I looks like this doesn’t work yet (like LED while charging, but this is known)