Using LineageOS on the FP2

My experience so far:
I have now been using Lineage OS for more than 4 weeks at a stretch ever since I got my display. I am very happy with the OS…

The only things not working for me:

  1. Very loud In-Call volume on the lowest setting (not Lineage related)
  2. Very fast battery drain (only after the latest update, the settings show normal usuage, no particular app using too much battery)
  3. Wi-Fi and LTE have an x sign most of the times, but they still work.
  4. Crazy, hypersensitive touch screen and proximity sensor (also only after the latest update)

Thanks again to the community for making it possible to have an awesome OS on the FP2!


Maybe you could try a few days without gapps installed. I have not such a battery drain.
I have lineageos, f-droid priv and microg flashed. Not much background trouble.
And I have wifi and bluetooth always enabled. I feel, the google services take a lot of
I don’t want to pull you into google-free, it always depends on what you want to do with
your device. I have all my usecases complied. And I call myself a power user.

1 Like

No battery drain with newest Lineageos on my side either. But without Google stuff.

Everything works as far as my demands go.

When the LED notifications (charging state etc.) get fixed next I’ll be totally happy with it.


Thanks mase. I have never had gapps on my FP2 ever since Fairphone Open was released about 1 year and 3 months back. Prior to that I had disabled google services. So, that could not be the case.
I also use the Energy Saving profile under batterie. Wi-Fi is always off when I leave my house. And still, my FP2 lasts half a day. As I said, this is only since the latest update…

Try leaving the battery out for 5 minutes to reset the battery stats and clean your (dalvic) cache through TWRP. Maybe this will help.

Thanks. I did that. Very minor improvement. :frowning:

After the last update the WLAN-search was reactivated. After disabling it (Settings -> Location -> Menu -> Search -> Disable WLAN-Search) my battery drain isn’t that high anymore.

The start post is quite dated as most issues described there are fixed in the OTA release.
Can you update it?

1 Like

Well I don’t think it’s a good idea to maintain two posts/wikis that both list the same stuff, so I edited the post to make it more clear where to look for an updated list of issues. :slight_smile:


Weather provider or settings problem:
When I installed the older build from here I had it quickly configured so that the lock screen displayed the current weather of my user-defined location. I thought that was quite neat.
Now that I’m on the newer OTA build from here, I somehow fail to recreate that.

I once again installed the OpenWeatherMap weather provider for LineageOS, I once again added that to the clock’s Widget settings, I once again added my API key for OpenWeatherMap, waited for it to be verified, and now I’m stuck with a problem:

I can’t enter a user-defined location anymore in the Widget settings.
Everything I enter there almost immediately throws a generic “location could not be determined” (if that is the English localization) message, the same that you get in map Apps still having to fixate your location.
With the older build, when I entered a city, I would be given a choice of locations if there were more than one places matching my input.

Has anybody got anything like this working with the OTA build?

Edit: Never mind, I uninstalled the weather provider, installed it again, and now it works :+1:

Just a quick message: yesterday I did a travel by car with OsmAnd~ navigation and it was a pleasure! The experience was awful in FP Open, with reboots, overheats and incorrect compass. Thank you all for the awesome work, :blush:


Hi all,

three hours ago I started encrypting my phone. It said it would take more or less 1 hour. Now it seems to start up again and again. Is this part of the normal process and should I wait some time more or should I break up the process of encrypting?

tnx :slight_smile:

No, this is not normal. Which LineageOS build did you install?
I first tried encryption with the build linked to at the beginning of the Porting thread and ran into a bootloop.
Next time I installed the newer build from the OTA thread and encryption went fine.

@AnotherElk ok, tnx! I think I have the same build as you started with. What should I do now? Can I just pull the plug and shut down the phone and install the newer build later on?

Here’s what I did then:
Force-shutdown the phone (very long press Power).
Boot into TWRP, wipe everything, format data.
Install the other LineageOS build.
Immediately encrypt the phone, it will not take long since data is almost empty at this point :slight_smile:.
Edit: Check whether encryption works by rebooting into TWRP, it should prompt for the encryption password and decrypt data with it.
Edit: Boot into LineageOS, restore my data from backup.

1 Like

@AnotherElk. Tnx a lot :slight_smile: again! I got the threadfile. Now adroidfilehost advises me to check the md5. Where should I find that number? I can’t find it… Also, the file is actually 15MB bigger then it should be according to androidfilehost. Is this something to worry about?

Not because of MD5, but because I think you should follow the instructions of the “When coming from any other OS” section of this post :wink: :

The one thing I find hosted on androidfilehost is the older build that gave me (and probably you) trouble with encryption, so that doesn’t sound helpful.

@AnotherElk. You’re right :-). My phone is in a loop again. So, if I get it, I should get this build: and not v14.1.3?

Why should I actually follow the “When coming form any other OS” section? I thought in my case I have to follow the version “when coming from @chrmhoffman’s build”.

tnx again!


If you completely wiped your phone and formatted data (like you should do just to be safe after an incomplete or otherwise broken encryption attempt), you’re not coming from any build :wink: .

1 Like

Hey folks, I tried to do the “LineageOS 14.1 with OTA updates for FP2” and then followed the instructions from “When coming from any other OS”. I got stuck at the fastboot method. When I type
“adb reboot bootloader” in terminal and then press enter I get the following text: “-bash: adb: command not found”. What to do?