Using LineageOS on the FP2

True! That also confused me! I changed my post above a little (deleted “MicroG”).
MicroG is more for functionality of Push-messages using the google push service - If I am correct - and needs some more configuration under LineageOS to get it running…

@darioce You wrote in May about the SD card problem in Noutag/LineageOS.
Could you give a little bit more details (or links), how you gained write access over your external SD card for alle apps under LineageOS14.1@FP2
As I have of couse the same, by google intended problems / limiations, I would be happy to have a practical solution, which I didn’t found until now…

That was quite a while ago…:sweat:

Make sure you try the following in this order:

  1. Allow the app to ‘Access Media & Photos’ in Privacy Guard (relatively obvious)

  2. Under Settings->Developer options enable Force allow apps on external
    (if you do not see Developer options, tap 7 times on the Build number in Settings->About phone (This will hopefully do the trick)

  3. Change a few lines in /system/etc/permissions/platform.xml according to this post: SD Card no writing permission in FP2
    This used to work in FPOOS 5.1 but I think it is deprecated now. (Probably neither necessary nor helpful)

I do not remember, what I did exactly, but whatever I did survived any system upgrade, so you only need to do it once :sweat_smile:

@darioce thanks for your recap…
Unfortunately I am not quite there, where I want to be, I tried all your hints with the following - negative - result:

  1. Thats clear and I checked.
  • But e.g. The App SyncMe Wireless has only read access to ext. SD Card, and in Privacy Guard no “Access Media & Photos” is available (only “Notifications”, “Keep active”, “keep in background”, “start at boot”).
    • Edit1a: For SyncMe I read, that there is a beta version, which should be granting write access to ext. SD cards (I don’t yet know, how it will do it. I E-Mailed the devs and wait for the app, as suggested here.)
    • Edit1b: The developer in deed sent me a beta-version of “SyncMe Wireless” which includes a special dialogue in settings to get SD Write acces (and also to withdraw it) and with this it works!
  • For TitaniumBackup also no “Access Media & Photos” is available there.
    • Edit2: TB can access folders, which the programm itself created using option “DocumentProvider” in “Choose folder” options dialogue of TB. Found here.
  • Just a thought: Could it be, that these (maybe outdated) Apps have problems to make a proper request to Android in its preferred way, that they want to access to the ext. SD card? So Android could not allow it explicitley because it even don’t know? And just “grabbing” the permission by breaking the Android rules seems not possible?! But I also want to be able also to use older Apps, not explicitely designed for Android7…
  • It was not activated, but also after activation and after reboot there is no change
  • Unfortunately the structure of my platform.xml seems different from Android5/6 and there is none of the <group gid="sdcard_r" /> entries mentioned there, and a lengthy explanation which I don’t understand:

[details=Details of comment in platform.xml] These are permissions that were mapped to gids but we need
to keep them here until an upgrade from L to the current
version is to be supported. These permissions are built-in
and in L were not stored in packages.xml as a result if they
are not defined here while parsing packages.xml we would
ignore these permissions being granted to apps and not
propagate the granted state. From N we are storing the
built-in permissions in packages.xml as the saved storage
is negligible (one tag with the permission) compared to
the fragility as one can remove a built-in permission which
no longer needs to be mapped to gids and break grant propagation.[/details]
<permission name="android.permission.READ_EXTERNAL_STORAGE" /> <permission name="android.permission.WRITE_EXTERNAL_STORAGE" />

So - any other ideas for granting write access to erxternal SD Cards in LineageOS14.1@FP2 for all apps??

Can anybody shortly tell me, how the update process after the release of a new weekly of LineageOS will take place? I have running now LineageOS14.1@FP2.

  • Do I need to go just to the built-in updater and perform an update?
  • Will any of my data or settings NOT survive this update?
  • I guess a backup before every weekly-update is recommend (TitaniumBackup? TWRP?)?
  • besides the very detailed changelog is there also some less technical changelog? How I can decide if an updates includes some bigger changes or only some minor under the hood?

Should work.

Should not happen apart from possible updates to the OS settings themselves.
Be safe with a backup …

I would highly recommend it. Anything can happen :slight_smile: .
Be aware that TWRP just backups the state of the OS and leaves Androids “Internal Storage” out of it (if I understood correctly, the devs can’t guarantee to get it right 100% because Android made a mess of it).
So you need additional measures for your data … here’s what I do …

  • I backup all my stuff in Internal Storage (pictures, contacts, ringtones etc.) locally with MyPhoneExplorer, because it works great and I additionally sync my contacts locally with it and it can do some more fancy stuff which might come in handy occasionally (e.g. screen mirroring or recovering contacts accidentally saved at Google to the phone) … but it is Windows only, I didn’t test it with Wine.
  • I download all relevant update files to the phone (modem, LineageOSOpenGApps for me).
  • I boot into TWRP and backup the OS state before the update so I could go back if the update somehow turned out to be no good. I transfer the backup to my PC.
  • I install the update files in TWRP, as I’m there anyway then.
  • I reboot into the OS and go through my personal list of important features and check whether they still work.

I’m not sure at the moment about backing up Apps and settings … I didn’t bother until now whether I cover this as until now it only mattered if I changed the OS or installed from scratch, if in doubt I can set all that stuff up again if needed.
MyPhoneExplorer could extract Apps and install them again (one at a time, no batch), but I don’t use that feature.
I see Titanium Backup mentioned in that context pretty often in the forum.

I don’t know. I just install every update and thus don’t need to decide :slight_smile: .


2 posts were split to a new topic: Open links in browser

A post was split to a new topic: ‘One hand mode’ in LineageOS

I’m having the same problem!
Phone is rebooting instead of powering off.

Same issue here. I turn it off, it boots up again. I remember not having this issue after reflashing several times, but can’t recreate it.

1 Like

Thank you, however the problem persists. I’ll keep on researching,but this looks like a real challenge to fix :slight_smile:

Hi, can you provide logcat and /proc/last_kmsg ? Logcat during shutdown and last kmsg after reboot?


I just did my first update from via TWRP and everything worked very well!
I can confirm that all settings survived the update process - I do not miss any setting!

And the best is: thanks to the newly incorporated FP-ProxmitySensorCalibration-Tool I can finally use my display during calling, which did not work before (stayed black, as soon as i startet a call). :+1:

Really great work!!! I hope every update will work such flewlessly!


After happily using LIneageOS14.1 (Android7) for one month, I have only some features, which I miss in comparison to FPOS (Android5) + GravityBox which I want to count in the following.
Maybe I just did not figure out how it works now… Any help is welcome.

  1. There are no data-usage arrows in WiFi and cellular/SIM symbols anymore (which I find very usefull to judge over a proper data connection)
  • I cannot customize the symbols in the extended status bar (behaviour and visibility of individual shortcut symbols).
  • I miss a possibility to easily toggle between “2G only”/“3G only” and "“2G/3G mixed” (which I sometimes used with GravityBox because of bad reception areas)
  • I miss a toggle to easily switch the “Switch off display after X minutes”. “30s/2min/keep on” would great. On Android5.1 I used it with GravityBox in StatusBarSymbol and with PowerToggles, but not possible anymore.
  • Slow reacting AdaptiveDisplayBrightness: It takes about 2-5s for a first reaction of the display to increase brightness if display is switched on in brigth sun. So waiting 5s for using FP or always keep it at max brightness is not a nice way. I would prefer: either display remembers stat of last switch off and than adapts slowly, or start always in a quite bright level and adapt slowly down if needed.
  • If I set the display brightness using the activated feature “swipe status bar” the background app is fade out (and status bar has focus) - but this makes it very difficult to adjust the brightness easily, because it is just some white symbols on black background and the app beeing acitve in background which I want to adjust is faded-out and thus darker as it will be after finishen brightness adjust.
    So I would prefer that this great feature will keep the status bar closed and app in foreground (as it was in Android5.1+GravityBox), or to open the small slider instead.
  • if I activate “do not disturb” (e.g. for 8h) in shortcut symbols in status bar, I have no possibilty to check at the status bar symbol, how long it will still be activated (workaround: pressing +/-Vol to check, but it is not a nice way).
  • if I activate “do not disturb” a second time, I have again to choose 8h by 8 clicks. It should remember at least the setting I last (and every day) used…
  • I can’t get additional time zones displayd at stock clock widget (after activating it in the clock settings). It was possible in Android5.1. But now no settings in ClockWidget.
  • Display imideately switchted off after starting a call. FIXED: in LineageOS20171121 thanks to the good FP-ProximitySensorCalibration-Tool
  • Number of last used Apps displayd in “App manager” is very limited (~5?). But maybe this is changed in lates LOS as it seems? (now I see 16, thats quite OK).
  • I can set “Vibrate when connected” but not “Vibrate when disconnected” which was possible with GravityBox. FIXED: As it seems since LOS-20171121 it works. (But I can’t find anymore the settings…)
  • After FP-Reboot I can see sometimes 3 SIM-PIN requests (instead of 2, one for each SIM), the last one comes twice and I can either type in again or just wait until it closes after some seconds… strange.
  • Initially I had some problems to grant Apps write access to the external SDCard. Then I learnd about the “DocumentProvider” of Android7 which does handle this for modern apps. But for older apps which not properly request these write rights it is sometimes not possible at all. Quite strange way google goes, I wonder why LOS also (has to?) follow(s) this path…
  • I sometimes have a #-sign in the status bar, want to warn me about usage of SuperUser rights by any app. But I would like to remove it … but without XPosed it seems not possible…
  • I do miss a feature I loved on the Fairphone OS that seems missing in Lineage: Mounting the SD card as USB Mass Storage to a computer. But I now uses “SyncMe Wireless” to sync Data (photos, apks, music) with one click via WLAN ( you have to wirte ask developer for its recent beta verision via mail
  • I miss the FP ring tone … how I get it?

… ok, thats all (at least for the moment). I will keep my list updated, if I found solutions for this.
If anybody has solution to my hiccups above, let me/us know.
I guess some of them I should report as FeatureRequest / Improvements to LOS-forum, shouldn’t I?

Cheers, Robert


2 posts were split to a new topic: UpdateProcess from FPOS/Android5 --> LineageOS14/Android7

If you still have an original FO OS (or FP Open OS) at hand you’ll find it in /system/media/audio/ringtones/Fairphone.mp3.

1 Like

Since I was coincidentally extracting some files (in my case: wallpapers) from a Fairphone binary image yesterday, I wrote a short how-to that might hopefully help:


@fai8753 @AnotherElk @max_seabrooke
Can you please tell which kind of cameras your phone has?
(old 8 MP + 2 MP — or new 12 MP + 5 MP)

There’s the assumption, that the bug only appears with the new 12 MP + 5 MP cameras. (see comment oli.sax 24 Nov. 2017 18:15)


I have the new ones, thanks!

I have the new ones.

no, i am on the official LOS, and my setting for USB debugging survived the shutdown today…


1 Like