Official LineageOS is here!

I think that the powerdrain might be fixed now.



Update to 14.1-20171031-NIGHTLY-FP2 went smooth.

No further reboots until now, but the OTA Update did’nt work:
"Das Herunterladen ist fehlgeschlagen. Bitte überprüfen Sie die Internetverbindung. I did the Update via TWRP.

I had that too. After some time, the update worked via OTA.

For me too via OTA without any problems.

  • (unchanged, not installed again)

Update installed via TWRP:


The following things work for me so far:

  • call / be called
  • send SMS / receive SMS
  • internet via WiFi
  • internet via mobile network
  • location
  • compass
  • screenshot
  • main camera (new module)
  • selfie camera (new module)
  • USB connection to PC / MTP
  • alarm (incl. swiping it off)
  • MyPhoneExplorer
  • root

Installation of isn’t mentioned on Install LineageOS on FP2. Maybe it would be good to add it there (not everyone will read this here on the forum)?

Same here! Battery life is amazing since the update today.


3 posts were split to a new topic: “x” over both wifi and 3G notification symbols

Hi everyone,

I just switched from regular fairphone OS to official lineageos.
I should also mention that my phone has a 12mp camera.

Because I had to format everything, I finished installing and then went to encrypt the data partition, just as it had been before.

However, it appears I am facing the same issue as Encrypting new FP2 fails

I tried wiping, repairing, resizing and reformatting the data partition.

As the topic does not mention the OS I assume it is also happening on regular FPOS. It would then appear to be some sort of OS-agnostic issue.

Problem : I do not have my old 8mp camera anymore.

Does anyone has any idea what the cause could be and how to fix it ?

In which cases the additional modem installation is neccessary?
I support, that it should be included in the installation instructions, if it is needed!

1 Like

jippi, it worked like a charm

1 Like


I have problems activating the SIM cards on Lineage OS, I installed

I was on FPOS 17.10.2. So I followed the guide in the lineage os wiki-page linked in the opening of this thread. I added the zip for open GApps mini.

Everything went well while installing and Lineage boots correctly. However, when trying to unlock my sim cards I get “SIM unlock operation failed”, and I cannot get them to connect. As I understood it, if I came from a recent FPOS I should not need to add new modem files, correct?

Have I missed something?

I did not root.
I’m using 2 SIM-cards


1 Like

About the fixed Wakelock: Great news & good work!!
You are talking about , right?

OK, updates:

I have tried swapping around the SIM-cards, seems that my work-SIM that was in slot 2 only works in slot 1 now… Whereas the Private-SIM works in both positions.

So the following setups:
SLOT1: Private, SLOT2: – - WORKS
SLOT1: Work, SLOT2: — - WORKS
SLOT1: Work, SLOT2: Private - WORKS
SLOT1: --, SLOT2: Private - WORKS
SLOT1: Private, SLOT2: Work - None of the SIMs work
SLOT1: Empty, SLOT2: Private - WORKS

So when I use Work-SIM in slot 2, nothing works.
Any Idea why? Since this worked in my previous setup with FPOS. I didn’t change anything regarding the SIM during the install…

Anyhow, I guess it works for now since I can use both SIMs at the same time.


Can you try to add this setting to /system/build.prop


31-10 build is really great for the battery. So far no problems here


What do I need the su arm for? If I don’t flash this, do I still have root access (I think I do, as root-apps work…)

Somebody else is experiencing erratic auto brightness behavior? Sometimes, without moving under a light, the display gets dark and won’t get brighter again… Only when i up the brightness level, it’s getting brighter again

1 Like

Reinstalled with LO official 31-10 build yesterday. No problems and its a joy to see the charging LED back. Well done :slight_smile: