Upgrading LOS for microG to 15.1 (feedback/issues)

Well so far fromme the microg forge has worked pretty well. Appart from twitter crashing while opening, and not being able to choose weather provider in the clock widget everything is ok. The twitter thing came from older versions.

But im impressed by the battery performance. Never been better before.


network standby is going through the roof… wiping cache /dalvik didn’t work this time. Bad signal means battery drain, I think :thinking:

I have the same problem now!
Made some research on the Internet and it looks like it doesn’t affect only Fairphone. Someone on a forum says that Google messed up:

There is no fix because this is not a rom issue or device issue. Its a google mess up when they built 8.0/8.1 and word is it wont be fixed till later this year. Not all devices are effected but most are. I had to go back to 14.1 because the drain was massive. Cell standby was at 68% on 15.1 but is 1% on 14.1

I have read a workaround that suggests to set preferred network in “Phone information” (dial *#*#4636#*#* / Phone information / set preferred network). Some people set it on “LTE only”, others on “LTE/WCDMA”).
Any thoughts on that?


I won’t recommend doing it unless you’re sure your area has LTE available anytime. As I rarely use mobile data and anyway my city is all covered up in LTE, I’ll try it.

Edit: making calls didn’t work with “LTE only” selected in my area. Might not be your case, though.

The drop in battery life was obvious to me. I bought recently a new battery and was having an outstanding battery life in 14.1. In 15.1, it foresees only 13 hours with 88%. And I barely used it today…

1 Like

There are some providers who provide very good LTE but their 3G connectivity is sub-licensed or otherwise terrible. In The Netherlands these are Tele 2 and T-Mobile. I don’t have either, but if I had one of these I’d try it out.

EDIT: Furthermore you might wanna set it to GSM only if you have terrible LTE reception. I’m not sure about this but I get around -95 DB on LTE only and around -65 DB on GSM only. If you want to call via LTE, your provider needs to support VoLTE. You can see if you support that in the very same menu as where you set it. BTW, use the dialer, not the contact list (bottom right on contact list).

I updated to the 27/08/2018 OTA from TWRP. Installing through the Updater didn’t work, as expected.

The 27/08 OTA can be re-installed from the Updater and it doesn’t bring an error now, which means next OTA will be installable through the Updater.


I just installed LOS for microG 15.1 from scratch via TWRP by following the instructions from LOS and the microG specific part. Went pretty smooth. Only problem I got so far is concerned with the Signal messenger. I downloaded it as apk from their website, but the dialog “Verify your number” chrashed when I hit register with my phone number. Any hints want might be wrong? I already checked the permission in privacy guard and allowed all requests from Signal.

Most probably it is detecting microG Services Core and trying to register on Gobble Cloud Messaging for push notifications. Enable them on microG and try again.

Did anyone else ever try casting their screen - either Netflix or local content playing in VLC - to a Chromecast device using LOS 15.1 for microG, without GApps? (I did, yesterday, and it didn’t work out.)

I admit it’s somewhat far-fetched to expect a Google device to join forces with a Google-free OS, but still, I’m curious.

Gobble = Google? So you mean I have to turn on “Google Cloud Messaging” in microG settings including the device registration? Thought it would be possible to use Signal without that.

Yes, my fault. That’s the word I use to refer to them.

Yes, Signal requires that. If you use a device without Gobble services, then it configures its own push notifications at registration time and works fine afterwards, but if the app detects them (and microG makes all apps think that Gobble services are available), then it requires GCM.

Edit: to be sure, this is not an issue on the microG side, but how Signal is designed to be used. Moxie Marlinspike, the lead developer, says that GCM is only used in a privacy-friendly, not traceable way. This can be verified on the source code, although I’ve not checked it personally. As I prefer not to ping Gobble servers at all (although nobody can avoid to visit other parties hosted on their servers), I would prefer an option to switch.

API Functionality Crashing Issues
Cast :x: None :x: Yes #79, Missing most APIs

Source: microG Official Wiki — Implementation Status


I also updated to the 27/08/2018 OTA from TWRP. Went fine so far!

Hey @Roboe, thanks for your fast reply and your long answer. It seems not be caused by GCM though. I turned it on in the microG settings, but Signal still crashed when I hit “Register”. Any further ideas?

PS: I agree with you in pinging Gobble as little as possible :slight_smile:

Then I think it should be caused by the new Firebase Cloud Messaging API that’s now replacing GCM. microG doesn’t support it (yet?). The bad news is that it will probably take some time for them to reverse engineering it… :confused:

Maybe an older Signal version might work? Or even today’s 27/08 update? (I installed 20/08). It seems weird to me since other users do not report this problem :confused:.

It’s a good idea. Since the registration process needs to be passed just once, no more users are suffering for this, I guess. Anyway, if you catch some logat (how to here, #los:logcat), I would be able to read what’s the exact problem is.

FYI and topic related… Bounty for Implementing FCM to microg

Edit by @Roboe: microG project needs support to migrate to new cloud messaging service


After trying around some times with different installation orders, it somehow worked out. Didn’t seem to be any specific problem though. I have the 27/08 version now with GCM enabled, but only Signal seems to use it and WhatsApp and Telegram not.

However, I always get the notification about push notifications from Telegram. Anyone knows how to get rid of those?

Apart from that the system is very fast and it was definitely worth the upgrade.

There’s an option somewhere in Telegram’s settings to switch between GCM or their own push notifications service (I can’t find it in the FOSS version available at F-Droid).
Any app that needs to have a service running all the time, like push notifications, need to show a permanent notification for it. If you prefer the Telegram push service, you could tap and hold the notification and reduce the notification “importance level” to the minimum (don’t know the English naming). That way it’s only shown when you swipe down to show the notification drawer.