Help needed!: How to install LineageOS for MicroG? (FP2)

Hello there!

I recently bought a FP2, after my FP1 finally crashed. After starting it, I was shocked, that I cannot deinstall such Apps as GMail, or google hangout, but only am able to deactivate them. Thhis did not satisfy me.

Thus, I did some research and decided, that I wabt to install LineageOS for MicroG in the first step, and later on extend it with playmaker, in order to get those play store apps, that are important to me, without google. The only problem: I have no plan, how to implement this software and failed to find a step by step instruction. (note: since the phone is totally new, I do not need the mitigation, but a new setup of the system)

What I found until now:

  1. the LineageOS for MicroG official website with FAQs, downloads and so forth
  2. The downloads - which one is the one I need? Is it one of those from the 17.12.2018? And if yes, which of those three? If it is the, do I need to unpack it on my Computer first before starting the installation?
  3. this wiki, which I should follow according to the lineage for microG-website, but which confuses me, since there is no .img data in the LineageOF for MicroG downloads, put also no .img in the unpacked //
    Thus, I do not know, which file I should later use in the installatation process.

So, those are the question, I have so fare. I used the search fuction in the forum, but was not successfull in finding any other than the instruction for the mitigation and the instruction link for installing the normal LineageOS (// ), which does not solve my problem.

Currently I am very clueless and hope to receive help here.
Thank you a lot in advance. I wish you some great coming-up-christmas-days :slight_smile:


Currently …

It’s the correct way to install.
The only difference is the file you want to install is the LineageOS for microG file, but that makes no difference for the way to install it.

Take your time, read carefully, follow one step at a time, and follow the steps exactly like they are written there. Don’t try to cut corners.

The general concept is: You first install an IMG file of the latest TWRP recovery, then you use TWRP to install a ZIP file of the LineageOS flavour of your choice.
You don’t need to extract the ZIP file on your computer or on the phone, it gets installed as is.

That’s because this install guide you already found really works, there’s nothing more easy or more clear to find.

If the details of a step give you trouble, feel free to ask.


The img file is not in the zip you downloaded, it’s the custom recovery (TWRP). There is a first step you need to follow before you flash the zip.
Follow all the procedure from the start and it will work. In point 1, there is a link called TWRP. It will let you download the img file.
Good luck!

Please be warned that LineageOS for microG (at least the latest releases - 15.1) is not as reliable as the official releases of Fairphone OS and OOS.
I myself am using LineageOS on my current device and connecting to Google services through microG might not always be successful. For example for some apps registering for push notifications. I’m currently working around these issues, because I think my freedom is worth it, but it’s not working “out of the box”. It mainly depends on the apps you are going to use.

Also you will not be able to deactivate/uninstall certain apps on LineageOS until you root your phone. Some apps cannot be deactivated at all (i.e. gallery, files, contacts) and must be uninstalled using root to get rid of them. But these apps will come back as soon as you install a LineageOS update, which appear weekly.

@ Freubert:
Uff, this sounds complicated.
I would prefere to have a google-free-version to run smoothly and reliably once it is installed.
I need not that many Apps from playstore, though, but I prefere them to run smoothly. (Signal, DB-App, Stadtrad-App, K9 for E-Mail, ACE-App, I guess that’s all, Telegram runs also without google services and is available in F-Droid)
Push notifications are not that important to me, as long as the App receives the messages once I actively open it, I am fine

Signal Messenger currently IS working on my LOS and has been successfully registered for GCM/FCM, but had issues before. You need to make sure microG is correctly configured before installing any apps depending on it. For Signal there are 2 options: Using GCM and therefor enable it in microG before your install the app or using the websocket connection, which may have an impact on your battery life.

Stadtrad and K9 are working flawlessly on my device currently. I think K9 doesn’t require any of the microG stuff. Stadtrad needs Google Maps, but that’s working fine. Didn’t install DB-App yet, because I’ve been using it only infrequently before. But there may be issues with push notifications if you rely on them.

Thanks a lot for your answer! And also you, chrisse!

I carefully went through the steps, but something with the adb and fastboot does not work. This is the manual, I worked through:
The problems, that I have faced are the following:

  1. In the chapter "Setting up adb" I faced some tricky points: 4.) Scroll down, and check the “Android debugging” entry under “Debugging”.
    -> under “debugging” there was no entry like “androis debugging”, thus I selected “USB debugging”

The only other subpoints are: Revoke USB debugging authorisations; bug report shortcut; select mock location app; enable view attribute inspection; select debugg app; verify apps over USB(which is by default switched on); Logger buffer sizes

  1. “6. On the computer, open up a terminal/command prompt and type adb devices .”
    -> output: “List of devices attached” with no device named
    This appears somewhat strange to me. The FP2 was seen by the computer & appears in the explorer, it definetely is connected. hm…

  2. “7. A dialog should show on your device, asking you to allow usb debugging. Check “always allow”, and choose “OK”.”
    -> This Dialog did not show up, only the notification: “USB debugging connected. Touch to disable USB debugging.”

  3. Could it be a problem, that I used in the installation(windows7)a personal path\adb-fastboot as target path for unpacking the adb-zip instead of%USERPROFILE%\adb-fastboot` and then for the later step:
    ;the personal path\adb-fastboot\platform-tools?

I did not understand, what was meant by %USERPROFILE% and I understood it as suggestion path

When you connect your USB cable, the default mode is “Charging only”. Switch to “File transfer (MTP)” and you’ll see the authorization pop-up :smiley:

Then depending on how much these Apps use Google services LineageOS for microG might be the wrong choice, and the combination of the official LineageOS and Open GApps might work better.

microG does its best to mimick Google, but it isn’t Google, so you can’t 100% depend on Apps which need Google, they might malfunction or break at any time Google changes something and microG needs to catch up again.

Open GApps installs the real Google stuff, but you can select how much of it you want with the different packages Open GApps offers.
For LineageOS 15.1 you would select ARM - 8.1 - (package of your choice).
Minimum to run the Play Store is the pico package.

But in any case, installing stuff needs to work first.

It isn’t strange at exactly this point, because adb devices at this point normally would cause …

If this doesn’t happen and you are sure you use adb for the first time on this computer + phone combination, then when using Windows, try to install a Universal ADB driver, e.g., or try the Minimal ADB and Fastboot Installer: .
Then try adb devices again.

If adb still doesn’t work, go to the Device manager in Windows, locate the “FP2” (should be listed under USB devices), right click it and uninstall it.
Then reboot Windows, connect the phone again and see whether Windows reports a problem when re-installing the drivers for the phone.
If not, try adb devices again.

No, that shouldn’t be a problem.
When using Windows, %USERPROFILE% just points to the directory of the respective Windows user without having to know the username.
If the user’s username would be “xyz”, then %USERPROFILE% would equal “C:\Users\xyz”.

This is a popular choice for a place the user is meant to do stuff in, because in this place the user is supposed to have all the necessary permissions on directories and files and mostly doesn’t need to do stuff as an Administrator.

No, the USB debugging authorization is different from the USB connection mode selector.
USB debugging works regardless of the USB connection mode (it works in charging mode, too).

The authorization request looks like this (generic screenshot from the internet) …

… and normally it pops up when the phone is connected via USB, and you have USB debugging enabled, and you use an adb command such as adb devices for the first time with the respective computer + phone.

1 Like

Reading that and some of your later answers: why did you decide to go for LineageOS with microG?
At first glance, the apps you mentioned later seem to indicate that you could do with plain LineageOS, without microG or opengapps. “Just” install the f-droid store and the apps it has (K9 e.g.), and for the apps you need from Google play store, install Yalp store that allows to use the play store without personalized account.

1 Like

I will keep in mind the other suggestions, e.g. open Open GApps as option, but first I am curious to try out the Lineage with MicroG and whether it works for me.

There, indeed seems to be a problem, that my computer does not recognize the fp2- drivers. This might be the problem, why the other stuff does not work. Is there a possibility to install the fp2 driver manually on the PC (windows 7)?




Did you already install this driver?

Hallo Ingo,
Hm. Yes, I did install beforehand and restarted the computer. But afterwards still received this anouncements.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.