Upgrading LOS for microG to 15.1 (feedback/issues)

If one wants to use Signal with Websockets and without the need for MicroG or GAPPS you should deactivate MicroG or remove it and install the Signal-APK from here: https://signal.org/android/apk

2 Likes

I’m not sure if it is included, but microG Services Core has received a new update some minutes ago. At least, it will fix the insistent “Google Play Services need to be updated” pop-up.

3 Likes

Thanks for that advice. It was a hustle to get it working at all, so for the time I will stay with it. I would prefer an option to choose websockets in the settings.

@Roboe: I removed the Telegram notification as you explained. Thanks a lot again!

1 Like

it does not.
dazn, nrk tv and nrk super app still ask for a GPS update :persevere:
(haven’t tried any other)

Without connecting them to the internet (because I don’t trust closed-source apps), they have not thrown any pop-up to me. Apps usually throw it at opening, so I can’t reproduce your issue. Could you make sure your microG Services Core are updated to 0.2.5.12879?

I wasn’t. I am now, and it’s working now.
sorry for that. I thought F-Droid would download AND install, which it does usually, but somehow not this time.
Thank you!

2 Likes

That’s because Marvin (the main developer) is not releasing updates as stable. It’s simply not possible to launch stable releases for reverse engineering projects whose sands are constantly changing. And due to these sands changing (i.e. breaking apps), anyway people need to update for compatibility, :man_shrugging:

3 Likes

I experienced two quite high battery drops today. Then suddenly without charging (!!) Battery went up again from 14% to 35%… Did anyone else experience this? Is this a result of a 2 1/2 year old battery? Quite interesting I think :slight_smile:

Possibly.
Warranty on the batteries is 1 year.

1 Like

Hi all!

I’ve just upgraded my FP2 from LOS14.1 microG fork to LOS15.1 microG fork.
All seems working except apps installing. The system refuses to install any app, or update, from any position.
From Files app I can’t see FP2 root, only sdcard, documents, downloads exc… On LOS14.1 I could see also FP2 root. I don’t know if this issue is related with the installation problem.

Any idea?

Thank you very much!

Matteo

Open the menu → “Show Internal Storage”

1 Like

Hello Matteo,

do you using Magisc?
There is a error with Magisc that causes that problem.
The LOS Roor zip works well for me.

1 Like

Update went fine!
Download from the updater; installation launched from the updater too. Automatic reboot in recovery. I had nothing to do!

Same here, updater did it’s job. And the annoying ‘update google services’ is gone!

Yes I use Magisk.
So I have to uninstall Magisk and not use it forever and ever??
What if I wipe all? Data, cache, storage?
And then make a clean install?

Not for me… I still have that message…

You are right…
I don’t know why I didn’t see it before…
Thank you very much!

1 Like

Hello Matteo,

I have already tried a clean install.
I have posted earlier in this thread, what’s probably wrong here.
I don’t know if it’s on magisc or los side.

I’m just trying the LOS 15.1 for microG and i’m new with it.
Are there any experiences with Threema? Until now it didnt make a registration in the microG options and when i want to set back the Push-Token it doesnt work.

Edit: The problem is known since 6 months. https://github.com/microg/android_packages_apps_GmsCore/issues/509

I installed it from the site you linked but it only works with microG enabled. Otherwise it crashes. LOS 15.1 for microG 20180903.

That is strange, did you try to import an old Signal backup or something?