English

Updating LineageOS 16.0 for microG via TWRP + feature test

Tags: #<Tag:0x00007f05e6ba37c0>

Ok, thank you very much for your answer!

3 Likes

https://forum.xda-developers.com/android/software/lineageos-microg-t3700997/post79654770

“Build server is online again!”


https://forum.xda-developers.com/android/software/lineageos-microg-t3700997/post79657676

“We build in the order specified in https://github.com/LineageOS/hudson/…-build-targets

… Right now the most current build from today is for d801 … 8 nightly devices to go until building FP2, if I read that right.

3 Likes

Find7 is done, too. So FP2 should be next :grin:

via Updater, I get an installation error…
does that happen to anyone else, too?

I never use the Updater.

Installed it now manually.
If I remember correctly there was a problem with the updater in the beginning but should be solved with this update…

Hi.
Update showed up in the updater app. I have downloaded it and tried to install it, but got an error, just like you.
So I restarted the phone in recovery and installed it manually (data/LineageOS updates). Everything seems to work so far.

2 Likes

I did the updgrade to last version of LOS16+microg:
microg version 0.2.7.17455
LOS version:

When I check the Self-check version of the microG Setting im missing the 2nd and 3rd check box of the signature spoofing, also the "play Service (GmsCore) has correct signature and the first one of the UnifiedNIp.

Is this happening to someone else or is something wrong with my installation?

I updated via updater and get an error.
Then I tried to install it manually just like @chrisse and I’m stucked in a boot loop now… :sob:

Solved.
Although I’m a little confused…
Form TWRP I wipe:

  • Dalvik / ART Cache
  • System
  • Cache
  • Data
  • Internal Storage

then I flash the lineageOS-16.0-20190604…zip and reboot and I find my system as I left it before the bootloop (more or less).
So I’m a little puzzled because I thought that wiping all I wiped there would be no app and no data surviving… Am I wrong?

do you have a link for lenage micro g 16?

Here: https://download.lineage.microg.org/FP2/

1 Like

Update Installed via TWRP 3.3.1-0 (Releases), which seems to have trouble with encryption in general.
But custom TWRP 3.2.3 couldn’t install the new modem.zip.

The following things work for me so far:

  • call / be called
  • send SMS / receive SMS
  • internet via WiFi
  • internet via mobile network
  • location
  • compass
  • screenshot
  • main camera (new module) works correctly with Open Camera, stock camera App not checked, didn’t operate the flash correctly last time I checked.
  • main camera (new module) video recording
  • selfie camera (new module)
  • selfie camera (new module) video recording with stock camera App not checked, worked correctly last time I checked, Open Camera records only black if surrounding light is too dark or changes into too dark while you move.
  • USB connection to PC / MTP
  • alarm (no alarm sounding with volume set too low.)
  • MyPhoneExplorer 1.8.11
  • Root access (Settings - System - Advanced - Developer options - Root access)
  • USB OTG
  • WiFi hotspot
  • Bluetooth (data connection, music playback … pairings survived the update)
  • FM radio
  • weather (Yorecast with my own OpenWeatherMap API Key, Weather Widget)

For reporting bugs see the bottom of this page.

1 Like

A post was merged into an existing topic: Lineage-16.0 (Android Pie) Nightly

hey guys, I might try /e/ . therefor I would like to know whether microg is part of the data partition that I backup with TWRP? Or are there just apps? Would like to try a clean install of /e/ but recover data partition. you think that could work?

hey everyone,

I’m still runnung LO" 16+microg. Latest version from yesterday. I have the following issue. I would like to use the App “Jelbi” (A Trafi-version for Berlin) which was released a week ago. However in yalp and aurora store I cannot find the app. When I login my google-account (on my laptop) playstore shows me that the app is not compatible with “FP2”.
I tried to install the app manually with a apk. However after I get the message to allow for location services the app crashes…

Any ideas what to do? On facebook another user told me with LOS16+Gapps the app works without problem. Seems to be a Microg issue??

Google Maps installed via Aurora Store is affected by the same issue. If maps tries to access location service the app does crash immediately. I don’t know if it is an issue by microg itself or due to the missing tts module. Osmand for example does not crash but can’t talk.

Oh well… so probably jelby requires GoogleMaps and this leads to a crash…

Still strange, because I have other apps (Telegram, DBnavigator) that also normally work with maps but do not crash…

I have the same problem (apps crashing) with runtastic and waze. Installing GoogleMaps doesn’t seems to be useful in my case.

Any suggestions?