English

Lineage OS 16.0 issues and questions

No problem with Lineage OS 16 for me. But I’m missing the possibility to access the camera and the Contacts app from the landing screen (before unlocking the screen).

Any hint?

How to get back the Camera and Contacts apps access from the landing page (before unlocking the screen)? On Lineage OS 16

Settings - Security & location - Lock screen preferences - Change shortcuts

2 Likes

I experiment a very strange issue : everything work well except the “authentification” via all applications.
Examples :

  • k9-mail tell my my password is not correct
  • yalp : same issue with my Google Account credentials
  • DAVx5 : same with my Nextcloud credentials

I have rechecked several times for good credentials and there are correct.
My internet connection is OK : I have downloaded apps from f-droid without problem…

I just updated to the last version (june 13th) and everything is working well. but surprisingly the microg app is gone, when i check in F-Droid it appears Microg Service Core as installed but with an older version (1.6.8) and it doesn’t allow me to update or uninstall it. I tried downloading the apk from the website but it doesn’t install.

Not surprisingly :wink: .
If you want to use LineageOS for microG, you have to stick with the LineageOS for microG builds.

If you install regular LineageOS without microG instead, you will end up without the deep microG integration you had before.

LineageOS for microG builds are here, and there is none for June 13 … https://download.lineage.microg.org/FP2/

1 Like

I’m quite happy with LOS16, still from may (waiting for the June security update :slight_smile: ). I do have the impression, though, that the phone gets a bit sluggish with longer uptime, and it looks like memory pressure is higher, even though it looks like i have normally between 400 and 500MB free, apps get killed aggressively when in background.

Wow. I didnt realized i applied the wrong file when updated a couple of weeks ago. Now im on the microg track. Thanks!

I had some problems when changing the font size and display size. After restarting the phone i couldnt pass from the unlock screen. I type the pin and screen goes black and get back to locked screen in an infinite loop. I managed to find a hint of the problem: if i click on emergency call and having the dial pad on screen swipe down the notification bar to get the icons, the. I click.in any and it prompted for the pin to unlock. After typing it doesnt go black. Instead a dialog box shows app saying that system UI is not working and gives me the options of “show info” or “close” any which brings me back to the locked screen.

The only solution found was to restore the phone from the TWRP boot and setting font/display size in default.

Thou im sure i was using small settings on those before.

Im using the micorg version of 10th of June.

EDIT:

it might be related with a widget (probably YR weather or aCalendar) as I already got stuck in the loop with default sizes. I will keep it without resizing and without widgets for testing.

EDIT 2:
It happened again. without widgets and default sizes. but this time happened meanwhile I was listening music in spotify. so there was an image and a animation in the locked screen. I tried unlock it and got stuck in the loop again. I restarted and didnt manage to unlock even when the animation wasn’t there anymore. but it certainly is something with the UI.

I had to restore it again, now testing, without lock screen animations from media, no widgets, no resizing and no pin code!

Is anyone having any issues with the latest builds? I wanted to try the latest FP OS and realised that I definitely prefer LOS but now it won’t boot up when I reinstall it… I’ve tried a few builds now. Is it just my phone maybe?

Well it’s not the phone because I’ve tried to install Lineage on my partner’s old FP2 and it hasn’t worked either. This is crazy. I’ve had no error messages at any point…

Which steps did you take to install LineageOS, did you wipe the phone completely?

If in doubt, just do steps 1 to 4 of this guide before trying again …

I did all that - on both phones! It’s so strange. I can’t work it out. I can reinstall the FPOS but not Lineage. But I want Lineage :sob:

What is the filename of the build you are trying to install, and what is your TWRP version?

I worked back from the current build to lineage-16.0-20190930-nightly-FP2-signed.zip in three or four steps. So I’ve tried a few packages. And the TWRP version is twrp-3.3.1-0-FP2.img. Thank you for your help…again!

I did the following for testing …

  • Installed Fairphone OS 19.08.1, confirmed it boots and did initial setup.
  • Installed TWRP 3.3.1-0.
  • Wiped the phone strictly according to the guide step 4.
  • Installed lineage-16.0-20191011-nightly-FP2-signed.zip, confirmed it boots and did initial setup.

So I can’t reproduce what’s going on on your phones, sorry.

1 Like

I knew something strange was going on. It must be my computer when adb sideloading, although everything seems to go through fine. I have no error messages. I think I’m going to stick with the FPOS for now, if I can get the dual sim to work. Otherwise - I can’t waste anymore time on this thing - I’m off to the phone shop.

Well I got Lineage working. For some reason the modem.zip was the issue, I booted into LOS without installing it initially and then installed it on a subsequent reboot, so I have that sorted at least. Still having issues with dual sim. I think it might be a problem with the homologation process here in Colombia. I still have network access, just no data… So I’m going to take it back in to the shop where they sorted that for me and see if I can get this thing working again!

The mystery deepens. Now my phone is seemingly functioning better than before, with both SIM cards fully functioning and with data speeds that are nuts. I’m just not going to question it and thank you for your help @AnotherElk

2 Likes

If you have 2FA/MFA enabled (you should!) you need to create an app password. I made one for P=P (K-9 opportunistic encryption fork), and one for Aurora (Yalp material design fork). I keep mine in a password manager.

Were you able to fix it? It works fine here. Make sure you understand the latest version as there are multiple available.