English

TWRP for Fairphone 4

Here you can find TWRP (TeamWin Recovery Project) builds for the Fairphone 4.

Please remember, that TWRP is not officially supported by Fairphone!

Download:
twrp-3.6.0_FP4-UNOFFICIAL-20211216:
https://drive.google.com/drive/folders/1xz6P6wbVtWj24PuCYIjXcL78MUCOBBx3?usp=sharing

Known issues:

  • Encrypted userdata not supported
  • MTP broken (for USB/adb to work go to Mount → Disable MTP)
  • Vibration not supported
  • Restore page is a bit buggy
  • Other undiscovered things?

Please also note, that Android security features like AVB (Android Verified Boot) & dm-verity might make your device unbootable if you tamper with some partitions. Keep your important data always backed up off-device!

Device repository (incl. build instructions):

24 Likes

Thanks a lot !

Isn’t encryption forced anyway ? Could not find a procedure to disable it.
I guess it means we’d have to wipe and decrypt from TWRP right ?

Correct, encrypted userdata is forced on new devices, so for accessing Android userdata TWRP is currently not useful.
There’s some TWRP support for this feature and I’ll look into getting it working reliably on FP4, maybe for the next build :slight_smile:

4 Likes

Anyway, thanks for sharing, I’m so glad to already see constant new promising things every day for such young device !

6 Likes

Awesome.

Thank you so much @lucaweiss .

2 Likes

I want to backup the phone before fastboot flash TWRP.

I am able to fastboot boot but then when I try to backup all partitions I get failed to mount /data (invalid argument)

Which would be the procedure to be able to set the phone back to its initial state after trying /e/OS ?

:point_up: You won’t be able to backup the whole device until there’s a version with support for encrypted /data

1 Like

Can I decrypt /data?

I wouldn’t recommend it, encrypted /data is default on newer Android versions I believe.
If you do, you will have to wipe the data partition completely and I wouldn’t try that without a complete flashable rom available for disaster recovery.

2 Likes

Hey,
since I flashed /e/os on my FP4, I cant boot into twrp anymore.
Any ideas, why this is the case?
I would like to use TWRP to root my device using Magisk, since the usual method doesnt work on /e/os

Because installing /e/ overwrites the recovery partitions :point_down:

And besides, please don’t flash TWRP to your device, just boot it with fastboot boot twrp.img

What problems do you have with the usual way, it apparently still works

Edit: To be slightly more precise, since you are flashing your whole phone anyway, you can just take the boot.img from the /e/ release, patch that with Magisk and flash it to your device. If you need help with that, please head over to the root topic :pray:

2 Likes

Hey!
Thanks for answering!

Using Magisk to flash the Stock ROM boot.img works fine. I did that, when /e/os was not released yet. It doesnt work with the /e/os provided boot.img. Many guides in their forum suggested to use TWRP instead to flash the Magisk.zip directly, since it doesnt require to modify the boot.img using the install step.

I did not try to flash it. I tried to boot it using fastboot boot downloaded-twrp-name-that-is-really-long.img, however it stayed in the boot screen where it showed “Fairphone”.

1 Like

Have you tried flashing a modified boot.img with fastboot? :thinking: Flashing Magisk through TWRP will modify the boot.img anyway. Could you maybe link one of their guides, I don’t really get the point.

Ah, sorry, misunderstood you there :see_no_evil:
Someone with /e/ actually running will have to test if booting TWRP still works…

Magisk will just crash if I attempt to modify the boot image using the app. So using TWRP seems to be my only choice.

Interesting, let my try that :smiley:
This is definitly root discussion territory now :point_right: FP4 Root Access is possible, maybe a bit risky

It instantly worked for me. Can you try it with another phone or do you want me to send you the patched img somehow?

@hirnsushi send me a boot img. And it worked (at least magisk shows that its installed), when I flashed it.
However, a direct install still doesnt work. Its really odd.

After the initial install of /e/os, what did you do? I only locked the critical bootloader again. Do you think that may be a reason?

I downloaded the e/os zip, patched the boot.img and then just followed the regular installation instructions with the patched boot.img. I also didn’t locked the bootloader after that

Edit: Meaning I just did this

  • Boot your FP4 in bootloader mode, and plug it to your computer
  • On your computer, download the zip file from the link provided above. Unzip the folder and browse into it
  • Flash /e/ with the following commands:

with the patched boot.img instead of the regular one

Interesting. Did you unlock your bootloader (again) before the install?
As my phone was already unlocked, I skipped it and only unlocked the critical part.

I didn’t unlock anything specifically for e/os, I’d already unlocked everything I needed to flash a rooted stock image about a week ago. I didn’t change anything since then