Trapped in fastboot mode with locked bootloader and corrupted custom ROM

If you reflash the same ROM there is basically a guarantee that it’s 1 again. Once you boot it for the first time you will end up with a 0 (at least with stock FPOS and CalyxOS).
That’s why you shouldn’t boot into Android and lock it afterwards, that’s how you end up with a :brick:

No, the install script will set the slot, don’t mess with it if you don’t have a good reason. Switching slots won’t bring back get_unlock_ability.

If your system is unbootable, your bootloader is locked and you have lost get_unlock_ability, then there is no way for you to switch slots. Changing slots only works with an unlocked bootloader.

1 Like

my fairphone 4 is blocked in fastboot mode.
after installing /e/ OS i wanted to secure again my phone and enter these commands:
fastboot flashing lock_critical
fastboot flashing lock

but my oem was locked by the official e installer…

so my phone always start in fastboot mode and the only authorized operation is poweroff

is there any possibility to unlock oem?
fastboot see my phone but not adb


  • fastboot flashing unlock : FAILED (remote: ‘Flashing Unlock is not allowed’)
    – fastboot devices find my device
  • adb devices didn’t see anything

i tried to contact fairphone support to be helped but, i’v bought my phone in Orange Store (and neither the store nor the 3900 want to help me at this time). so i only receive an automatic message from fairphone telling me to contact them. No answer from fairphone at this time (contacted from a week ago)

someone could help me to unlock oem?
thank you

Welcome to the community :wave:

I’m sorry to say, but there’s no way for you to fix this yourself other than going through support. You’ll need a shipping label from support, the phone gets sent to Cordon, they’ll charge you ~30€ and you get it back.

If support doesn’t answer soon, try calling them, that usually speeds things up.

1 Like

is there any french phone number to call them?

How do I make sure the install script won’t reboot the phone automatically? I tried to alter the script but then it wouldn’t run at all since the checksum didn’t match anymore.

Afaik no. For additional information you may consult #contactsupport

Which OS are you trying to install, sounds like stock FPOS?! :thinking:

In that case you can delete the line in the SHA256SUMS file that points to the install script.

I want to try different custom roms to see, which one suits best for me. I was on eOS 1.81 and want to try iodeOS 4.0 now.
In the documentation it says you need to be on latest stock FW with locked bootloader - locked critical to be precise.

I was on unlock ability 0 until I found your post yesterday. Thanks to your kind help I was able to flash stock without automatic reboot, therefore unlock ability was 1. :smiling_face_with_tear:

I then sucessfully run fastboot flashing lock_critical, but afterwards the phone booted automatically and I’m back on unlock ability 0. :expressionless:

This is ok as a prerequisite for iodeOS installation, but is still very frustrating when someone wants to go back to stock completely. :smirk:

Those are two very different things!
Locked critical partitions means you can’t flash any of the critical partitions, that’s not directly tied to the state of your bootloader (you loose that ability if you lock the bootloader though).
You should not have a locked bootloader however if you plan on installing iodéOS.

As long as the OS you are installing flashes the frp partition, not sure if iodé does, you will end up with get_unlock_ability=1. Just make sure you check the state after flashing and don’t lock it if it’s 0.


Hello together,

I’m getting desperate and do not know what to do and hope someone can help me. I bought a Fairphone 4 and wanted to install CalyxOS on it. This has worked well so far. Then I restarted the phone and now have the problem that I’m stuck in a bootloop. I made it into the bootloader and the device is locked again. OEM seems to be deakvitert again, because when I get I always get an error. So I’m in the situation of having a bootloop with locked OEM and can’t unlock it via CLI. Also my attempt to install a recovery image via adb sideload fails. Does anyone have any other idea ? I am getting desperate.

Translated with DeepL Translate: The world's most accurate translator (free version)

Hi and welcome, I assume your are hit by the above and the only way to unbrick is to contactsupport and send the FP4 to France…

Not sure how you installed CalyxOS maybe have a look here as well

1 Like

Welcome to the community :wave:

Did you lock the bootloader manually, the installer should protect you from bricking? :thinking:
If you didn’t, you can just run the installer again and that will take care of everything.
If you were on the latest FPOS release, you might have to wait for a few days to be able to lock it.

What’s the output of fastboot oem device-info && fastboot flashing get_unlock_ability?

Depending on the recovery (slot) you ended up in, you won’t get far without a properly signed update, that fits the state your phone is in right now.
It’s basically a dead end.

1 Like

I got this:

(bootloader) Verity mode: false
(bootloader) Device unlocked: false
(bootloader) Device critical unlocked: true
(bootloader) Charger screen enabled: false
OKAY [ 0.010s]
Finished. Total time: 0.010s
(bootloader) get_unlock_ability: 0
OKAY [ 0.000s]
Finished. Total time: 0.010s

That’s a case for support, nothing we can do here :grimacing:

How did you lock it, that shouldn’t happen!

via Bootloader. Could i send it to them ? F*ck… i want to use it.

You’ll have to contactsupport, they’ll get you shipping labels to send it to the Cordon, the repair contractor. Will cost you 30€.

Once you get your phone back, don’t ever lock the bootloader without checking fastboot flashing get_unlock_ability beforehand.
And in the case of CalyxOS, don’t lock it manually the next time, the device-flasher checks for that and prevents you from bricking.


So, running that command where in the sequence prevents bricking?

Did you do some reading? If not I would say do this :wink: you can even search in the topic, so that you dont need to read everything


Could someone confirmed if my phone also will need to be sent to france?
Here are my details:

 .\fastboot.exe oem device-info
(bootloader) Verity mode: true
(bootloader) Device unlocked: false
(bootloader) Device critical unlocked: true
(bootloader) Charger screen enabled: false
OKAY [  0.005s]
Finished. Total time: 0.005s


.\fastboot.exe flashing get_unlock_ability
(bootloader) get_unlock_ability: 0
OKAY [  0.002s]
Finished. Total time: 0.002s

There are dozens of these threads, why has Fairphone team not addressed this fatal bug?