Trapped in fastboot mode with locked bootloader and corrupted custom ROM

Hello Hirnsushi,
I am new to this forum and preparing myself to convert my brandnew FP4 to iodéOS.
In case the unfortunate happens to me (unlocked bootloader & get_unlock_ability = 0), could you tell me how to make Magisk set get_unlock_ability = 1?

Is this by installing Magisk on the yet-unbricked FP4 and applying the required commands from there? Is this correct, or can it be done from terminal-ADB?
What are the required commands?

Does the yet-unbricked FP4 need further preparations such as rooting?


See above:

(and it can be done from terminal-ADB)

Thanks Volker, now got where to find answers if required

1 Like

If you mean running it outside a normal Android userspace (e.g. through recovery), then no, your phone still needs to be fully bootable.

Oh and welcome to the community btw :wave:

Hi, i have my FP4 now for over a year and I would love to use LineageOS 20 because the FP4 is now officialy supported by LineageOS. And when I read through this topic I’m not sure if I should rly do this…
So I have to install the Lineage Recovery thing to install LineageOS. When and how do I have to (or shouldn’t I?) lock the bootloader. And if I go back to the original OS what should I do? Or is this even possible because of the Android anti rollback thing (Because LineageOS 20 is A13 and the FairphoneOS is older and probably has an older security update)
So what should I definitely not do to avoid to have a bricked phone…

And a happy new year :tada:

Just read along this topic and probably most of your questions are answered.
If it’s too long you should imho at least read the summary (which is about 50 posts…).

My very short summary would be:
you’ve to decide yourself if you’ll lock your bootloader or not. It’s a matter of convenience vs. security.
I suppose it’s not the problems of major releases but just of date of security patch level.
And as long as OEM unlock is enabled you’re on the safe side.

1 Like

So if I don’t lock the Bootloader, I’m on the safe site?
With other words I can let the Bootloader unlocked and if I would go back to FairphoneOS I can just lock it?

No especially when you go back to FPOS you have to be careful. Did you read as suggested?


The tldr is: it’s fine to relock if you use the device flasher by CalyxOS. If you don’t there is a small risk of the phone bricking, which I personally wouldn’t risk.

If you make sure the setting mentioned above is showing unlocking is possible you’re probably fine.

IF you choose to leave it unlocked you ultimately risk almost nothing.

So in combination with the answer from yvmuell

Did I understand it right, that it doesn’t matter if I lock it or not when it comes to get a bricked phone? The risky part is to install later the FPOS?

For what exactly do I have to lock for? I read quite a bit of the Topic and I didn’t find like the cause of the bricked phones. What does the get_unlock_ability exactly mean? And what should I do when it is 0 or 1?

For your future risk of bricking the phone it doesn’t matter if you’ve locked it in the past, that’s correct.
But, the risk isn’t only present with FPOS, you can brick it with any OS you install if something goes wrong and you didn’t make sure fastboot flashing get_unlock_ability_ is 1 beforehand.
The CalyxOS device flasher just checks that for you and stops if it isn’t, that’s the part that makes it safer.

You don’t have to, there are some (banking) apps that check for that and will refuse to work and there are several security benefits that are only in effect if the bootloader is locked.

Whether you can unlock the bootloader again by issuing fastboot flashing unlock or not (which means it’s bricked if you can’t boot into the proper Android userland)

If it’s 0 don’t lock, reflash the ROM you were trying to install, check again. If you want to lock the bootloader, don’t boot into Android userland after flashing, there’s a high likelyhood that resets the value and you definitely shouldn’t lock after that.


Thank you so much for your detailed answer and sorry i’m still asking (maybe stupid) questions.

So let’s go through an installation:

  1. I have to install the Lineage recovery (Does it matter already here if the unlock ability is 0 or 1?)
  2. Let’s say I can install the image and it says 0 should I flash it again? If it is 1 can I run fastboot flashing lock and boot into LineageOS and I’m still able to go later back to FPOS?

And now worst case: I brick somehow my phone… Did I understand it right that I would have to contact the support and then it would cost me 30 Euros to fix it or would that mean my phone is broken?

LineageOS doesn’t support a locked bootloader, so you definitely shouldn’t try to lock it when using that.

If you want to go back to FPOS it’s safest not to relock the bootloader at all.

If I were you, I’d use the CalyxOS device flasher. It does everything for you, more or less. Just follow the instructions carefully and you’ll be fine.

1 Like

As long as you don’t brick your phone you can always go back to FPOS, but as @AvidAlbatross noted, make sure, if you are locking the bootloader on a custom ROM, that that’s actually supported.

That’s generally what happens, since it’s a bug in the bootloader so Fairphone’s responsibility, but none of us work there, we can’t guarantee it, the policy might change any time.

Just a small addendum, if you decide to go that route and updated your phone to the latest FPOS already, you’ll need to use the beta factory images, not the ones mentioned in the instructions. More info here.

1 Like

Just for documentation:
I installed /e/OS and after that LineageOS on my FP4 (purchased 22/03 with FPOS), all worked nice. Then I needed to go back to stock-ROM, because my banking-app only works on phones with locked bootloaders. After installing the latest Stock-Rom ( ) I locked the bootloader. And voila: Stuck in bootloader with no possibility to unlock or boot into recovery.
Now I contacted FP support and wait for an answer.
To be continued…

It’s pretty interesting that they still haven’t fixed this over a year later.

1 Like

So I bought a used fairphone 4 from a big online retailer. Said in the description: foil on the screen was removed, functions flawlessly.

Well turns out it doesn’t work flawless. it is stuck at fasboot the bootloader is locked and booting to recovery or the system does show a quick fairphone logo and returns then to fastboot.

So i guess either someone bricked it and sent it back to the retailer and they sold it again without checking the function of the device, or it was not working from the beginning or magic happend.

I reached out to the online retailer to find a solution.

And it all makes me pretty angry, since i bought a fairphone because it is easily repairable - at least thats what i thought. And rn idk how much of that i can really believe anymore. since it seems to be a problem that needs the intervention of the official support. so what was then the point of getting a repairable phone if i cant repair it on my own.

Also that this wasn’t fixed yet. also the lack of replies to this from fairphone on this all disappoints me, i was hoping that with a company that is invested in repairability and sustainability things would be different but maybe a big part of it is just marketing. thank you all for helping me finding out what’s wrong by reading this thread. i hope the retailer i bought the phone from comes to a good solution for me. And i guess if buying used fairphone 4 phones if possible make sure that it boots beyond the fastboot before buying, especially when buying from private people.

I understand you are angry, however blame the reseller. it is repairable, your issue is not a hardware failure, so has nothing to do with repair overall.

1 Like

Hey all :grinning:,
I recently got my FP4 as a present and was really hyped using it and trying out a custom ROM. But unfortunately I’ve run into the same problem as many in this thread have.

My story (short):

  • (at first I ran into some issues because I, unexperienced and completely new to the topic as I am, forgot to update my FPOS to the latest release)
  • then I installed /e/ OS using their EasyInstaller. Everything worked perfectly (except the automatic locking in the end of the installation process; that (fortunately) didn’t work)
  • after locking the bootloader (because I read that it’s recommended) my FP wouldn’t boot (because of a corrupt OS)
  • fortunately, I could unlock the bootloader and installed FPOS again and did the whole process over again except for the last step. Because of reasons my present-self doesn’t understand, my past-self tried locking the bootloader again (reversing the order of the commands, first lock and then lock_critical, because I’ve read it somewhere)
  • and then my device got into said brick state, that is well known around here. Doesn’t boot and keeps returning to the fastboot screen.

Unfortunately I only discovered this thread after I bricked my device (next time, I hope I will be more careful).
I’ve contacted support 2 days ago (til now no answer, but they said in their mail that they would need 5-6 days, so no hurry on my side, my old phone works). I would be willing to pay the 30€ (after all, the accident happened while installing a custom ROM), but after reading this thread and as far as I understand the matter this is caused by a bug in Fairphone’s bootloader. I’ve already written in my support ticket that I tried installing /e/ (and I don’t like the idea of giving false information, e.g. that the error happened while installing FPOS, especially with a company like Fairphone, whose mission and goal I really care about).
Let’s see what will happen. In every case, I’m very excited for my new Fairphone (and waiting a few more weeks is a bummer, but won’t stop me from (hopefully) becoming a very satisfied Fairphone user).

Just wanted to inform you, that this is still relevant and still happens to inexperienced users like me.

(Sorry, this post unfortunately got longer than I planned.)

Thanks for the loads of really helpful advice in this thread (I wished I would have read it earlier). You’re all great!


Wait a sec. You mean that if I run into a 0, I can simply reflash the same rom and without rebooting there is a high chance that afterwards it’s 1 again?

Somewhere on here I read, that it might also help to alter the current slot. Is that true?
If yes, that will only help once, right? Because when let’s say slot a gives me a 0, then I change it to slot b and this one also get corrupted, there is no going back, right?