CalyxOS (is coming to) is here for FP4!

You are right, default profile pics on a small phone screen … :smile:

Well, that is indeed a very plausible explanation.

As far as I can tell, there hasn’t been any update on the fate of the first device, @juri.gagarin.ii , are you still stuck on a Calyx installation with a locked bootloader? :thinking:

1 Like

Yes I am, but as CalyxOS is working well (except, of course, the camera-issue which is not exclusive to CalyxOS), I didn’t dig deeper.

If I ever want to try another OS (I’m kind of an OS-hopper), I will have to think about that.

Interesting, hmmm :thinking:

Could you check the output of fastboot oem device-info :pray:
Oh, and the output of adb shell getprop ro.boot.flash.locked.

No idea how that’s possible, locking the bootloader should just make the OEM unlocking switch available again … very interesting :smiley:

Unfortunately that will take some time as I am on holiday without my laptop. But when I’ll be home I will get the information and post it here.

1 Like

Dump question: Now that FP4 is officially support with/by CalyxOS since a while, locking the bootloader and have the phone rooted is still not supported/recommended, right?

Apart from that the last few updates via OTA went just fine via the described way. Thinking about putting the update procedure into a separate wiki thread/post. Sometime it feels like the procedures/hints/infos/step-by-step-guides are somehow buried in very long threads like this one (or )

As I wrote in that other thread:

If you use the device-flasher, it’s now generally safe to lock the bootloader.
I’ve tried it 30+ times by now and everythings been fine, as always, no guarantees though :nerd_face:

Edit: Woops, missed that part :see_no_evil:

Never will be supported, and it’s not only not recommended, it can very easily brick your phone.


3 days ago I installed Calyxos on my Fairphone 4 and I just want to let people know of my experience and opinion of it. I’m a programmer techie nerd so my phone is my life.

The Pros:
The first 3 days were absolute bliss. I loved working in Android 13 and Calyxos is really very very well done. Only one bug I found in the whole thing in their Knock-off of GooglePlay if you somehow miss hitting the “install” button after downloading a new app the only way to continue is to restart the phone. But for such a huge software that is really a very very minor bug. Everything I really needed for banking, communication, etc, all worked perfectly. I’m not interested in avoiding the evil Google Corp so my goal was to just get everything I need to work. Others prioritize avoiding Google and there Calyxos Shines victorious, but then, very little will work of course since Google is so powerful.

The Cons:
Not everything works. Probably 95% of all you need/want will work. Eventually you will find things that don’t work. Not Calyxos’s fault at all. A very few apps that love the evil Google Corp will eventually find something they don’t like about Calyxos and refuse to work. For me it was the following

  1. Samsung Wear and all samsung apps for my watch which means my watch was toast. Too bad because I loved Samsung pay and my watch. I could buy a new Garmin watch which others say works.
  2. All my streaming apps refused to work. You know, like Netflix, however I don’t have netflix myself. Apparently they check if the phone is root unlocked and refuse to work if it is. I assume it is to protect their copyrighted material.

So I re-rooted my Fairphone 4 back to the old Android 11. That went rather well with only a few minor hiccups. One major note here!! “You must re-lock your root or your streaming apps still won’t work”!! Now actually I realize that although Android 13 was a little more eye pleasing than Android 11, actually android 11 is just as good and even some of the eye candy in android 13 is actually irritating in the long run. So for now I am very happy back on Android 11.

FWIW (some nerdy annotations):

You could have locked the bootloader on calyxOS, too, if that’s really what Netflix checks to run.
(Afaik calyxOS installation guide even recommends to relock the bootloader)

You reinstalled stocks OS if I understand correctly. This has nothing to do with rooting. Rooting is not necessary to install an OS on a FP3.

I suppose you mean here that you have to re-lock your bootloader. :slight_smile:


Monk(y) annotation: FP4 :upside_down_face:


Yes, yes, and yes :laughing:. I also thought about locking the bootloader on calyxos but never tried it. I just felt if they’re so careful to check the lock they probably have a way to check the validity of the android. They don’t give any decent error message. Just don’t work when you start a stream.

On the other hand immediately after re-installing the stock android I tried the streaming apps and they still refused to work. I then locked the bootloader and the streaming worked perfectly. It was quite frustrating that when you lock the bootloader it erases any data or apps so I lost a few hours work there.

Hey guys!

For 2 days now, I’m trying to root latest CalyxOS, but it always gets stuck in a boot loop. What I’m doing:

  1. Install Magisk App
  2. Upload boot.img that comes with CalyxOS
  3. Patch that boot.img
  4. Copy it back to my PC
  5. Install CalyxOS with device-flasher.linux
  6. fastboot flash boot <modified boot.img>
  7. fastboot flash vbmeta --disable-verity --disable-verification vbmeta.img (the vbmeta.img that comes with CalyxOS
  8. fastboot reboot

And then it’s stuck in a boot loop. But even when I flash back the unpatched boot.img from CalyxOS, it stays in boot loop. I can go back to Stock ROM, but I don’t seem to be able to root my CalyxOS. Has any one succeeded? Please advise!

Welcome to the community :wave:

Don’t directly flash that boot.img, unless you want to make OTA-updates unnecessary complicated. You also shouldn’t / don’t need to flash vbmeta, just follow the usual root procedure:

I’ve been running CalyxOS rooted since it’s been released, no issues so far. (Obviously you loose the ability to lock the bootloader, it will always be a compromise)

1 Like

Using fastboot boot <patched boot.img> didn’t work either. It showed the boot screen for 1h, and then I turned off the phone. Am I patching the wrong boot.img? I’ve tried using the one from the latest stock and the one that comes with CalyxOS.

Did you reflash your phone since you patched vbmeta? :thinking: If you messed with that partition, that might keep it from booting correctly.

You need to patch the boot.img that comes with the CalyxOS .zip you downloaded.

I reflashed the full thing with the stock system. When that booted properly, I re-installed CallyxOS, didn’t patch any partition, but tried to boot directly into the patched boot.img from CallyxOS. That one then lead to the phone shutting down and turning itself off :confused:

After fastboot boot boot.img the image that lead to the phone shutting itself down about 4 or 5 times, it eventually booted and I successfully rooted the phone. This is really odd.

Sounds like a problem with your USB-cable / -port, I don’t think fastboot boot checks what you send over for integrity, maybe some bit flipped in transit :thinking:

Did you try to boot into CalyxOS before you started with root?

In any case, I’m glad it finally worked :tada:

I assume this happened because it unsuccessfully tried to boot from one slot (e.g. slot a). After several unsuccessful retries it automatically changed the slot (e.g. to slot b) and could successfully boot from this one.

EDIT: the statistics of the fastboot command fastboot getvar all might back this theory.

1 Like

That could play a role here, good point, but I’ve never had a CalyxOS installation stuck in the wrong slot after installing and I’ve done well over 50 at this point :thinking:

If that is indeed what happened, there is probably a bug in the device-flasher that needs to be fixed. That could lead to problems if the phone gets locked at the end (as it’s supposed to).
Shouldn’t that issue have prevented the initial boot as well?

1 Like

Hey there,

just checked out the latest update’s ChangeLog (CalyxOS 4.3.1), and saw this:

FP4: Make wide-angle camera available to third party apps (OpenCamera, Google Camera, amongst others)

I’ve got the OTA update installed, but couldn’t notice a difference at first glance using nikita NGCam 8.2 v1.8

does anyone have a clue how to test this ?

At least with the stable Nikita (and Greatness) version I tried, I had to enable AUX camera #2 in the settings, have you tried that? :thinking:
It’s under Settings → Advanced → Auxiliary camera → switch 1st and 2nd lens to on.

Other GCam versions, like BSG (I use) and Wichaya, seem to pick it up automatically.

1 Like