Stock fp3(+) (factory reset) boot loop (workarounds in first post)

Thank you very much to your developers and the whole team for contacting Google and make sure you work together. Unfortunately it is like I said here (last point). Everyone who has the problem MUST do the workaround or “reset” the FairPhone to get rid of this problem. But at least it is ensured that no one will be confronted with this problem again.

@moderators I would suggest to mark that answer from @Blaffi as solution!



I am also affected by this issue and have waited until now for this solution.
I have not done a factory reset so far.
I have tried the recommended option #1 (quickly deinstalling the Google Play Services updates). However, I always get a message “Deinstallation failed”, and my phone restarts.

Is there a way to allow uninstalling it without factory reset?



Thank you all very, very much. I can confirm, that there was a change. I’m not absolutely shure, but I think I didn’t manage to downgrade Google Play Services really in time. So I assume, a simple “waitimg for the magic to begin” can solve this issue either.
I left my (unchanged and effected) phone powered on in a wifi connected state, 1h after your post everything seem to work normal, no reboots or anything.


That’s very cool I did not expect this and I’m interested what was done in the background and if someone else also just needs to wait and the affected phone downgrades the version automatically? Maybe there is new Update from Google without the crash? That would be awesome!


Thanks to yourself & all FP, FP community, and Google folk who helped resolve this; massively appreciated :slight_smile:

Quick question - before this was resolved, I’d used the below to disable Google Play Store:

I’ve now re-enabled that using adb shell pm enable, rebooted my device (not sure if required), and dragged my Google Play Store icon back onto my home screen (it was removed when the package was disabled).

I then opened Google Play Store, clicked on my profile image, selected Network Preferences, Auto-update apps, and put this back to Over Wi-Fi only (it had been Don't auto-update apps).

I then opened Google Play Store, clicked on my profile image, selected Manage apps and device > Manage > updates available and then selected and applied all pending updates.

Once all updates were applied, I rebooted again (for good measure). (All’s still good >1 hour after applying those updates).

Question: Are there any other actions that should be taken to put the phone back into it’s “normal” / non-workaround state. Thank-you again.

For further reference, see the most recent Fairphone statement by Yasen Tomov.
Previous Fairphone statements by Rae and Blaffi

As time is limited when trying to uninstall the Google Play Services update as suggested in Rae’s post, I thought it might help to have step-by-step screenshots for this part so you know as exactly as possible what to expect in each and each following step. I’m not illustrating Disable automatic Google Play Services updates as I conclude from @Blaffi’s latest update that that is no longer necessary to do.

Of course, there are other ways to enter Settings.

Click at these previews to enlarge them, then navigate to the next by arrow keys resp. swiping:


Jüngste Google Play-Dienste Updates deinstallieren

  1. Einstellungen > Apps & Benachrichtigungen > Alle XX Apps ansehen
  2. Runter zu "Google Play-Dienste* gehen
  3. Oben rechts die drei vertikal übereinander gestapelten Punkte antippen
  4. “Updates deinstallieren” antippen
  5. “OK” antippen

Zum Vergrößern diese kleinen Vorschauen antippen, dann weiter mit Pfeiltasten bzw. Wischen:


EDIT : I really hope for everybody that just let your phone connected to the wifi a few hours top works that easily but apart from that I would have loved to have confirmation of this before I took one hour to write a more detailed step-by-step “advanced” adb workaround :rofl:


Hi @fcpprs,

Did you try to use adb (Android debugger software) from your computer to deinstall the problematic version of the app from your phone, and then reinstall a previous (non buggy) version, like described in this post by @Pilo11 ?
ADB workaround by Pilo11

This might be difficult for most people so let’s try to give as much details as possible for each step :

  1. Activate Developer mode on your Fairphone

Boot your smartphone and type the SIM card PIN code, but don’t unlock the screen yet.
Scroll down and open the quick pane (with ariplane mode and other buttons) and click on the little Settings button.
Be ready to “speedrun” after you unlock your screen…
… Scroll to the bottom of the Settings page and click on About Phone
… Scroll to the bottom of the About Phone and click quickly 10 times on the Build Number entry !
You will likely fail the first times, but you can do it ! Keep faith !
For official instructions on how to activate Android Developer Mode see : Android dev options

  1. Activate Debug via USB on your Fairphone

Similar as in step 1 boot and click on Settings before unlocking, then let’s go for the “speedrunning”…
… Scroll to the bottom of the Settings page and click on System
… Click on Advanced Settings
… Click on Developer Settings
… Scroll down (about 2 screens height) and below a cosmetic bar find and activate the USB Debugging button.
We believe in you ! You will require multiple attempts before success, but you will do it !
For generic instructions on how to activate USB debugging on Android see : How to Enable USB Debugging Mode on Android

  1. Setup your computer to be able to execute adb commands

To be able to pass adb commands from a PC with Windows, you might want to have a look at this post from @Stanzi : Link to a lightweight adb program for Windows users

I have a Fedora GNU/Linux computer.
I have installed android-tools package. I think you might be able to only install adb, and/or android-tools-adb for Debian/Ubuntu-based distributions.
Make sure your user is in plugdev group : sudo usermod -aG plugdev $LOGNAME (see Android Developer)
Make sure your udev rules are set up for your Fairphone :

  • Use command lsusb to identify your Fairphone (mine is described as a Google Nexus device) and note its 2 4-digit ID values. (for example ID 22b8:2e81)
  • Edit Android rules file : sudo nano /etc/udev/rules.d/51-android.rules
  • In this file add the following line with the ID values retrieved from lsusb : SUBSYSTEM=="usb", ATTR{idVendor}=="22b8", ATTR{idProduct}=="2e81", MODE="0666", GROUP="plugdev"
  • Reload rules and restart adb : sudo udevadm control --reload-rules
  • sudo adb kill-server
  • sudo adb start-server
    For more detail on this procedure you might check at this page : Github post
    For the record I had to delete my ~/.android folder for my phone to prompt me for debug linking to my computer. (You probably do not care about it if you are not already an Android developer with this computer.)
    If you have trouble you might try to reboot your computer.
  1. Permanently authorize USB debugging from your computer
    Once you are set on the computer, connect via a USB cable your Fairphone to it (again with PIN code entered but not yet unlocked of course).
    After a few seconds try to unlock it and you should see a prompt asking you if you want to authorize your computer to debug on your phone, with a check box for this authorization to be permanent.
    Check the box to not be asked again, and accept the debug pairing between your phone and computer before your phone reboots (you can do it !).

  2. Download a fallback APK package and install it on your phone via adb
    Check that your computer can debug your phone right by typing adb devices (see part 3 if a potential problem is raised).
    Download a Google Play services fallback APK file (NB : I trusted @Pilo11’s APKMirror link on this subject but keep in mind this is not Google-owned platform, but still a widely used platform by the founder of Android Police).
    Last, perform @Pilo11’s commands to uninstall problematic package from your phone, and install this APK instead :laughing: :

adb shell am force-stop
adb shell pm clear
adb install -d\(150408-428111784\)-220221039_minAPI30\(arm64-v8a,armeabi-v7a\)\(480dpi\)

I hope this helped some people !


I can confirm what @fcpprs writes: Deinstalling Google Play Services ends with a failure message “Deinstallation failed”. And then the phone reboots again… Any fixes for that?

Factory reset is just not an option for me.

I am having the same situation. I hope there is a solution for this.

1 Like

The Google Play services is essential and if the new update isn’t available then it has to be downgraded, not uninstalled. Hence the adb procedure

However it is the Google Play Store that updates the G Play Services, as well as OTA updates, so you can disable or uninstall the G Play Store

1 Like

Hi @amoun - so far I had Google Play Store deactivated. Still could not deinstall Google Play Services.

Now I uninstalled Google Play Store with the result that Google Play Services does not open/ load any more in the time window before reboot… Just black screen. Seem to be caught in a vicious circle…

Google play services either requires the new update, or being replaced via adb, not uninstalling.

You can uninstall Google Play Store where the updates for the Google Play services are updated.

If you don’t use the Google Play Store then it may well as be uninstalled.

1 Like

@fcpprs @BGR @ajg As spotted by @Kommissarmartin here, this happens when an app which uses the Play Services (such as Find My Device) is enabled as a Device admin.

To fix this, go to Settings > Security > Device admin apps and disable the services there. After you deinstall the Google Play Services updates, you can go back and enable the Device admin apps again.


Hi all. I had the same issue with my FP4 and finally did the factory reset (two times actually, as I did restore my Google Backup with all the apps).
The app I identified as the problem was smart launcher (an alternative launcher),
Since I reverted back to the original launcher, everything works fine.

1 Like

Hi, thanks for the advice. Nevertheless although I manage to reach Settings > Security > Device admin apps and disable the location device app, phone still restarts and then the app is again enabled.
Any thoughts or suggestions on this?
Thanks in advance

Are you having this issue with a fp4?

I guess thats a different root cause maybe causing the same bootloop issue, however the one and only report so far…

A post was merged into an existing topic: :de: Fairphone 3 startet immer wieder neu und sagt, dass Android nicht gestartet werden kann

yes, it is a fp4 where I had the problem.

No, I think you can’t. As @Kommissarmartin already wrote: Switching this setting off doesn’t seem to be saved. When I suffered the problem, I had a fairly long 20 seconds window until reboot (plenty of time). But even if you reach this device admin setting (or the general “find my device” setting - there is another one but it behaves the same), upon switching it off, it just spins busy waiting (greyed appearance on switched off position, like “not yet done”) for another ten seconds until the phone reboots. To me, it makes the appearance it cannot switch off because it waits for Play services to start :chicken: :egg: , while Play services starting triggers reboot :melting_face:.

So, I conclude if you suffer an error message on Googe Play services update uninstallation or deactivation, e.g. because you are using the “Find my device” functionality, you can only resort to the ADB procedure or factory reset (or the yet somehwat nebuluous “just do nothing for hours and it fixes itself” fix?). Deactivating “Find my device” does not work if you are already having the reboot issue.