English

Software update Kola Nut 1.8.7 is ready - Stagefright fix

osupdates
1.8.7
Tags: #<Tag:0x00007fb119d95b08> #<Tag:0x00007fb119d95388>

#1

Hi all,

We’re excited to announce that the new software update Kola Nut 1.8.7 is here. From today, the update will be available once you connect to a Wi-Fi network. Your Fairphone will check for the update automatically, or you can open the Fairphone Updater app yourself to begin the process.

Kola Nut 1.8.7 is an important software update with security fixes, including those for the Stagefright bug.

For the full list of changes, please have a look here.

How to update
There are two steps to install the new software update. You can see how these steps work in detail in the interactive tutorials we’ve created (available in German, Dutch, French and English).

Here’s how to update:
Step 1 will download and install the Kola Nut 1.8.7 software update from the Fairphone Updater app.
Step 2 will reinstall Google Apps. If you wish to exclude Google Apps from your Fairphone, you can skip this step.

We want to thank the people who were part of the beta testing for contributing valuable community feedback.

Cheers,

Rick
The Fairphone Team


After update to 1.8.7 google apps can't be installed!
I didn't apply the Stagefright bug fix until now — is that dangerous?
Fairphone 1 maintenance comes to an end
Stagefright vulnerable in spite of newest update
Help! Fairphone does not start any more
Accessing an online banking app
#3

Manual installation through https://fairphone.zendesk.com/hc/en-us/articles/202478028-Manually-install-Fairphone-OS-software-update-version-Kola-Nut-1-8-7


#4

I tried to download the update but everytime I downloaded it I can’t restart my phone and the warning ‘no room in cache’ appears. I already emptied the cache but nothing seems to work… can you help me somehow?


#5

Try to keep the screen active while downloading/installing.


:de: Nummern werden nicht mehr geladen
#6

For me, downloading/installing the 1.8.7 update went smooth and uneventful.

When re-installing Google apps (yes, I’m stuck on the dark side) I first encountered the dreaded ‘file not found’ message when tapping “restart” after downloading. After a repeated download it worked, however.

And as with previous updates: we who have the Xposed framework installed must reinstall/reactivate the framework and reboot if we want GravityBox and/or other modules to work.


#7

The download went perfect. Yes, the google apps also, because the app NS-reisplanner is only available through google.


#8

I tried that, but it still didn’t work. It still just say that there is not enough storage in the cache. Even after I cleared it.


#9

Do you have a unified storage? (Or do you have an internal and a phone storage in settings storage?)
If you have a unified storage did it come like that (FP1U mid 2014), did you do it with an official storage upgrade or with the XDA storage upgrade?


#10

How did you clear the cache? System settings > Storage > tap Cache and choose ‘Clear’ only clears the installed apps’ cache, not the whole cache partition. Try the following:

-Turn off your phone by pressing and holding down the Power button.
-Go to ‘recovery mode’ by holding the Volume Up button, while at the same
time pressing and holding the Power button. Hold these two buttons at
the same time for about 10 seconds until the screen turns on, then
release the buttons.
-You will see a resting robot lying on his back with an exclamation point.
-Now, select “Wipe cache partition”, and wait till you see “Wipe cache complete”.
-then "reboot system now"
and try to start your phone again

(thanks to @Lidwien for a clear description of how to wipe the cache)


:pencil2: How to update your Fairphone 1(U)
#11

Yeah I have an unified storage and did it with the official update of the fairphone updater.


#12

Well then wiping the cache as described above should definitely do the trick! :smile:


#13

thanks a lot, I#m gonna try that


#14

yeah, didn’t see the post until after I replied ^^


#15

I Downloaded and installed the new update. With googleapps I encountered problems: first I got the message that we couldn’t download the normale gapps. You het redirected to another downloadsource. I DL-ed that, but the MD5-hash was wrongand I got the “intsallation wizard had stoppen” message.

Biggest problem: no more sync possible with google.


#16

Update done without any problem. Thanks for the tutorial.


#17

Cool, unlike the last couple of times when I had to update, from the beginning there is no problem with my connection to Google Play services. Me likey.


#18

I back-upped everything before I did the update, - the update was (as the other times before) without problems and after the back-up all my music, my apps on the different screens, the bookmarks etc were still there.
Thank you, Fairphone-people! :sunglasses:

(ps: no google playstore :dancers:


#19

For me, it took two attempts to update. First try: downloaded, pushed update, the green animated android appeared, then the restart button, phone restarted. But all seemed unchanged, and indeed, the updater show still 1.8.5. Then I started the update again, new download, new animation, but then, it started to update all the apps, and then the updater shows 1.8.7 and the missing Google Apps raised their hand…
Now the second restart is ongoing and the second “optimation” of apps is running, so I think, all went well.


#20

the update works for me


#21

Hi

“failed downloading google apks” so I’m stuck AGAIN…!!! And then I get “FP downloader stopped working”…

Can’t this work once without problems? Everytime… everytime… now I know I’ll spend the day trying to correct this… :frowning: and I don’t know how…