Software update Kola Nut 1.8.7 is ready - Stagefright fix

Update installed but the phone keeps showing a message saying that the Android keyboard has stopped working. Which it has.

Lots of flawless installs over at Fairphone-Freunde FB group. :relaxed:


3 posts were split to a new topic: Can’t unlock phone after update replaced cyanlockscreen

Thank you Fairphone Team

Update and phone still working fine!

1 Like

Update works. Thank you very much, especially for the roaming and multi touch fix :slight_smile:


Reinstall the App Store.

Mine also has keyboard not working. How do i reinstall app store? My daughter has a fairphone. She does none of the updates because there are always problems. Why do some phones have problems and others not? Mine is a first edition. Thanks

For me everything worked fine with the update. Thank you!
Everyone who uses 2-factor-authentification on Google should create backup-Codes to be able to login after installing GApps again - because in that moment you can’t get Access to the Authenticator-App.


Too bad I could not access nor reinstall Xposed, so I had to perform factory reset.
Luckily I had made a backup of the most important data, but the backup I made in the recoverymode is gone.
Is this because it is made on the unified partition and not on the SD card?

first part went okay, then i had no keyboard working. Only now i realize i have to download and reinstall the Google apps part. We will see!


How did you try to reinstall the Google Apps? I don’t think that the updater app would suggest another download source?!
But then again I never installed GAPPS, so I don’t know.

For next time: Before you update go to settings > developer options and tick “stay awake” & plug in your phone. This way you’ll only need to do the update once.
As for the Google Apps, you have to reinstall them with the updater app, just another restart won’t help.

Open the updater app, there should be a button for that.
PS: As rick explained below, if that button is not there you have to enter “advanced mode”.

Strange I usually only have to open the Xposed Framework app and navigate to “install/update framework” and do a restart. Then everything is back as before.

1 Like

It’s explained in the tutorials - just go to the Fairphone Updater app -> Advanced Mode.

Thanks for the update. It worked smoothly this time.


Thank you for this update. This company also does a lot to keep the phones already sold in good shape and up to date. This is not at all self-understood, as you can read everywhere. Everything with the update just went fine with my phone.

You all do a great job



For me the update itself and reinstalling the Google apps went alright.
But I am not getting any notifications of the google apps. E.g. if someone writes me on Hangouts there is no notification, also when I get an email. Anyone has a clue how to fix this?

Thanks in advance!

Install any app from the app store. That should restart the cloud sync function.

Hm, that does not work for me, I always get the error " could not be downloaded because of an error (Error: unable to retrieve information from server [RPC:S-…])" (freely translated from my german output) when trying to install an app or update. Reinstalling the Google apps did not help either.

Thanks to the Fairphone team for this, all fine here.

One detail though: When I want to CANCEL Google stuff installation, it’s a bit tricky. There is a HUGE Google button and a tiny [×] in its corner. I must be very, very careful to touch the [×] and not accidentally start what I do not want.

In this thread you will find various solutions to RPC errors, I hope one of them works for you:

1 Like

The common approaches there did not work for me.
However, I realized that I never did the storage fix so I’ve done it now and then restored the apps. Everything is back working. Thanks for your time!