Error retrieving information from server [RPC:S-7:AEC-0]

For the last 2-3 months I’ve been getting this errormessage each time I try to download a new app or update the existing ones.

“Error retrieving information from server [RPC:S-7:AEC-0]”

I’ve been through numerous guides on the nett searching for an answer and with the exeption of resetting the phone to factorystatus I’ve tried them all. I really do not want to resett to factorystatus since that would lead to a large amount of work shutting down and resyncing my google 2FA which I use for cryptocurrencies.

I’ve been in contact with Norwegian google support to get an answer, which took an extra month before I had to nag and they finaly sent my case to a specialist.

Now the specialist blame it on the fairphone! Saying that the Fairphone does not have support for using google play store. WTF? I have not seen a complaint similar to mine in this forum, and with something close to 50000 units out there one should think that there would be a few cases.

What to do next?

2-3 months, wow. I would have quite directly asked here if anybody would have had the same error message…

It could be helpful for us and others to state what you tried, which did not work. Maybe, then someone can spot another option.

Just FTR, I think that “specialist” is trying to get rid of you. It’s true that FP does not come with pre-installed Google Apps, but I did not see anyone on the forum yet with that specific error message, and the majority of users is definitely using GooglePlay services, including the PlayStore.

Agree, he just wants to get rid of me.

I have cleared data and cache from play store and google services, removed google account, rebooted, and added account. No luck.

Dear Sven Erlend,

I had the same problem and found this help site: (“Problems downloading apps & games” at Google Play Help)

I went through the list and the problem was solved after I tried the fifth bullet point (Reinstall Play Store updates).

I wish you good luck!



Did the above resolve your problem?

@Johanna, Thnx.

@Chris_R, No.I’e done all the steps in the link. When I try to reinstall play store updates I get another quite similar error message and no updates will download.

The error is somehow connected to that my google account won’t sync properly, even though all aplications for the account lists as recently synced.

After I deleted the google play services updates as mentioned in another problem solution guide the option system updates wont even show in the “about phone” section. google authentificator was momentarily out of sync and scared me something bad, but luckily that one would sync.

Google support just keeps saying it’s the fairphone, indicating that google play might not be compatible with fairphone.

Also tried these steps:

Mmhh intriguing

Have you tried removing your google account altogether from the phone and then re-adding?

To do this you’d go to Settings > Accounts > Google > Select your google account, then click the settings button (bottom left button on your phone) and select remove account.

To re-add go to Settings > Accounts > Add Account and then go through the setup

Several times by now :frowning:

Found this thread.

Seems I’m far from alone, kind of pissed of on Google who almost had me factory reset my phone. Tomorrow I’ll call direct support to rant at them.

Google just keeps telling me there’s nothing they can do since the fairphone is not a supported unit by Google, both with regards to the syncing and the downloading.

I really don’t know what to do, any tips?

Sorry that this isn’t getting anywhere quickly.

Did you ever try doing a hard reset? I know it’s not the best solution in the world, but I suspect it will resolve it.

Im having the same problem exactly, I’m new to fair phone and its been a problem since I got it. Spoke to Google who say its the phone, I agree they could be fobbing me off. Theres a lot of other posts on forums sharing the same problem, however nothing is working for me.
Its pretty bad, basically I can’t really use the phone other than for basic calling and texts. None of the apps will update and I can’t install the ones I need such as pdf reader etc.

Any solutions?

@rachelanderson Have you tried alternative app stores, like F-Droid or Amazon app store? If you only need the apps, you could try to download them there.

@Chris_R , no, I have to reset alot of 2FA functions around diferent exchanges before I can do a hard reset. I keep procrastinating in regards to that, much hazzle.

@rachelanderson, There are som different advice in this thread

This is very ugly error on android and there are some steps to resolve this issue.
You can check for finding some appropriate solution.

I have the same problem and the exact error message every time I try to update or install a new app and I can’t sync gmail app with my Google account. I tried every possible way, cleaning cache and data on both download manager and Google play, removing and re-adding account and uninstalling and re-installing play store updates. Still no luck. Except a hard reset which I definitely don’t want to do it. Now, did you guys find any way? Please let me know.

No, I’ve had no success with finding a solution. I’ve messes around with the time settings and updated the credit card information for my google wallet, but no luck. Factory reset is the only thing left.

Hi guys. Had the same issue and found the following forum:
If you scroll down you find a post by bman6074:
Ok, just in case
another comes across this thread. I had this exact error message. Contact
google via online chat. they had me walk through

  1. Turning off Automatic Date & Time and Automatic time Zone.
  2. Then set the time and date manually incorrectly (few years back and
    different time).
  3. Then go to the home page. Now back into date & time and manually change
    it to the correct date/time and timezone.
  4. Then choose the automatic check boxes.
  5. Now try downloading apps.

Followed all the steps and voila my Fairphone seems to download all updates and new apps at the moment - fingers crossed!


I found this solution maybe you can find here

“””” A Fix For Not Being Able To Download Or Install Apps From The Google Play Store
For People Who Have Tried EVERYTHING And It Still Doesn’t Work !!!”””””””””

To keep a long story short, I had decided to start using an older Android phone of\my wife’s. So I decided to factory reset it so I could start fresh on it. Well after it restarted it immediately began to bitch about not being able to connect to server. Then when I opened the play store everything I tried to download was Error retrieving information from server. I tried everything I could think of but nothing worked. Then hitting the forums and trying everything listed in them at least 10 times. So I was about to just give up then my little voice said try this one last thing and to my surprise it WORKED. Everything was working, updating and downloading. Here are the steps to what I did.

  1. Remove all accounts and yes this means do a factory reset
  2. Restart the device
  3. After start up DO NOT and I mean DO NOT create, link or sign in using your google account info. Hit skip this step and let the device fully start up.
  4. After is has started and you have a data connection open the Play Store
  5. At this time NOW sign in with your google account info.
  6. Just sit back and enjoy watching the updates come zooming in.
    I don’t know why this worked or how but it worked. I am posting this so that others who are as frustrated as I was, might have a chance at PEACE. May this post save others and lead to calm.

Thank you!
Following these exact steps did work!
No more errors whatsoever!

1 Like