Software update Kola Nut 1.8.7 is ready - Stagefright fix

Thank you for this update. This company also does a lot to keep the phones already sold in good shape and up to date. This is not at all self-understood, as you can read everywhere. Everything with the update just went fine with my phone.

You all do a great job



For me the update itself and reinstalling the Google apps went alright.
But I am not getting any notifications of the google apps. E.g. if someone writes me on Hangouts there is no notification, also when I get an email. Anyone has a clue how to fix this?

Thanks in advance!

Install any app from the app store. That should restart the cloud sync function.

Hm, that does not work for me, I always get the error " could not be downloaded because of an error (Error: unable to retrieve information from server [RPC:S-…])" (freely translated from my german output) when trying to install an app or update. Reinstalling the Google apps did not help either.

Thanks to the Fairphone team for this, all fine here.

One detail though: When I want to CANCEL Google stuff installation, it’s a bit tricky. There is a HUGE Google button and a tiny [×] in its corner. I must be very, very careful to touch the [×] and not accidentally start what I do not want.

In this thread you will find various solutions to RPC errors, I hope one of them works for you:

1 Like

The common approaches there did not work for me.
However, I realized that I never did the storage fix so I’ve done it now and then restored the apps. Everything is back working. Thanks for your time!


So far my attempts at installing the update have been going like this:

  1. Get message update 1.8.7 is available: fine
  2. download update: fine
  3. restart phone: fine
  4. android robot flat on it’s back with exclamation mark “no command” : uh-oh…
  5. wait a bit…nothing happens…: uh-oh…
  6. press on/off button to enter recovery mode, reboot phone: fine
  7. phone starts up as if nothing happened and back to step 1

I wouldn’t mind installing the update manually (again…), but I don’t understand why apparently these updates go smooth on some phones while on others they don’t work at all?

Either way, any suggestions are most welcome, thanks

1 Like

Plug in your phone to charge it, go to settings > developer options and tick stay awake. The screen needs to be active during the update at all times.

Already tried that and just tried it again, but to no avail. I keep getting the dead robot (no command).

This guide should help you in that case.

Very good tipp. If you forgot, like i do regularly, you can make Google call you or send you a message with a working code.

1 Like

Hi Paul, thanks for the hint. I followed the guide, but my phone didn’t show the folder “updater” and a few other folders were missing too. Why is this?? Anyway, I rebooted the phone again, used file management to cut and paste the downloaded zip file to a folder that did show up in recovery mode (\storage\sdcard0\updater) and followed the guide again, which seemed to work this time.

Thanks for the help,

edit: so I’m having the same problem now when reinstalling the app store. The updater downloads the file ( to te folder (\phone\updater) but on restart i get the dead robot again. I will try moving the file to a different folder and isntall the store manually I guess
edit 2: yup, that did the trick as well.


All fine here, too (with screen activated while downloading and updating!).

1 Like

A post was split to a new topic: Contacts missing 2 days after update

Dear Fairphone Team,

Everything went perfectly. Thank you very much! :kissing_heart:



I think in my case the update worked even with a black screen inbetween.
I did not activate the “stay awake” option and the phone was not connected to the charger all the time …
But update worked completely fine!

Yes that stay awake trick is not necessary for everybody and of course the screen will be black a few seconds during reboot.
But sometimes the screen will go to sleep before or after the reeboot and the thing will go wrong.

I am a real clever phone novice. When I look at right page to install Google apps I do not even get this:
Scroll right ad find Menu Button… I scroll right and do not have a menu button. what does it look like?
What is a menu app and where can I find all these updaters?

Are you talking about step 3 in the interactive tutorial?
If you don’t have that widget with the menu button you can also get there by performing an edge swipe.