SD card problems although formatted as portable storage

Hi everyone!

My FP4 has just arrived :partying_face:

Although I don’t use a Google account, I managed to (manually) migrate most of the apps and data from my old Samsung Galaxy A3 without any major issue. The problems started though when I inserted a fresh 128 GB SD card (SanDisk Extreme microSDXC UHS-I A2) and formatted it as portable storage. As I read in the forum, this is the preferred option as it’s supposed to work better than formatting it as internal storage.

Yet, while the SD card seemed to work at first, OsmAnd~, for instance, gave me I/O errors when trying to save offline maps on the SD card. Similarly, accessing Android’s basic folder structure from the computer didn’t work. I tried to format it again now receiving the error that the card is not supported (anymore) and needs reformatting. I tried it once more without success. Android still claims that the SD card is not supported whatsoever. I thus got it out of the phone and tried reformatting it to exFAT both on my Linux machine and on Windows 10 (via diskpart). Again, the SD card seemed to work at first but in fact didn’t when trying to copy files. Interestingly, it works flawlessly when using it on Windows/Linux only.

I also tried another SD card, my old SanDisk Ultra (XC I, Class 10). The problem is exactly the same. So it shouldn’t be the SD card.

Has anyone experienced the same issue? Any tips? I’ll contact the support sometime soon anyway but just wanted to hear your opinion first. Thanks in advance!

1 Like

Hi and nice to see you got your new phone :package:

Could you try formatting the card in the galaxy A3, or another phone first? There is a known issue that’s preventing the formatting of larger SD cards to work properly as portable storage. It should however work if it’s formatted first on another phone.

Let us know how you get on.


I don’t have an FP4 but formatting as portable is the favoured option for many.

  • The data on it is not encrypted to the phone so you should be able to access your files on ‘any’ pc/phone

So you initial formatted it via Android 11 on the phone as portable and then later it fails to recognise it ??

That makes sense as it is encrypted you can only access the portable SD not Android.

Great! Thank you! So, ideally I shouldn’t get prompted for another round of formatting on my FP and use it right away? I’ll try that as soon as I get hold of another phone :smiley:

1 Like

Yeah. You’ll be asked when you insert it if you want to use it as portable or internal. But it shouldn’t then ask you to format


Have you tried formatting on your PC that’s what I do?

All my SD cards are formatted on a PC and they all work in the FP3

I did … both on Windows and on Linux. But the FP4 always asks for reformatting.


@Chris_R We need your expertise more often here, I never heard of that known issue before :blush:


Let’s see if that worked first before suggesting I’m an expert :stuck_out_tongue:

It’s because I’ve had this issue and have reported. I know the dev team are aware of it, and it’s not an isolated situation.


It worked! The FP4 seems to destroy the file system in a way that even the Galaxy A3 couldn’t handle it at first. I formatted the card again on Linux, inserted it into the A3, did the initial setup there, and then put it back into my FP4 where I skipped the initial setup of the card. No error for now … hope it lasts.

@Chris_R, do you have any more info on how large a “larger SD card” needs to be for the FP not to get formatted properly?


Great. Glad it worked.

I don’t have a definitive answer as I was only able to test it on an 8gb and 128gb card. The 8gb had no issues. I didn’t want to try my 64gb card as that’s full of stuff I didn’t want to trash :stuck_out_tongue_winking_eye:

1 Like

My 64 GB card also had issues. I guess, with 128 GB or more internal storage, hardly anybody will add substantially less than that. So its definitely something to keep in mind as more and more people are starting to use the new FP. Thanks again!


I’m a ‘hardly anybody’ with my 4, 8, 16 and 32 GB cards, :slight_smile: They are old like me, from the last century.

1 Like

Hi there,
I’m new to the forum. I have a similar issue with the SD card(s) in my new Fairphone 4, which I’ve had for about three weeks now. Since the suggested solution did not work for me, I wanted to post here showing my problem.
I keep music on my SD card which the FP doesn’t correctly recognise and the music player app (Pulsar) does not play. Not all files appear in the file explorer, and the bit that is there can’t be played. Checking the music files on the computer, everything is there and can be played.
Pictures and videos taken with the FP camera saved on the SD card started being damaged while saving or disappearing altogether two days ago, without me being able to recover them via computer.

I’ve tried an old and another freshly bought SD card (bc I first thought the old card is broken; both are by SanDisk, the same as OP - has someone tried with another manufacturer’s model? I don’t have any at hand rn), always formatting as portable storage, tried several times formatting and reformatting on the computer and inside the FP and nothing worked.

Also getting random notifications “issue with SD card - tap to fix” which prompts the FP set-up. Following the set-up and then trying to put the music there does not help.
Sometimes the system shows “ejecting SD card - don’t remove” and when I press “manage” I can’t really do anything. These notifications disappear after a restart, but show up again after 1-3 days.

However, I think I found out that the FP formatting seems to not work properly on my device. When being prompted to fix the SD card issue or for initial set-up and formatting the SD card as portable storage (which should erase all data anyway), the FP file explorer shows the card is clean afterwards, but when I put it into the computer, all files are there and the music can be played, which means to me the formatting did not work. This happened every time I tried, not only once.

I also tried this thread’s solution by formatting at the computer first and then formatting on another phone (in my case, a Samsung Galaxy Note 10) and skipping the FP set-up, which didn’t help either.
So I’m here posting to ask if anyone has got other ideas (apart from a factory reset, see below). My other ideas would be it’s an issue with the SD card slot or a compatibility problem related to the manufacturer (SanDisk), but I can’t test this rn. Has anyone got other experiences related to this?

(Side note: In the music player app Pulsar there appears a java language script error message, the media format may not be supported. I tried with the original MP4 and M4A files mixed and with everything converted to MP3, both doesn’t work. The player worked fine on my old phone and YT Music on the FP works too, with the bit of music that is visible/accessible, but there is still the issue that most music in either format does not appear in the file explorer on the phone. Also, independent of the music format, it’s always the same pieces that seem to be there and all the others not, and I haven’t found out what this causes.)

My Fairphone 4 is updated to the newest software/security fix, the OS is the preinstalled Android 11.
I contacted support about this and they suggested I perform a factory reset, which I treat as last possible solution bc the procedure with backing up all chats etc. takes a lot of my scarce free time and I still hope there is an easier solution.

Looking forward to hear from you and glad for any bit of help, sorry for the long post :sweat_smile:


For future user, could you name which Sandisc SD you exactly tried? I think on the long run we might open a wiki listing compatible SD cards for the FP4 as well, so your experience might help. I think we have seen issues with some SanDisc Versions while others worked well.

For the issue, just a few thoughts (hope I did not overlook in your summary, hat you already tried):

  • which file explorer do you use?
  • did you try another music player (is YT Music comparable player app?) It seems VLC is still one of the best

Edit: change log of Pulsar indicates there where compatibility issues with A11+A12, is your App up to date?


Thank you for your reply anf for reading, yes I can provide the info. I’m sorry that I forgot.

SD card: SanDisk microSDXC Card 128GB ExtremePro A2 (UHS-I)

File Explorer: The App called “Files” on the FP (and Android in general I think). Computer explorer is Windows 10, freshly reset (bc of other issues unrelated to the phone) and up to date.

YT Music has the same issue. I did try VLC too, bc I thought it can open so many different file types, maybe it helps. However, the issue persists there. It worked insofar that it could open the M4A files iirc (it’s about a week or two ago so I’m not sure if I remember everything correctly), but still it didn’t show all my music, only about a third of it (unrelated to the media format - some of it that showed was MP3, some was M4A. After having tried to format the SD card as it was suggested here, I could try that player again.)

I installed and re-installed Pulsar several times already, so honestly I just thought it will install the most recent app version automatically.

There is a file Explorer called Total Commander. I never used it, but the people who use it, say its a quite good file manager App and has more options as others. You could give it a try (just note it seems the surface needs getting to used.

Overall, if I would be you, I think I would put some of my music to the Internal storage and wait to use an SD card, until further information is known and the teething troubles are sorted out.

1 Like

I think I’ve seen Total Commander at my workplace, but I never used it.
Anyway, I think I’m just going with the music I have on Spotify (internal memory) and see if there will be more information on this issue later.

1 Like

It seems to work fine with a Samsung EVO Plus SD Card (256 GB; microSDXC UHS-I).

1 Like

I can’t get my Samsung EVO Plus 128 GB to work with the FP4 either. The FP4 doesn’t manage to format the SD card as portable storage: It starts, briefly shows a progress bar at 20%, then immediately reports success, but not rightly so. Then a permanent notification appears saying “This device doesn’t support this Samsung SD card. Tap to set up in a supported format.”

I have also tried formatting the SD card (exFAT) using Windows and putting files on the card that way. But when I plugged it back into the FP4, it showed the same notification as above.

(Edited: I will #contactsupport to say: Please let me know if and how I can assist in resolving this issue.)