Proximity sensor goes crazy while calls

Hello to all!
I have had an FP4 for just over a month and am very satisfied. Especially the sustainable concept is great. However, I’ve had a problem with the proximity sensor for a few days.
First of all, when I use the phone normally (hand-held, not talking on the phone), I don’t have any problems. The problem only occurs when I talk on the phone with the phone to my ear.
The problem is that sometimes the screen turns on and the touch function is also activated, even though I hold the phone to my ear. This is annoying in that it sometimes causes me to accidentally “press” buttons with my cheek. For example, I have already muted myself in this way during a phone call.
I haven’t installed any apps or changed any settings, so that can’t be the problem.
Is my problem known? What could be a solution?
Thank you very much for your help!

4 Likes

The same problem has been reported here (in German). Maybe you can check the function of the proximity sensor in the test app. You can find it in the My Fairphone app or by dialing *#*#2886#*#*

1 Like

Thank you for your reply. I have already tested the proximity sensor in the way you describe before posting my problem. According to the test app the sensor works fine.

I also sometimes have problems with it but not as extreme as you describe it. For example, when I want to listen to a Telegram voice message on my ear, the sensor seems to have a delay and playback is very loud (speaker mode) for half a second before switching to descrete mode.

Same Problem here. Sensor ok. Screen sometimes turns on while I’m on a call.

As a workaround it helps to actively turn off the display using the power button, just ensure to disable the "power ends call function if enabled in the settings

4 Likes

Thank you for your answer. I will use this but only as a workaroud. A still prefer a fix of this problem.

4 Likes

I’ve been having the same problems, I think it started a couple of days ago. It’s very annoying! Could it have anything to do with the last Fairphone update? I think I installed it right before my problems started.

2 Likes

I have the same problem and the power button is only a work around, it was also a problem on my FP2.

Update:

Unfortunately, the support does not help. After the request to perform a test of the proximity sensor (as has already been recommended here), it is directly recommended to perform a hard reset. After my refusal (I hardly believe that a hard reset will change anything about the problem), I am told to send my phone to France for repair. This is not an option, as I cannot do without telephone accessibility.

1 Like

I have a possible solution for everyone:
I recently stopped using the Google dialer app for privacy reasons and started using the dialer app from Simple Mobile Tools. Since then the problem is solved! So if it comes into question to no longer use the Google dialer but a third-party app, that might solve the problem.

4 Likes

Good to see you’ve accomplished what many, including Fairphone couldn’t. Yes and a repair would have done a reset anyway.

Hopefully you will have told support of your findings.

1 Like

Isn’t that app filled with adds?

No. It’s ad-free actually.

1 Like

Great - thanks for info!

When will this really annoying issue be solved by Fairphone finally? Is it a software or a hardware problem? The workaround with the power button is no final solution for a phone which claims to be technically up to date I believe! Unfortunately I cannot recommend the FP4 to my friends as long as this bug is not solved.

Did you #contactsupport reg this?

And did you try this

Thanks for the quick reply! I have just #contactsupport reg this. Let’s see what they say. I am not sure if I manage to deinstall the Google dialer app and I think Fairphone should solve this problem rather.

BR, Michael

image001.jpg

image002.jpg

Sure it would be good when they fix it sooner than later and for the time being I would like to have workarounds, so that I do not need to be upset all the time. You cant deinstall the APP, but once another phone APP is installed you would be able to deactivare through settings-apps

Ok, thanks! I will try to install the dialer app from Simple Mobile Tools . Hopefully I succeed in doing so :wink:

image001.jpg