"Liquid or debris in the USB port?" notification

I’ve got this message as well, with all kinds of cables. A few of them seem fine, others (Like the one from Fairphone for 65watt charging) I get this error.

Would a new USB-C connector help you think?

In my case changing the USB-C port solved the problem. As you can read above I replaced it beginning of January (I forgot to update this thread, I’m sorry) and never had the issue since then.

This is not a suggestion to change the USB-C port as I can’t guarantee all FP5s showing this problem can be fixed this way.

I’d ask the support if it’s the right choice.

Regards,
Massimiliano

Hello,
I am currently in contact with the customer support, but wanted to share my experience too.
My issue is, that after ~30 seconds after plugging any cable with any charger (which worked in the past) into the USB port, it stops charging and shows the “Liquid or debre in USB port” notification. I have a very awkward workaround with powering off the device and loading it while powered down. Basically it restarts every 30 seconds or so, loads for a couple of seconds and like that I can charge it a bit. It takes hours though.

I already tried replacing the USB port but no luck. I fear it might be a software issue, since it started to happen regularly after I upgraded my /e/OS versioon to 1.21 which also introduced a new FP OS version as far as I know.

Does anyone have similar experiences?

EDIT: I just found out that reverting to an older version of my OS will probably trigger a factory reset wiping all my data. I’d like to avoid that atm, since setting everything up again will be a pain. So I cannot figure out if this issue was triggered by a upgrade.

I tried different USB cables and even bought an original FP Charger but nothing seems to work. Anyone else experiencing the error message like me after an FPOS update?

i don’t see this message after FPOS update, only see a few times in the past when connect bad/poor_quality cable, but when i use “normal” cables (PremiumCord, Vention, AlzaPower) which is USB 2.0 or 3.x with “USB-A ↔ USB-C” or “USB-C ↔ USB-C” newer have this problem…

Hello,
I really like Fairphone and it’s mission and especially my FP5 I have since the end of last year, but recently I am experiencing an issue when I try to charge my phone. I already posted in different threads about it, but seeing that the symptoms are not identical I figured, a new post is warranted for this, in which I can go into details, what is happening, what I tried and so on.
Fairphone Customer service is already informed and I will send them this thread too, but as of now they couldn’t help me.

Environment
Model: Fairphone 5
OS: /e/OS 1.21 with unlocked bootloader

Issue
When I plug in my FP5 to charge, it works for ~30 seconds and then stops with the notification “Liquid or debris in USB port” which leads to the USB port being disabled for safety.

Lead up to the issue
I encountered the same message a few times already in the past, where I cleaned out the port with a toothpick and fair enough, there was some dust in there. After cleaning it worked again normally.
Also there was an /e/OS update prior to the issue becoming permanent, which also updated the FP firmware to TT45 FPOS.
Prior to this update I could charge normally.

Workaround
Luckily I figured out a workaround. When the phone is turned off and I plug the charger in, it displays the chharging animation for up to a minute and then turns black and reboots apparently and then charges again, basically creating a loop. At around 50% charge it usually stops completely and I have to unplug it and plug it back in so it can continue the cycle until it reaches 100%.
This is the only way I can charge it now which is annoying.

What have I tried
Naturally when the notification appeared the first few times I tried cleaning the USB port and the charger cable but that didn’t work.
I tried different USB-C to USB-A cables with my normal charger I use all the time, which also charges all other devices normally and did so with the FP5 too.
I tried a different charger.
I even bought an original FP quick charger and tried charging with different USB-C to USB-C and USB-A cables. Here what I found interesting is, that when I try to use USB-C to USB-C on the FP quick charger, it immediately shows the notification. With USB-C to USB-A it charges for 30 seconds before stopping.
I also replaced the USB port just to be absolutely certain that there is nothing in there. The notification keeps showing and interrupts the charging.

Speculation
I am not 100% sure, but I think, that the issue really started after the recent upgrade to /e/OS 1.21 which also introduced a FP5 firmware update to T45 FPOS. Since changing the USB-C port didn’t work, I think this might be a software issue, either in /e/OS or in the FP firmware.

Next steps
The only thing I can think of, is trying to revert the OS update. But this will lead to all of my data being wiped, due to the unlocked bootloader probably and also has the risk of bricking the phone due to different android security versions (not sure though).
Sending the whole phone in to Fairphone to repair it is also an option, but would probably also lead to data loss and I’d probably have to setup /e/OS again since as far as I know they would flash it with FPOS.
So I am delaying these steps in the hopes to fix it with less risky and costly measures first.

Related posts

If anyone is experiencing a similar issue, I’d be glad to hear about it. At this point I am desperate for any help, since the charging situation is really suboptimal… F.e. I cannot use it as alarm in the morning and while it charges…

Thank you for reading until now and have a great day!

See above for further posts

1 Like

This is my recommendation (what I’d do in your case):

  • do a backup using Android backup project . It won’t work for all apps, but for a lot of them. As you’re using /e/OS you’ll find the necessary ADB root option in developer options.
  • or at least use the seedvault backup included in /e/OS (which will probably backup even less apps)
  • backup data of your important apps using the app backup functions of those apps
  • install FPOS. As long as you don’t relock the bootload you won’t brick the device independently of the security patch version
  • let your device repair by Fairphone
  • reinstall /e/OS on the repaired device and restore your apps
1 Like

Hi,
I have exact the same issue as Antonio.

But I use a regular Android 13.
I guess also that this is a software issue, but I’m not willing to do a factory reset or send the phone back to fairphone. I bought it 5 weeks ago, since 2 weeks I have this issue.

Have some one an idea to solve this problem?

Can anyonye tell me, where exactly the Liquid sensor is located? On the USB-C port, which I already replaced?
If not then it will a hardware issue, otherwise it is a software issue and I will wait to Android 14.
It is frustrating that the message can’t be overtuned manuelly to reactivate the USB-C port. Also I can’t delete the USB cache (USB Settings are not available on Android13).

1 Like