"Liquid or debris in the USB port?" notification

I’m using a FP USB cable with a FP USB charger (both bought in Dec 2020 with my FP3+).

I started having this problem with FP5, never had with my previous FP3+.

However, I changed the USB-C port a couple of weeks ago, let’s see if this makes any improvement.

Ciao,
Max

Perhaps it’s an idea to use a magnetic cable.
In this way you ‘close’ the USB-port and the port has less wear and tear.
Make sure that you have a magnetic cable capable for charging ánd data.

Hello
Just had this message after checking a new cable and walking in rain/snow.
I cleaned my port and checked with another cable, it worked fine.
But with this new one, the same brand, still the same message and no connection.
So I will be returning the new cable.

So I guess there may be many factors in place, but not necessarily a bug.

1 Like

I’ve got this message as well, with all kinds of cables. A few of them seem fine, others (Like the one from Fairphone for 65watt charging) I get this error.

Would a new USB-C connector help you think?

In my case changing the USB-C port solved the problem. As you can read above I replaced it beginning of January (I forgot to update this thread, I’m sorry) and never had the issue since then.

This is not a suggestion to change the USB-C port as I can’t guarantee all FP5s showing this problem can be fixed this way.

I’d ask the support if it’s the right choice.

Regards,
Massimiliano

Hello,
I am currently in contact with the customer support, but wanted to share my experience too.
My issue is, that after ~30 seconds after plugging any cable with any charger (which worked in the past) into the USB port, it stops charging and shows the “Liquid or debre in USB port” notification. I have a very awkward workaround with powering off the device and loading it while powered down. Basically it restarts every 30 seconds or so, loads for a couple of seconds and like that I can charge it a bit. It takes hours though.

I already tried replacing the USB port but no luck. I fear it might be a software issue, since it started to happen regularly after I upgraded my /e/OS versioon to 1.21 which also introduced a new FP OS version as far as I know.

Does anyone have similar experiences?

EDIT: I just found out that reverting to an older version of my OS will probably trigger a factory reset wiping all my data. I’d like to avoid that atm, since setting everything up again will be a pain. So I cannot figure out if this issue was triggered by a upgrade.

I tried different USB cables and even bought an original FP Charger but nothing seems to work. Anyone else experiencing the error message like me after an FPOS update?

i don’t see this message after FPOS update, only see a few times in the past when connect bad/poor_quality cable, but when i use “normal” cables (PremiumCord, Vention, AlzaPower) which is USB 2.0 or 3.x with “USB-A ↔ USB-C” or “USB-C ↔ USB-C” newer have this problem…

Hello,
I really like Fairphone and it’s mission and especially my FP5 I have since the end of last year, but recently I am experiencing an issue when I try to charge my phone. I already posted in different threads about it, but seeing that the symptoms are not identical I figured, a new post is warranted for this, in which I can go into details, what is happening, what I tried and so on.
Fairphone Customer service is already informed and I will send them this thread too, but as of now they couldn’t help me.

Environment
Model: Fairphone 5
OS: /e/OS 1.21 with unlocked bootloader

Issue
When I plug in my FP5 to charge, it works for ~30 seconds and then stops with the notification “Liquid or debris in USB port” which leads to the USB port being disabled for safety.

Lead up to the issue
I encountered the same message a few times already in the past, where I cleaned out the port with a toothpick and fair enough, there was some dust in there. After cleaning it worked again normally.
Also there was an /e/OS update prior to the issue becoming permanent, which also updated the FP firmware to TT45 FPOS.
Prior to this update I could charge normally.

Workaround
Luckily I figured out a workaround. When the phone is turned off and I plug the charger in, it displays the chharging animation for up to a minute and then turns black and reboots apparently and then charges again, basically creating a loop. At around 50% charge it usually stops completely and I have to unplug it and plug it back in so it can continue the cycle until it reaches 100%.
This is the only way I can charge it now which is annoying.

What have I tried
Naturally when the notification appeared the first few times I tried cleaning the USB port and the charger cable but that didn’t work.
I tried different USB-C to USB-A cables with my normal charger I use all the time, which also charges all other devices normally and did so with the FP5 too.
I tried a different charger.
I even bought an original FP quick charger and tried charging with different USB-C to USB-C and USB-A cables. Here what I found interesting is, that when I try to use USB-C to USB-C on the FP quick charger, it immediately shows the notification. With USB-C to USB-A it charges for 30 seconds before stopping.
I also replaced the USB port just to be absolutely certain that there is nothing in there. The notification keeps showing and interrupts the charging.

Speculation
I am not 100% sure, but I think, that the issue really started after the recent upgrade to /e/OS 1.21 which also introduced a FP5 firmware update to T45 FPOS. Since changing the USB-C port didn’t work, I think this might be a software issue, either in /e/OS or in the FP firmware.

Next steps
The only thing I can think of, is trying to revert the OS update. But this will lead to all of my data being wiped, due to the unlocked bootloader probably and also has the risk of bricking the phone due to different android security versions (not sure though).
Sending the whole phone in to Fairphone to repair it is also an option, but would probably also lead to data loss and I’d probably have to setup /e/OS again since as far as I know they would flash it with FPOS.
So I am delaying these steps in the hopes to fix it with less risky and costly measures first.

Related posts

If anyone is experiencing a similar issue, I’d be glad to hear about it. At this point I am desperate for any help, since the charging situation is really suboptimal… F.e. I cannot use it as alarm in the morning and while it charges…

Thank you for reading until now and have a great day!

See above for further posts

2 Likes

This is my recommendation (what I’d do in your case):

  • do a backup using Android backup project . It won’t work for all apps, but for a lot of them. As you’re using /e/OS you’ll find the necessary ADB root option in developer options.
  • or at least use the seedvault backup included in /e/OS (which will probably backup even less apps)
  • backup data of your important apps using the app backup functions of those apps
  • install FPOS. As long as you don’t relock the bootload you won’t brick the device independently of the security patch version
  • let your device repair by Fairphone
  • reinstall /e/OS on the repaired device and restore your apps
1 Like

Hi,
I have exact the same issue as Antonio.

But I use a regular Android 13.
I guess also that this is a software issue, but I’m not willing to do a factory reset or send the phone back to fairphone. I bought it 5 weeks ago, since 2 weeks I have this issue.

Have some one an idea to solve this problem?

Can anyonye tell me, where exactly the Liquid sensor is located? On the USB-C port, which I already replaced?
If not then it will a hardware issue, otherwise it is a software issue and I will wait to Android 14.
It is frustrating that the message can’t be overtuned manuelly to reactivate the USB-C port. Also I can’t delete the USB cache (USB Settings are not available on Android13).

1 Like

Sadly the workaround I posted about is starting to be less efficient. Before it goes into the charging/restarting loop I sometimes need to remove the USB-C cable multiple times. I fear that I won’t be able to use the FP5 at all in a couple of days.

I will send it in to FP for repair. Hopefully I get enough charge from the current charge cycle to backup data and restore FPOS.

Thank you for your post @Eric85, that shows me, that it might really be software or at least malfunction in the non repairable hardware.

Dear all,

I had the exact same issue on my first FP5 a few months ago. I sent my phone to support and they sent me back a new one without telling me what was the issue.
This morning what a surprise: same issue, again, on my new FP5… Obvisouly it never went to dust or moist.
@AntonioDell your guess on a software issue might be correct: the conversation I had with a support team member let me suppose that the issue has nothing to do with the notification, it is more a battery management issue (wrongly detecting a low current).

Best,

Félix

1 Like

Thank you for the reply! That is also one of my worries. I don’t think I will stick to FP if this issue is still present after I sent it in for repair. I support the mission, but at the end of the day a not charging brand new phone is a no-go. Even more so if a critical issue like this is not fixed immediately after discovering it and since already 2 other people reported this issue, there should be better communication about this other than “Try a different charger”.

I totally agree with you, this is too much for me as a user.
Especially because the support is not at the evel it is supposed to be : very slow reaction time, partial informations on the issue, and too much “try a different charger”
I will keep you informed about the support ticket I opened yesterday
Félix

I got a relative quick answer from the support and they asked me to perform some tests. I did so and you will find results here: Dear Michele,

You will find here the results of the test (on and a half hour of my time wasted for this phone): Fairphone 5 charging tests - Google Spreadsheets

Notes:

  • Every cable is in very good state - there is just one of my chargers that is obvisouly not working
  • “you have to try with a QC4” => I did it with my previous phone (same problem), at a professional shop and it did not work. Same behaviour.
1 Like

This is not a support but a user forum. So, posting a link to a spread sheet for the customer service here, doesn’t make any sense. Please send it to them via mail.

I can understand, that you feel angry about seemingly wasting your time with tests that don’t solve the problem. But it might give Fairphone customer service an idea if the problem is hardware or software related.

3 Likes

I am sending it in for repair on wednesday. Hope that it will be fixed then permanently. Will report back here :slight_smile:

I just reposted the content of my reply to Fairphone support team. My apologies if I broke some rules of this forum. I thought it might help people having the same issue.

Their answer is relativly simple : they think I might have used an incompatible type of charger, not recommended with FP5. And like the previous time proposing to replace USB-C port, what I did the first time it happened.

I am starting to lose patience and will get support from a consumer association to make sure I am refunded and then forget about this brand.