"Liquid or debris in the USB port?" notification

Today for the second time I experienced the “USB port disabled” issue.

My phone was on the table close to me and I noticed the notification about it, I clicked on it and the following pop up was shown.

The problem disappears after a reboot.

I’ve been using FP5 for a couple of weeks now and it never got in touch with water, dust or anything that could compromise the USB port.

Has anybody had the same problem?


1 Like

Haven’t seen this. Can you share a screenshot how it looks after you’ve pushed ‘got it’? Does the error persist in the top bar?

When I tap on “got it” the pop-up disappears but I don’t remember what happens to the notification.


I experienced this as well, but just one time from 18th September (when I received it) until today, it appeared while it got charged while I was driving my car. But since it hasn’t appeared again in meantime, I hope it was just a software bug and nothing physical.

I got this notification when I attempted to connect the phone to an external display,

I guess it is a bug.

I just got the same alert after disconnecting the phone from the charger. The notification remains active and cannot be removed.

Update: after 15 minutes I tried to charge again and the notification automatically changed, this time saying that debris or liquid were no longer detected and that the USB port was usable again.

Just got this as well, plugged it into a charger (with slow charging and stop at 80%) overnight, and this morning after my coffee this prompt came up.

I clicked “got it” and nothing in the messages dropdown.

After a few minutes, I rebooted since my headset did not work. After a reboot it was fine.

Brrrr, sounds like a bug…

I got the same message, but only sometimes when connecting to my car, which android auto stopped working too. It didnt even charge my phone anymore (other phones work ok, I tried several cables too). The message dissapear after a few connect/disconnect the cable or a reboot.

My phone is in pristine condition, never habe been near water or high humigity environments,… to sum it up: android auto stopped working (a few days ago), then sometimes this message appear (first time today).

I’m able to charge (official charger, powerbank,…) and transfer files without issues. To me it looks related to the android auto usb communication (the car didnt get updated)

Same here. If you plug it in, wait a second unplug it and reconnect the phone to the USB c solves the problem. (at least in my case)

I’ve seen this message now, too, however I must admit that it was quite accurate: I had the phone in my pocket during cycling, USB-port up with a charging cable in it. I had a short rain shower (not much) and when I stopped later on to put the audio jack adaptor in I got this message. Removed it, briefly checked the port, plugged it in again, liquid and debris were gone it said.

Dear all,

since few days my phone automatically disables usb (C) port, notifying that debris or water are detected.
This happens whatever the usb cable and the source to which it is connected (computer, charger, usb port…). When the cable is unplugged, the phone says that the problem is solved…but it blocks again the port if replugged.

This makes impossible to charge the phone if switched on, and the transfer of file via usb.

Any ideas ?


Have you tried to open the phone and clean it?

Even if it won’t help, it’s so easy to do that I think it’s worth trying.

It’s also the first item in the list of things to do every now and then:

Let me know if it works…


Thanks a lot, I’ll try, even if I do not know how I should clean the USB port.

In any case, I bought the phone 1 month ago, it is quite annoying that it already causes problems.

I completely agree with you.

Another thing you could do is contacting Fairphone support and tell them about this problem. You could also send them a link to this thread.



Have you found a solution?
I have the same issue.

Kind regards

No I haven’t.

However, it’s not so urgent to me as it only happens every couple of months and only lasts until I reboot the phone (sometimes it disappears by itself after 10 minutes, half an hour…).

Is it the same for you?


I’ve got that message several times, in my case I tracked it down to a problem with the power management and the connected devices:

  • Either the cable connection is not reliable → in your case if it happens without anything connected it might be some issue/defect with USB port or internal connection of it.
  • The connected device does a poor job in managing the delivered power → I have a powered USB hub that causes this if I power the hub before connecting it to the phone, people complaining about issues with USB monitors might have this same issue.
  • The charger power protocol is not well implemented → I had issues with the same QC3.0 charger with other, but not all, phones - a cable/charger checker didn’t detect any issue :confused:

If this issue happens randomly without any interaction with the USB port, the port itself is clean and the phone has been placed in a dry and clean place, then it looks like a defect and you probably want to contact the Fairphone support.

1 Like

I’m using a FP USB cable with a FP USB charger (both bought in Dec 2020 with my FP3+).

I started having this problem with FP5, never had with my previous FP3+.

However, I changed the USB-C port a couple of weeks ago, let’s see if this makes any improvement.


Perhaps it’s an idea to use a magnetic cable.
In this way you ‘close’ the USB-port and the port has less wear and tear.
Make sure that you have a magnetic cable capable for charging ánd data.

Just had this message after checking a new cable and walking in rain/snow.
I cleaned my port and checked with another cable, it worked fine.
But with this new one, the same brand, still the same message and no connection.
So I will be returning the new cable.

So I guess there may be many factors in place, but not necessarily a bug.

1 Like