English

LineageOS fork including MicroG

Thanks for the reply…
I checked the settings in the app and in android … all on go!
I reinstalled the app but again no notification
(reinstallation worked for all other apps)
The strange thing is, that the microG GMS recongises the notification coming in, but they won’t get through.
Its like outlook app has a different way of using the GMS…

Thanks for your answer. Indeed, it is exactly the same issue.
As far as I have understood, the MicroG “fork” takes the original LineageOS-sources as starting point.
Is the bug tracker still valid for official LineagoOS? I am a little bit cinfused, I have to admit.
Cheers!

Yes, LOS for mG builds on top of LOS sources, and continuously* rebases its sources to get LOS security updates and fixes. Therefore, any bug or issue that isn’t specifically related to the microG integration belongs to LOS.

*= I don’t know the exact frecuency, but it seems to be daily by the wording on the webpage. Didn’t check myself, though.

Hi, i didnt use the GMS before but I activated to use register for signal and then kept it active for few apps (6) that uses it. However i have realized a higher battery usage and i can confirm somehow GMS tends to drain the battery.

I assume LOS + GApps suffers from this problem. Does LOS + mG suffer from this problem?

1 Like

Hi !
I updated to the last version (14.1-20171122-FP2) of LineageOS+MicroG (which correspond to the official image of 21/11/2017 I assume). I’ve kept the modem 4437.1-FP2-0-07.

@chrmhoffmann if it can help you, can I provide any logs, kmsg, etc. ?

For bug 24 please look at the tracker and upload the requested files there.

Chris

Obviously mG is not affected.

1 Like

For the ADB bug , have you Magisk installed? Then disable “Magisk Hide” option.

1 Like

Good hint ! I don’t have magisk but iSu instead, and indeed in the settings there is “control the state of ADB”. Mystery solved, not a LOS bug :smiley:

Maybe a little off-topic, but I haven’t found a better place for this:
I feel like I get huge lags on push messages from Signal since I am on LineageOS for microG with deactivated GCM. Does anybody experience this as well?

The time I used LOS without GCM, I just received push notifications, when the apps were active.
I think to activate GCM and reinstall the apps to register is recommended.

I have one exception … MS Outlook App still has issues with the push notes … still could not figure out why.
Cheers

Sure, for most apps that’s expeted behaviour. But Threema is configured to use polling and Signal is supposed to work without GCM by design.

Hey guys,

I am thinking about changing to LOS+MicroG. I think I don’t really need GooglePlay and its services… But I have still some questions.

  1. Question would you recommend it up to now? Waht are Pros and Cons?
  2. For what do I really need MicroG compared to a pure LOS without Gapps?
  3. How do I change from my LOS+GApps? I would like to avoid factory reset…

Hi LeonL,
in my experience, a lot of apps depending on GAPPS to work properly.
There are some apps I wanted to use and only could be found in the play store.
So, in my opinion microG is the best choice to be able to use all apps without having a googl account.

  1. so, yeah, I recommend it. one con -> there is and info that signature spoofing is an issue in terms of security, but I don’t think its that big
  2. Google Cloud Messaging (push notes), high precision gps for navigation and as I said a lot of apps depend on these services
  3. First I did a dirty install without factory reset but it could cause some issues with apps, so it would be better so make a clean install with a factory reset, I think

Cheers

1 Like

for 3. you can do the Dirt installation using the migration file that can be found here : https://download.lineage.microg.org/extra/7

follow this:

1 Like

Warning: Don’t encrypt your device with Lineage microG fork! I have done it and bricked it, it is unusual now:
Device: Samsung Galaxy S5 (klte)
Software: Lineage microG 14.1.2 - 2017-12-13 klte
I did the encryption, the device started with the Lineage animation, asked for the password and started again with the animation for hours and doesn’t stop anymore. The only way to stop it is to take off the battery. I can boot into TWRP recovery, but only into the first screen, the following TWRP (version 3.2.1-0) menue dosn’t show up. I don’t see the device anymore - conected via USB - at the Windows explorer.
Do you have any advice how to get the phone running again or where I can search for help?

I do not think it has something to do with MicroG especially, see here:

https://jira.lineageos.org/projects/BUGBASH/issues/BUGBASH-457?filter=allopenissues

According to the bug report, it happened on HTC and other Samsung phones, too.

2 Likes

Hi,
I don’t know the reason for this encryption issue. At my FP2 I don’t have any problems with the official Lineage OS and encryption, and the FP2 hardware is quite similat to the one of this Galaxy phone and the software is very much the same as well. Would be interesting, to know, whether others run into similar problems with encrypting their FP2.
I have managed now to get the phone back to work, at least half the way. With the original firmware and the “odin”-tool I managed to get it running again on the Samsung Android software. The unsuspected surprise: When the system has booted, it asks me for the PIN code to decrypt the system. And it is not the one, I used at my encryption exercises. So in the moment I don’t know, how I can solve this problem. Probably the easiest way is to wipe the system and install a new Lineage OS. Hopefully the encryption is gone with that process.

If it is similar to the Fairphone 2, you will have to explicitly format (not only wipe) the data partition to get rid of the encryption. TWRP can do that for you.

If things got really ugly, you perhaps need to destroy the LUKS header of userdata, too. Also via TWRP.