LineageOS fork including MicroG

Hi LeonL,
in my experience, a lot of apps depending on GAPPS to work properly.
There are some apps I wanted to use and only could be found in the play store.
So, in my opinion microG is the best choice to be able to use all apps without having a googl account.

  1. so, yeah, I recommend it. one con -> there is and info that signature spoofing is an issue in terms of security, but I don’t think its that big
  2. Google Cloud Messaging (push notes), high precision gps for navigation and as I said a lot of apps depend on these services
  3. First I did a dirty install without factory reset but it could cause some issues with apps, so it would be better so make a clean install with a factory reset, I think


1 Like

for 3. you can do the Dirt installation using the migration file that can be found here :

follow this:

1 Like

Warning: Don’t encrypt your device with Lineage microG fork! I have done it and bricked it, it is unusual now:
Device: Samsung Galaxy S5 (klte)
Software: Lineage microG 14.1.2 - 2017-12-13 klte
I did the encryption, the device started with the Lineage animation, asked for the password and started again with the animation for hours and doesn’t stop anymore. The only way to stop it is to take off the battery. I can boot into TWRP recovery, but only into the first screen, the following TWRP (version 3.2.1-0) menue dosn’t show up. I don’t see the device anymore - conected via USB - at the Windows explorer.
Do you have any advice how to get the phone running again or where I can search for help?

I do not think it has something to do with MicroG especially, see here:

According to the bug report, it happened on HTC and other Samsung phones, too.


I don’t know the reason for this encryption issue. At my FP2 I don’t have any problems with the official Lineage OS and encryption, and the FP2 hardware is quite similat to the one of this Galaxy phone and the software is very much the same as well. Would be interesting, to know, whether others run into similar problems with encrypting their FP2.
I have managed now to get the phone back to work, at least half the way. With the original firmware and the “odin”-tool I managed to get it running again on the Samsung Android software. The unsuspected surprise: When the system has booted, it asks me for the PIN code to decrypt the system. And it is not the one, I used at my encryption exercises. So in the moment I don’t know, how I can solve this problem. Probably the easiest way is to wipe the system and install a new Lineage OS. Hopefully the encryption is gone with that process.

If it is similar to the Fairphone 2, you will have to explicitly format (not only wipe) the data partition to get rid of the encryption. TWRP can do that for you.

If things got really ugly, you perhaps need to destroy the LUKS header of userdata, too. Also via TWRP.

Yes, it is! I have thought that this could happen and now it did:
I managed to install the TWRP recovery, I am able to boot into it, but than it asks me again for that mysterius password I don’t know, what it is and where it comes from! May be, it was created without showing it together with the encrytion issue, which stoppt the phone??? Before I tried the encryption, I did have a PIN to lock and unlock the screen, but the phone dosn’t take that one. Any other hint what it could be???
I am at the end of my humble scills because I can’t use TWRP; no wiping, no farmatting or deleting via TWRP unfortunately.
My hope: There could be a way via ADB and fastboot? But where can I find an instruction, how to do it?
I would be very thankful for any advice or reference!

Whatever the password is, TWRP only needs it to access the encrypted partition.
There is a “Cancel” button when TWRP asks for the password, so you can at least proceed and wipe/format everything.

You are completely right @AnotherElk! I have been blind for that button! And it works and it says, that with formatting the data partition you delete an existing encryption as well! So that’s quite good! But I have learned more about Android, TWRP and this phone: The PIN number I tried all the time was o. k.! Something else still is wrong. When I try to enter the TWRP recovery, the phone tells me “Kann Speicher nicht einhängen” = “can’t mount memory(?)” and later on some hundred times: “E: Error parsing XML file”. If I put in a wrong PIN, it tells me, that it is wrong, if the number is right, it takes it and I get only the mentioned error messages.
Probably that’s the reason for the encryption issue as well.
May be, somebody knows what to do with this?
The next thing to do now is to install LOS again and see if it works, without encryption of course!!
Edit, one day later: Again the phone runs on LOS 14.1 as it has done before the encryption issue.


Hi everyone,

I’ve been able to install easily this OS but I block in trying to use snapchat. The app is launching but I can’t login. I guess this is because Snapchat uses Google services and microG fails to replace it in some way.
I already activated Google cloud messaging and Google safety net in microG settings.

If anyone has this app working or any clue I would be happy to ear it :slight_smile: Thannks !

If it’s related with login, you may need to check “Google device registration” in microG Settings, too.

Hi Roboe, I had this feature activated as well but it didn’t work.
Someone gave me a solution which seems to be the only one so far.
I installed openGapps, logged me in Snapchat then uninstalled openGapps and finally installed again microG. Now I just can’t log out from my account but it works !

Hey guys, can someone explain me what I did wrong in the migration from LOS+OpenGapps to LOS+microg?
First my phone is encrypted. I hope that’s no problem.

What did I do?

  • Uninstall F-Droid
  • backup system, data etc on sdcard
  • flash migration zip
  • Wipe system, cache and cache/dalvik
  • Flash LOS+microg
  • reboot

But what happened is that OpenGapps is still there. No microg nothing…
Can someone explain me that???

I have to add that I cannot uninstall fdroid anymore as it is somehow a system app… so partly it seems to have worked…

Is it maybe a problem that the SD-card where I stored the Zip-files is an adopted storage??

Found a solution!
Factory reset.
Flash los+mircog
Recover data partition from a backup I did before with twrp
Erase with twrp advanced /data/app/com…Everything with google

Just had some issues with signal…:frowning: but now everything should be fine!


Did you try activating Google Devise Registration ? Cf post 20 :

For me the issue was solved by enabling the option that you are asked if apps can use gcm.

But I have also enabled device registration… :frowning:

1 Like

I gave this a try, but I cannot succeed in installing it. I’m coming from FPOpen, and I followed the instructions doing a full wipe, but at the end, when lineage OS reboots, there are no icons, just a black screen with the wrong time, as if there were no applications.

I noticed the instructions diverge between this version and pure lineage: one says to wipe Data, Cache, and Dalvik, and the other to wipe Cache, System, and Data. Which one is correct?

I also had issues wiping the Data partition (I guess because the phone was encrypted), so I first formatted it. The zip verification would also not succeed, so I disabled it.

Could someone please tell me what I’m doing wrong?

Try disable in twrp the ZIP verification! Usely this stops the installation.

Good luck. Greetings ivi

1 Like

Thank you for the suggestion. As is often the case, I had misread the documentation, and installing went like a breeze.

Are there instructions to do an OTA update of this fork? I was notified there was a new version, I downloaded it, the phone then rebooted to TWRP… and that’s it. There was no automatic installation, and I cannot find where the zip file has been downloaded. Does OTA updating work for you?