LineageOS fork including MicroG

Perhaps this could help …

That worked great, thanks a lot. For others, the tricky bit is the path were the file is downloaded, which is root:/data/lineageos_updates.

Shouldn’t be necessary to locate the package. Try to update your TWRP before the next OTA update —older TWRP versions cannot update OTAs automatically, like the one included in FP Open.

1 Like

I did install version 3.2.1.0 from https://dl.twrp.me/FP2/. It’s not the correct one?

1 Like

Yes, that version should work just fine.

Does someone know, why there is so many updates for los+mircrog? Do I need to update always?

as a rule of thumb:
update at least once a month to get the latest security updates, usually published by Google in the beginning of a month, so if you update around the 10th you should have them.
and of course if you experience problems that have or probably have been fixed.

2 Likes

Is someone else also experiencing strange battery drains sometimes? Last times it dropped super fast from 15% (energy saving mode starts) within minutes to 0. This morning however I experienced a drop from 40% down to 11 within 10 minutes or so… Didn’t use anything special (Firefox clear and a public transport app)…

2 Likes

I used to have these kind of battery drops quite often with FP Open (both with/without GApps or microG), ), both with my original ‘one of the first’ FP2 and later on with the replacement phone I received because of other issues. However since I switched to Lineage OS + microG last Monday it hasn’t occured yet and battery use seems way more stable. Pity it still happens to your phone, it was the main reason I switched to LineageOS… I never found out what caused it.

I have similar battery drops. From 15% to 0% is often crazy fast. It also happens to drop from 40% to 0% in minutes, but that’s rare. It seems to happen to me more in winter, which makes sense given how batteries react to cold.

I also have been thinking for a while that the battery indicator might just not be completely accurate at low levels? Last time I had an enormous 15-2% drop within 10 minutes I forgot to turn it off, put my phone back in my pocket (wifi on and everything) and 2 hours later it was still on, at 1%.

Apart from that:

MicroG is awesome! I have dabbled with microG on FP Open before but ran back to Google after a while because I lacked the discipline to keep my proprietary apps updated via Raccoon (and I couldn’t miss my beloved railway and banking apps and Whatsapp for the world). However since a colleague told me about Yalp I decided to give the Google-free-battery-sparing life a chance again and this LineageOS fork including microG seemed like the perfect opportunity.

I installed the then-latest version of the LineageOS-microG fork on January 1st following all instructions at https://wiki.lineageos.org/devices/FP2/install but queuing the zips for the latest modem files and addonsu as well. Afterwards I updated TWRP to be able to receive OTA updates. In the microG-settings I enabled Google device registration and GCM.

So far, most of it works like a charm. F-droid provides almost everything I need and Yalp recovered some of my precious paid-for Play Store apps. Location and weather have never been as accurate before.

However I noticed some weird behavior that I believe no one else mentioned in this topic:

  • After every regular reboot, some settings are lost: I have to set SwiftKey instead of the stock Android keyboard again, set storage permission for almost all apps, set standard apps for various purposes (SMS), have to choose which launcher to use for the home screen, etc.

  • Signal works just fine both for encrypted messaging and SMS but doesn’t show contact names in chats, only phone numbers (Contacts are stored locally - with names - and Signal seems to be able to access the numbers but not the names?)

  • VDK mobile banking app (which probably no one else uses) seems to work fine at first, I can register my phone, but upon trying to login, it ‘forgets’ my settings and I end up in a register-ok-register-again loop.

Now, the latter two are probably just app-specific quirks. The first issue however, is quite incovenient - especially if you quickly grab your phone and have to set everything right again before being able to - for example - take a picture.

Enabling and disabling Safety Net does not help. I suspect my adoptive storage SD of causing all of it (it isn’t immediately recognized upon reboot either) but I’m not sure.

As I’m on quite a new install anyway, I figure just wiping the phone and re-flashing the same version of LineageOS is the quickest solution. However to prevent the same thing from happening (and avoid having to do another and then another and then another factory reset) I wanted to ask for some input from you guys first.

Does anyone recognize the ‘forgotten settings’ issues?

Did anyone succesfully use LineageOS with microG without GApps with an SD set as adoptive storage?

Would anyone know what else to do to prevent this quirkiness from occuring?

Have you tried to delete the apps’ data and cache ? After my update I restore OsmAnd maps through ADB and every time it started it behave as if it was the first time I launched it (downloading every time offline maps, ecc…) but after clearing app’s data it worked fine.
Have you read this #troubleshooting ?

For those with fast battery drop. Did you try a battery reset (#batteryguide) ?
Battery drops under 12-13% occurs to me too, but I think battery reset somewhat mitigated them.

2 Likes

I have the it on Fairphone Open aswell. Maybe it’s not Lineage related.

Weird thing, sure it’s not a common issue. Did you do a clean install? To me it seems to be two possibilities:

  • Your memory chip is faulty (unlikely)
  • As you are using your microSD card as adoptive storage, your microSD is faulty or broken, or the FP cannot make proper contact with it

Long time ago, when smartphones had kind of 50MB free on disk from factory, tweakers like me used to use some hacky techniques to expand the internal memory with partitions on microSD and other stuff. As there’s a wide spectrum of SD cards qualities, issues like that (loosing some apps, or some app’s data) arrived from time to time with cheap and slow cards (depends on the “class” of the card) or just because microSD are prone to break.

That works just fine here and near me. Have you enabled LOS’s Privacy Guard for Signal? Make sure its disabled (or well-configured), Signal has read and write permission to your contacts and try to resync them (pencil icon -> open ⋮ options -> Reload).

Nothing to say. Some apps just don’t work because of missing Google APIs in microG.


OSMAnd doesn’t store offline maps or cached tiles in app’s data (which is the thing you restore with ADB), but in user-accessible storage (/storage/emulated/0/Android/data/net.osmand.plus/files/). If it doesn’t find them, it will download assets again, obviously.
(Note that /storage/emulated/0/Android is considered system data and is flushed when you wipe data from TWRP, even it being on user-accessible storage.)

1 Like

Thanks guys for your help. I should have mentioned some more details in my previous message: I cleared app data and cache, checked permissions and configured Privacy Guard already. The problems did not go away.

However… it turns out all my LineageOS issues were related and they’re all gone now! I just did a clean install and everything is working as it is supposed to. My phone doesn’t forget what apps I gave permissions to anymore, Signal is suddenly able to give people a name instead of a number, I don’t switch to the annoyingly vibrating stock keyboard after a reboot and even my banking app is fixed, it doesn’t act like it’s the first time I ever use it anymore. Hurray! Party! LineageOS forever!

I didn’t dare to use my microSD as adoptive storage this time, as no one in this topic confirmed they’re successfully doing so. The thing is, I don’t know whether the problem was the LineageOS install itself or the use of adoptive storage. Right now, I don’t have time to go through the whole process of backupping and setupping again, so I won’t test it, but as soon as I do, I’ll report on the results here!

Haha, well, fair enough, I did once screw up a (quite decent, Transcend) microSD by using partition managers with what some might call an overdose of enthusiasm. The replacement I got (even after honestly telling the store it was most surely my own fault!) was fine at first but slowly degraded over two years of extensive use, syncing a lot of data, using it for backups and later on as adoptive storage. Turns out SD segments have a limited amount of read and write cycles and you’re screwed afterwards (I didn’t know that).

The microSD I’m using right now however, is only 1 month old, its specs should be sufficient for adoptive storage (Samsung EVO) and it was doing just fine - adopted - in FP Open, about an hour before I installed LineageOS. I’m pretty sure that’s not the problem this time. :slight_smile:

PS: to fix the battery drops I had in FP Open, I tried everything in the batteryguide a few times yet without any effect - but so far, my battery is doing really good with LineageOS, yay!

3 Likes

Yesterday I had the second battery drop, this time from ~ 40% to 14% while I was walking outside at a temperature between 2 and 5 °C and taking a few photos. When I noticed the drop, I switched to flight mode immediately.

The interesting thing: about 6 hours later the battery was still at 14%. I switched off flight mode again and surfed the web for almost 1 hour in WiFi mode. The battery continued to stay at 14%, usually surfing an hour uses 5% to 10% capacity.

So in total I think the displayed battery drop might more be a sensor / calculation issue and less related to the battery itself.

Since the last couple of updates I started feeling the battery was draining at a faster rate. For example during the night without using the phone it’s dropping about 20% and when I check the details it seems to be the microG Core service that is taking the most of it. even after some hours of usage the % of the microG Core is comparable to the screen!

Hmm… I can’t approve that, in my case microG is at 1% battery usage (since yesterday morning).
Did you happen to install additional apps (or app updates) that might explain the increased microG usage?

Mm no new apps. But yes i did several updates. Hard to figure out what could be…

This is after half day of usage including the night

1 Like

Maybe the microG settings might give a hint, e.g. by checking which apps are registered for Google Cloud Messaging?

Another idea: did you already check the #batteryguide?

2 Likes