SD-Card suddenly switches to read-only file system


three weeks ago I bought a SAMSUNG Evo Plus 64 GB SD-card for my FP2, inserted it without any changes and selected “use as internal storage” (or similar - don’t remember the exact wording).

Everything seemed to be fine, camera pictures end up on the SD-card, I can copy music to it from my PC and play it on the phone, etc.

Now I sometimes experience a strange error, where the SD-card suddenly is mounted in read-only mode. I usually notice it because images won’t load in twidere twitter app.
Or when AntennaPod cannot download new episodes. AntennaPod’s log then shows “I/O error - read only file system”.

I have not yet found any way to reproduce this. It just happens from time to time and can only be remedied by restarting the phone.

I checked several times that the SD-card is properly inserted in its slot.

Is anyone else experiencing this?
Could it be a hardware issue with the sd-card or even the phone?
Any ideas how I could find the cause for this?

Thanks in advance.

This should work reliable as I have the 128GB type operating fine.
“Read-only” state could be an indicator of a damaged filesystem. Try to check on this using the windows dos command “chkdsk [sd card letter FP2]:” and see what it reports.
Fixing should be done with chkdsk [sd card letter FP2]: /f.

If possible backup all data and reformat the card specifically in the phone before restoration. This step can often prevent later troubles in advance as new sd cards are usually formated in a standard way which may not fit for all purpose from out of the pack.

To do that on Windows you’d either need to put the phone in mass storage mode, or insert the SD card directly into the computer. Otherwise Windows has no direct access to the file system - you can’t chkdsk an MTP volume.

1 Like

Yesterday evening I tried as suggested:

  1. migrated all data back from sd to internal storage
  2. let the phone re-format sd card as “mobile” storage
  3. inserted card into computer (mac) and ran a check with diskutils verifyVolume, which showed no errors
  4. then inserted card into phone again, let the phone format it as internal storage and migrate data to the card.

All was good until this morning, when the card was read-only again.

Any other ideas? Can someone point me to where I can find the system logs? Maybe they contain some more information?


Unfortunately no further idea.
But several FP2 users had relating issues. Maybe this thread provides some useful information. #fairphone2help
"SD Card no writing permission in FP2"

Good luck

I’m having the same issues as heapifyman. Using a FP2 with an 64 Samsung EVO SD card as internal storage with LineageOS.

I figured out that instead of rebooting one can unmount the SD card (Settings -> Storage -> Chose SD Card -> Eject -> Confirm) and then mount the card again, without removing it from the device.


Thanks for the hint. Unmounting and re-mounting the SD card does indeed work. And is faster than a reboot.

Have you found a way to reproduce this issue? Maybe noticed some special circumstances under which it happens? Or does it happen randomly?

So far I can not reproduce the issue. Sometimes it works for some days without any problems, sometimes the SD card doesn’t work in the right way after some hours.

I use the card only for a small number of apps such as osm-navigation (offline maps) and podcasts (large audio and video files).

Update: I decided to migrate my data back to the internal storage and stop using the external SD card as adopted storage (as part of the internal storage). This was because I couldn’t access anything from the adopted storage via TWRP, I could select the Micro SD card in TWRP but it would make the phone freeze therefore needing a force restart (hold down power button).

I wanted to actually install the latest version of TWRP by finding the image in my downloads, which was in the Micro SD card. Would this be a bug in TWRP?

Original post

I’ve recently decided to format and use the external SD card as part of the internal storage.

Everything migrated fine but I’ve had a missing SD card message and asks me to reinsert it. Rebooting didn’t fix it at first but I think after a couple of reboots it recognsied the card again and the card (fortunately!) wasn’t corrupted.

I think I had the same problem on FPOS and FPOOS so I’m wondering if this is either a firmware, OS or hardware issue.

My phone is encrytped and the card is a SanDisk 32GB.

Alternatively you could install it via Fastboot …

… see “Fastboot Install Method”.


I wonder when we move to LOS 15.1 if the problem accessing and installing the zip files through TWRP on an adopted Micro SD card would still be a problem (I now have the latest TWRP version 3.2.1).

I tried using LineageOS with an SD card as adoptive storage but ran into all kinds of quirks as well, described in this post and below:

I could not make it work and in the end stopped using adoptive storage. My SD is doing fine as regular external storage for videos etc.

Interestingly, I’m also using a 64 GB Samsung EVO.

Did anyone have issues with internal storage using another type of SD?

Hmm, I have a 64 GB Samsung EVO+ as well, and the same problem in LOS14.2:
first, my card (external storage) became read-only.
I unmounted, but then could only mount again if I “forgot”, meaning formatted, the card. I did this but it failed after 20%, and I can’t see or mount the card anymore (sd card missing, or no sd card).

Funny thing is, I can see it from TWRP recovery, even make it accessible to my PC (with MTP enabled), but I can’t mount it in TRWP or android.

Took the card out, inserted it back (while phone switched off or on), nothing :frowning:

1 Like

I do not know if your card is new, but you may want to read my post

There is more to sd card compatibility.

Btw. I have this card as 128GB version operating flawless with Lollipop5.1, but could read in this forum that other users had troubles with 64GB and also on LOS. As it looks it´s not only the plain capacity differing them. Also it is important to pay attention to minimal differences in the naming EVO / EVO+

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.