Using LineageOS on the FP2

You don’t need mini. You need at least Open GApps pico to get the Play Store, and with the Play Store you can install Maps. So it would be pico + Maps instead of mini (whatever difference this makes).

I only flashed addon-su and didn’t install any App, and root looks like before (I had it enabled in the unofficial builds).
If there was no root before, you might just need to enable root in the developer settings.

1 Like

Ok, for the record: I’ve checked* and Gobble Maps app’s basic functions worked with microG (an open source implementation of Google Services). Showing the map, searching a location and planning a trip. I don’t have a Google account to check login, but according to microG’s supported features, it should work (if G. Maps doesn’t handle this itself, which is likely).

*= calm down, privacy defenders and #livingwogoogle like me. All connections were made through Tor (Orbot’s VPN) and protected with LineageOS’s Privacy Guard, :wink:


OK, only Pico sounds OK.
But in principle I don’t want to use Playstore or Google Account at all. Just using the bare GoogleMaps functionality (show map, routing, traffic). I just want to get the APK for GoogleMaps, eg. here or with Racoon or… and therefore I ask if anything MORE from google services is needed to use it. You know what I mean?

7 posts were split to a new topic: Appstores and Trust

I see.

Does it have to be Google Maps for some specific reason, or would OsmAnd perhaps work? You wouldn’t have to bother with Open GApps then.

Here and here is some more info for when coming from Maps. And there’s more on the internet on that I would bet.

1 Like

Hi dear LOS fellows :slight_smile:
I’m quite happy with LineageOS becoming official.
However I found a little difference compared to unofficial LOS:

  • With official LineageOS, allowing ADB debugging in the settings only lasts until next reboot.
  • previously on unofficial LineageOS, allowing ADB survived shutdowns and reboots…
    Perhaps this was done on purpose, for security purposes?
    Can anyone confirm this?

Well, depending on how often you need to use it, you could just visit
That’s what I do when I have to use Google Maps.

1 Like

that’s true…but the usage in a browser is very ugly.
And my basic question is still not really answered: do I need for sure at least GApps Pico + Maps.apk to get it running, or can I also avoid pico…I think I will test it now…

You don’t need Pico to use the Maps app. I have no Google on my phone and maps works fine.


No, you don’t need GAPPS:

(But that is not the content of your quote, isn’t it? Anyhow…)

For the record - and the answer for my own question above:

  • I have a smoothly working LineageOS14@FP2 (following these instructions using TWRP coming from FPOS 1.12/Android 5)
  • I did NOT install any Open GApps Packages (not Pico, not Mini, not Nano Package, just nothing!)
  • I installed the bare Google Maps APK (, which I downloaded with Raccoon via PC from PlayStore and a FakeAccount, but I guess any GoolgeMapsAPK would work)
  • Result: I have a working Google Maps Application (without PlayStore or any google service installed, without the need of any GoogleAccount@FP2). GPS-location is displayed, maps, routing and current traffic is shown.

That’s all I wanted and I am happy that it is working without problems.

About my overall experience going from FPOS/Android5 --> LineageOS14/Android7 on FP2 I will report back here in a while.


Just as a reference for people reading along … while there is an “OpenGApps micro” package, microG has nothing to do with Open GApps, as it re-implements Google Apps and libraries with free software.

Open GApps offers install packages of the original Google stuff.

But good to know Google Maps wouldn’t need any of this :+1: .


True! That also confused me! I changed my post above a little (deleted “MicroG”).
MicroG is more for functionality of Push-messages using the google push service - If I am correct - and needs some more configuration under LineageOS to get it running…

@darioce You wrote in May about the SD card problem in Noutag/LineageOS.
Could you give a little bit more details (or links), how you gained write access over your external SD card for alle apps under LineageOS14.1@FP2
As I have of couse the same, by google intended problems / limiations, I would be happy to have a practical solution, which I didn’t found until now…

That was quite a while ago…:sweat:

Make sure you try the following in this order:

  1. Allow the app to ‘Access Media & Photos’ in Privacy Guard (relatively obvious)

  2. Under Settings->Developer options enable Force allow apps on external
    (if you do not see Developer options, tap 7 times on the Build number in Settings->About phone (This will hopefully do the trick)

  3. Change a few lines in /system/etc/permissions/platform.xml according to this post: SD Card no writing permission in FP2
    This used to work in FPOOS 5.1 but I think it is deprecated now. (Probably neither necessary nor helpful)

I do not remember, what I did exactly, but whatever I did survived any system upgrade, so you only need to do it once :sweat_smile:

@darioce thanks for your recap…
Unfortunately I am not quite there, where I want to be, I tried all your hints with the following - negative - result:

  1. Thats clear and I checked.
  • But e.g. The App SyncMe Wireless has only read access to ext. SD Card, and in Privacy Guard no “Access Media & Photos” is available (only “Notifications”, “Keep active”, “keep in background”, “start at boot”).
    • Edit1a: For SyncMe I read, that there is a beta version, which should be granting write access to ext. SD cards (I don’t yet know, how it will do it. I E-Mailed the devs and wait for the app, as suggested here.)
    • Edit1b: The developer in deed sent me a beta-version of “SyncMe Wireless” which includes a special dialogue in settings to get SD Write acces (and also to withdraw it) and with this it works!
  • For TitaniumBackup also no “Access Media & Photos” is available there.
    • Edit2: TB can access folders, which the programm itself created using option “DocumentProvider” in “Choose folder” options dialogue of TB. Found here.
  • Just a thought: Could it be, that these (maybe outdated) Apps have problems to make a proper request to Android in its preferred way, that they want to access to the ext. SD card? So Android could not allow it explicitley because it even don’t know? And just “grabbing” the permission by breaking the Android rules seems not possible?! But I also want to be able also to use older Apps, not explicitely designed for Android7…
  • It was not activated, but also after activation and after reboot there is no change
  • Unfortunately the structure of my platform.xml seems different from Android5/6 and there is none of the <group gid="sdcard_r" /> entries mentioned there, and a lengthy explanation which I don’t understand:

[details=Details of comment in platform.xml] These are permissions that were mapped to gids but we need
to keep them here until an upgrade from L to the current
version is to be supported. These permissions are built-in
and in L were not stored in packages.xml as a result if they
are not defined here while parsing packages.xml we would
ignore these permissions being granted to apps and not
propagate the granted state. From N we are storing the
built-in permissions in packages.xml as the saved storage
is negligible (one tag with the permission) compared to
the fragility as one can remove a built-in permission which
no longer needs to be mapped to gids and break grant propagation.[/details]
<permission name="android.permission.READ_EXTERNAL_STORAGE" /> <permission name="android.permission.WRITE_EXTERNAL_STORAGE" />

So - any other ideas for granting write access to erxternal SD Cards in LineageOS14.1@FP2 for all apps??

Can anybody shortly tell me, how the update process after the release of a new weekly of LineageOS will take place? I have running now LineageOS14.1@FP2.

  • Do I need to go just to the built-in updater and perform an update?
  • Will any of my data or settings NOT survive this update?
  • I guess a backup before every weekly-update is recommend (TitaniumBackup? TWRP?)?
  • besides the very detailed changelog is there also some less technical changelog? How I can decide if an updates includes some bigger changes or only some minor under the hood?

Should work.

Should not happen apart from possible updates to the OS settings themselves.
Be safe with a backup …

I would highly recommend it. Anything can happen :slight_smile: .
Be aware that TWRP just backups the state of the OS and leaves Androids “Internal Storage” out of it (if I understood correctly, the devs can’t guarantee to get it right 100% because Android made a mess of it).
So you need additional measures for your data … here’s what I do …

  • I backup all my stuff in Internal Storage (pictures, contacts, ringtones etc.) locally with MyPhoneExplorer, because it works great and I additionally sync my contacts locally with it and it can do some more fancy stuff which might come in handy occasionally (e.g. screen mirroring or recovering contacts accidentally saved at Google to the phone) … but it is Windows only, I didn’t test it with Wine.
  • I download all relevant update files to the phone (modem, LineageOSOpenGApps for me).
  • I boot into TWRP and backup the OS state before the update so I could go back if the update somehow turned out to be no good. I transfer the backup to my PC.
  • I install the update files in TWRP, as I’m there anyway then.
  • I reboot into the OS and go through my personal list of important features and check whether they still work.

I’m not sure at the moment about backing up Apps and settings … I didn’t bother until now whether I cover this as until now it only mattered if I changed the OS or installed from scratch, if in doubt I can set all that stuff up again if needed.
MyPhoneExplorer could extract Apps and install them again (one at a time, no batch), but I don’t use that feature.
I see Titanium Backup mentioned in that context pretty often in the forum.

I don’t know. I just install every update and thus don’t need to decide :slight_smile: .


2 posts were split to a new topic: Open links in browser

A post was split to a new topic: ‘One hand mode’ in LineageOS