Official LineageOS is here!

This is no “Distortion”, but the (new?) 1-Hand-Helper (so you can reach the “entire” screen with your thumb). If you click into the black areas it should go away - but i haven’t figured out where to set/disable this, nor where you can set the command to trigger it (i guess it is some slide-in/out-guesture).

Edit: A short google later: http://www.techdroider.com/2017/03/lineageos-gets-one-handed-mode-feature.html

6 Likes

To enable 1 hand mode, slide finger from left to right or right to left on the icons at bottom of screen. :slight_smile:
Chris

5 Likes

In addition to my previously mentioned issues, I just restarted the phone. While booting, instead of the Lineage logo, there is a text mentioning ‘Android is starting’, for like 20 minutes now.
[Edit: Apparently I could get in the powermenu while the message was on the screen. A reboot later and it starts up fine. At least, this time]

I feel that together with my previous issues, I may have to format my phone (maybe include going back to latest FP Open before installing LineageOS) again to get a clean slate.

My current issues with nightly of 14th November:

  • Internet (Wifi and mobile) very frequently loses connection. Status icons still mention the connection is fine, but no app can reach the internet (airplane or reboot fixes it sometimes)
  • Camera (v2) is not recognized.
  • Apps crash occasionally; they often run fine after 1 or more crashes
  • Cannot change call volume; I had this already with the unofficial builds. The slider now does appear when volume button is clicked, but the volume doesn’t decrease/increase.

Afaik, these issues are not present with other users, hence I am thinking of reinstalling from scratch. Which I dread btw, as I just finished installing everything after flashing the official from scratch…

Thanks! That was it…

1 Like

Ow, amazing! I had no idea about the one handed mode feature.
But the second screenshot shows a distortion though (top left corner).

@chrmhoffmann the #bugtracker is still used for official Lineage OS right?

@Douwe maybe it should be renamed as now it says:

###Community Port: LineageOS 14.1 for FP2###
This is the bugtracker for the community port of LineageOS to the FP2.

1 Like

Update installed via TWRP 3.1.1-2

The following things work for me so far:

  • call / be called
  • send SMS / receive SMS
  • internet via WiFi
  • internet via mobile network
  • location
  • compass
  • screenshot
  • main camera (new module)
  • selfie camera (new module)
  • USB connection to PC / MTP
  • alarm (incl. swiping it off)
  • MyPhoneExplorer
  • root
4 Likes

So what doesn’t work? :wink:
Chris

5 Likes

Don’t worry, somebody will find something :wink: .

5 Likes

That’s life. So, here it comes as a warning and help for users of the feature “adoptable storage”:

My SD card and with it the adopted storage wasn’t recognized anymore after using the Lineage Updater to install this update (20171121).
Before the update I had the nightly from 20171114, which was a fresh install (wiped everything before).

Because some apps and it’s files are stored on the SD card part of the adopted storage, I got an error message from AFWall+ directly after the reboot, saying it’s not working correctly. Maybe the custom scripts weren’t available.

Seemed worst case and I thought about going back with the TWRP backup I made before updating.
But I gave it one more chance and tried solving it with a restart (exactly a shutdown and manual start). And it worked, so the SD card is recognized again and AFWall+ still has it’s custom scripts without the need of configuring something from my side.

A big THANK YOU for your effort @chrmhoffmann and all, who are involved!
You compete with multi billion dollar companies not only to give the users a working smartphone, but giving them freedom and control over their data back!

Some background information:
I switched to LineageOS a few days ago coming from FPOOS 17.10, because of the same problems as @Smojo had. As I anyway had to wipe everything to solve the problems, I wanted to give Lineage OS a try.
Time will show, if I can have Android free of Google, without spending hours or even days just to manage the updates, as I had every time with FPOOS and Xprivacy to be sure, not to make a mistake and have a backup of everything for the worst case.

5 Likes

Awesome, since when does LOS contain the proximity sensor tool? I just saw it.
I can’t really test it as I don’t have any issues but if this works that will make some people really happy.

7 Likes

I saw it appear in the last release, the past tuesday, 2017-11-21. It was a good surprise! And it worked flawlessly for me, :hugging:

Specific commit is here: https://github.com/LineageOS/android_device_fairphone_FP2/commit/33ed4fafe474ea4f62fbad3aeb426fa21337f251

3 Likes

ohhhh thx :slight_smile: i also think that this is a bug :slight_smile::grinning:

Is there a way we can donate to the project (the port)? I’ve been so happy with LOS that I feel a donation is appropriate.

5 Likes

Donate to the red cross.

Chris

16 Likes

https://wiki.lineageos.org/costs/

4 Likes

Just to confirm the good job with this port for FP2:

I found more people using the adopted storage on standard Android (not Lineage OS) and having to restart their phones every few days for the storage to be found again.
So it seems to be a general issue to be fixed upstream on Android.

As my last nightly update was only 4 days after flashing Lineage OS and using this adoptable storage feature for the first time, the issue has most likely nothing to do with Lineage OS or this port for FP2.
Maybe it also depends on the SD card model. I’m using a 64 GB SanDisk Ultra Class 10 card.

If adopted storage refers to bundling SD cards as one device transparently, try a different SD card. Generally speaking I’ve had crap like that happening more often or solely on smartphones when it was cold outside.

Hi Paula, where did you find the tool? I can’t find it?

Latest LOS Build
Thanks for helping…
Tobias

In the list of installed apps. :wink:

1 Like