English

LineageOS 14.1 with OTA updates for FP2

4 posts were merged into an existing topic: Using LineageOS on the FP2

I moved this topic to #software:dev because it attracted issues that should go to

Please discuss everything that is not related to OTA updates there.

1 Like

Amazing job, thanks a lot :smiley:

If there are new developments regarding OTA updates, you can contact me and I will open the topic again. Otherwise the topic will open automatically by the start of next week.

@snevas better contact me via forum (PM) for open requests. :slight_smile:

I have fixed the issue with the new update available, I needed to change the timestamp of the zips to the builddate for it to not register as a new update. I fixed this for the last release and every upcoming one that will be built.

4 Likes

I have a question regarding porting Lineage to FP (I want to try the OTA-Method coming from FP Open. Why do I have to update TWRP? Can’t I just wipe and flash using the existing TWRP? As I have root, can I use the app, or do I have to flash aswell?

The patch for TWRP is only useful for OTA updates, if you don’t use that patched version, the updater will be rebooting to recovery, but not applying the update automatically. It should hopefully be soon™ be integrated into the normal build at twrp.me . EDIT: It’s actually already merged but not integrated in a build. So the next release of TWRP should include it :slight_smile:

3 Likes

I just installed Lineage! Thanks to all who realised this. How:

  • Flashed TWRP .img through TWPR and said reboot to recovery

  • Noticed that TWRP hat noch updated. Re-flashed TWRP.img and just shut down system. Rebooted into TWRP directly - TWRP hat updated.

  • Then flashed lineage.zip.

Now I just have to “install” the FP ringtone. :slight_smile:

1 Like

A post was merged into an existing topic: Official Fairphone Ringtone!

OTA Update has been worked as described (coming from Lineage OS). Thanks!!

1 Like

The new OTA went smooth without errors or hiccups - as always. Haven’t testet fm radio yet and don’t use encryption at the moment, but anyway, this is amazing.

Many thanks to @chrmhoffmann, @snevas, @z3ntu and the whole crew.

7 Likes

When I download the OTA update I often get a ‘Verification failed’ error and the update fails. A reboot usually resolves the issue and the update is installed without problems.
Is this a known issue? Am I doing something wrong?

Huge thanks again to all the people who brought this awesome OS to the Fairphone :clap:

This is just a hickup in the download. It checks a checksum before installation and doesn’t install it when the download is corrupt.
Redownloading normally solves this problem.

1 Like

New build available with these fixes. (Thanks @chrmhoffmann)

5 Likes

Thanks :slight_smile:

I tested FM radio and it works.

I didn’t test encryption, since I have formatted the SD-card as internal storage (which is already encrypted and works well so far).

Correction: FM radio only works for me for the primary user. Trying to use FM radio with a secondary user results in the same error message @s99h has shown below.

1 Like

Well, fm radio doesn’t work in my case. Tried with old 17.04.08 and new modem files 17.06.4 (don’t know if it makes a difference). Tried to wipe dalvik / art cache in recovery and app cache in Android options.

Did you try it with the primary or with a secondary user? For me it works only with the primary user (see my correction above).

I only use the phone as primary user (owner). Never tried the guest account or to register a secondary user.
Thanks for your thoughts.

I’m guessing you already tried with and without headphones plugged in and also after toggling airplane mode off?