Porting LineageOS to FP2

Chris’s goal is to have a clean port of LineageOS to the FP2 that can be submited as official (which is the best way to go, IMO). Any change to the OS itself is not allowed.
But… surely it can be done on the community build, :wink:


Who needs them to release source code when you can decompile the app :wink: I have a re-compiled version running on my phone (Lineage of course) but there are still a few permission problems due to the app not being a system app. (have never developed an app that uses superuser stuff :smiley: but I have to put that into the app to work properly probably)

EDIT: It’s harder than it seems… I’ll probably not spend the time doing it, sorry :confused: Developing a system app seems to be not really possible easily and it’s also way too complicated with su :frowning:


I can relate to your arguments so I changed the wiki accordingly. If there is anyone who is unhappy with that solution, please feel free to edit…

1 Like

I actualy don’t know how it happend, but suddenly works my proximity sensor during calls. I cleaned it, so I removed once tbe display. I’m on version 14.1.3.

A post was merged into an existing topic: LineageOS 14.1 with OTA updates for FP2

Encryption and FM radio should be fixed now.

I can currently not upload a new build (due to my ADSL line down), but I guess most people rely on the wearefairphone builds that should get the changes soon.



What’s missing to make FP2 an official LOS device? :slight_smile:


Thank you for managing PRs and merges to WAF repos yourself, :slight_smile:
This port is feature-full now! :smiley:

Does f3fb37 solve the wrong MAC address issue? (Not yet on WeAreFairphone builds)


The WiFi Mac problem should also be fixed now thanks to Luca.



A cleaner device tree history, a cleaner kernel history, some kernel features like scheduler and cpusets and other stuff.



A post was merged into an existing topic: Using LineageOS on the FP2

With the OTA update from 7th July, the MAC address is correct again.
Big thx!


Just FYI the Calibration tool isn’t easily installed because the tool needs to be installed as privileged system app which can only be done by the manufacturer/rom maker or with root permissions. But yes, a flashable zip should be possible (but that’s also possible with a non-open source .apk)

1 Like

Actually will the tool be enough?
FP OS 17.04.8 had the tool, but the OS wasn’t able to use the data provided by the tool if I understood it right.

Hey everyone,

Finally got a new screen and found time to test the latest source. First impression was that it runs better than some of the stock ROMs I’ve used in the past. Great work!

That being said, I did run into some issues after using it for a few days.

  1. Pairing Bluetooth can crash the device. It first becomes unresponsive and eventually reboots. I can reproduce it by running the pairing wizard in the Pebble app with a Pebble Time. I’ll look into it, but pointers in the right direction are welcome in case you’ve already observed.

Logcat: https://pastebin.com/rGd2YC3Q

  1. Some (probably related) battery drain that occurs occasionally. Couldn’t pinpoint it yet but the phone gets really hot. So most likely a process that runs into some kind of loop.


1 Like

Out of curiosity I’m checking out LineageOS at the moment, so far thumbs up :+1: .
But FM radio doesn’t work for me. I wiped my phone, had to format data because of encryption, and then installed lineage_FP2-ota-2017-06-14.zip, modem-17.06.4.zip and open_gapps-arm-7.1-pico-20170715.zip via TWRP.

The stock App is giving me “Process failed. If the problem persists, please turn FM off and on.”
Turning it off and on doesn’t help. I also tried forcing turn off and clearing App data and cache in Settings. Restarting the phone doesn’t help either.
And earphones are connected as antenna, as it prompts for this if they aren’t (so at least the earphone connection gets detected).

To check whether it is perhaps the App’s fault, I also tried SpiritF (free Open Source Spirit2 FM) from here, which doesn’t work, too …

Now what to do?


I started the encryption process, then the Android robot showed up for a moment, followed by an immediate reboot and a bootloop as far as the LineageOS booting animation.

What did I do wrong?

Are you aware of this thread?

Perhaps using a newer Version could help to solve the problem. Also there is the posibility to have OTA Updates.

1 Like

This has to be with the data partition filesystem and not with Lineage OS itself. Encryption doesn’t work for you in Fairphone OS or Open, neither. I have the same issue. Check the bug report: https://bugtracker.fairphone.com/project/fairphone-fairphone-os-android-6/issue/9

FM radio works fine here. And I have the same image installed as you did.
Just without gapps.

1 Like