LineageOS 14.1 with OTA updates for FP2

The new OTA went smooth without errors or hiccups - as always. Haven’t testet fm radio yet and don’t use encryption at the moment, but anyway, this is amazing.

Many thanks to @chrmhoffmann, @snevas, @z3ntu and the whole crew.


When I download the OTA update I often get a ‘Verification failed’ error and the update fails. A reboot usually resolves the issue and the update is installed without problems.
Is this a known issue? Am I doing something wrong?

Huge thanks again to all the people who brought this awesome OS to the Fairphone :clap:

This is just a hickup in the download. It checks a checksum before installation and doesn’t install it when the download is corrupt.
Redownloading normally solves this problem.

1 Like

New build available with these fixes. (Thanks @chrmhoffmann)


Thanks :slight_smile:

I tested FM radio and it works.

I didn’t test encryption, since I have formatted the SD-card as internal storage (which is already encrypted and works well so far).

Correction: FM radio only works for me for the primary user. Trying to use FM radio with a secondary user results in the same error message @s99h has shown below.

1 Like

Well, fm radio doesn’t work in my case. Tried with old 17.04.08 and new modem files 17.06.4 (don’t know if it makes a difference). Tried to wipe dalvik / art cache in recovery and app cache in Android options.

Did you try it with the primary or with a secondary user? For me it works only with the primary user (see my correction above).

I only use the phone as primary user (owner). Never tried the guest account or to register a secondary user.
Thanks for your thoughts.

I’m guessing you already tried with and without headphones plugged in and also after toggling airplane mode off?

Are you sure you are using the latest update? I am wondering about it because you posted about an OTA update a few hours before the build with the fixes was available. Did you do another OTA update afterwards?

I was wondering too.
I postet 26.06.2017 at 6:20 but the time stamp of the file is 08:25.

The build date in my phone settings shows 25.06.2017 21:01.

The build date on my phone is

1 Like

Your Build date is older than the date of your Kernel version. :upside_down:

1 Like

This was a build that didn’t have all the needed fixes: The newest one has build number: c55f5cafd9.
You can OTA update to get this one.


Thank you all for your support.
It must have been as @snevas said, an intermediate update that got drawn back. I was too quick :slight_smile:
Now I have downloaded and installed the latest update manually.
My fm radio now works! :+1:


Still I do not understand why the Build date (Jun 26 08:25:45 UTC 2017) is older than the date of the Kernel version (Jun 26 08:48:59 UTC 2017).

1 Like

@snevas may correct me if I am wrong, but I think the build date marks the start of the build process, which lasted 4 hr 42 min. The kernel was then built during this time.


I also have build number 4406f0c793, but the OTA updater keeps telling me that there is no newer version available?

Are you connected to wifi (there’s a setting that it only checks when connected to wifi)?

1 Like

I am.
shutting down the updater-app and emptying cache didn’t help either.