English

Lineage-18.1: Unofficial test build

Hi folks,

it’s THAT time of the year.

If someone can mirror the dropbox link… androidfilehost.com seems not working for me.

Few notes:

  • Google has dropped support for legacy keystore in 18.1 (so if your device does not boot, you might want to wipe):
    ** You might want to remove your lock screen before upgrading.
    ** Similarly, I am not sure if encrypted devices will survive the upgrade.
  • FM radio is not yet officially working. Using (and thx to) arco’s repo.
  • Device tree and kernel are up on gerrit. Vendor blobs as usual.

Thx esp go to z3ntu who did the big majority of the bringup!!!

Let us know what (does not) work here.

Chris

15 May updated downloads

35 Likes

This is so cool. Thx to you, @chrmhoffmann and @z3ntu.

6 Likes

Kneel before Zod!

         

Yes, wiping was necessary (default Factory Reset in TWRP 3.5.0_9-0).

6 Likes

Uploaded a new version (2nd) that includes also latest 17.1 kernel changes and the recovery.

Chris

2 Likes

Seems that Google maps blows up after a few seconds.
Chris

This is exciting :grin:. Thanks! Installed on my test FP2.

First, I tried installing with MindTheGapps (adb sideloaded the ROM and Gapps packages in the same session), but when I go through the setup procedure, when I get as the ‘Voice search at any time’ screen and click ‘No thanks’, it takes me back to the ‘Google Services’ acceptance screen without any way of exiting.

I tried again using OpenGApps 11.0 pico testing version and that works well. Now I will do some more testing :slight_smile:.

PS: Also, used the recovery file provided in the original post and managed to wipe and sideload using that.

1 Like

@chrmhoffmann Man, you are legend!

4 Likes

Interesting. I think this is a known issue in MindTheGapps.
For some reason the Google Wizard did not pop up for me - I thought because of space issue on /system partition.

Chris

Many thanks to @z3ntu

9 Likes

Is it possible to build from source @chrmhoffmann ?
I tried by checking out to c/301947 but device did not boot. Instead went back to fastboot.

You have kernel, device and vendor?

Head of kernel is: https://review.lineageos.org/c/LineageOS/android_kernel_fairphone_msm8974/+/303895
Head of device:
https://review.lineageos.org/c/LineageOS/android_device_fairphone_FP2/+/303769/3
Head of vendor:
GitHub - TheMuppets/proprietary_vendor_fairphone at lineage-18.1

1 Like

Thanks a lot @chrmhoffmann . I had not checked Kernel changes at all.

I can confirm that with the open changed in Gerrit, LOS 18.1 works perfectly. Might as well be be good to be merged. Also request you to please set eleven-bringup topic.

But I had a small issue with https://review.lineageos.org/c/LineageOS/android_device_fairphone_FP2/+/301918 . Build failed for LOCAL_COPY_HEADERS issue at android_device_fairphone_FP2/Android.mk at lineage-17.1 · LineageOS/android_device_fairphone_FP2 · GitHub. I adjusted it accordingly and it’s working…

Another thing is, I have used vendor blobs from A6. So, @chrmhoffmann with your permission can I ask users to try out this build?
I have uploaded it to AndroidFileHost.

Thanks.

Can you upload compilation error and / or diff somewhere? It compiled fine for me.

Chris

What do you mean by A6?

Chris

Android 6 I believe.

Well, if we upgrade blobs, we should go to latest available FP2 image (even 9 betas).

Now for fairphone, I am not sure to what extend this is useful, as they are not maintained by Qualcomm, so they (and now I guess) are partially fixed by fairphone.com (when they come from BSP compiled sources) to get stuff done or they are real blobs. Anyway, they won’t contain vendor security fixes because fairphone.com doesn’t have access (because they don’t exist because Qualcomm never maintained them).

So is blob upgrade useful? Maybe.

Chris

1 Like

Here’s the diff:
diff --git a/gps/loc_api/ds_api/Android.mk b/gps/loc_api/ds_api/Android.mk
index 18ab617…9a8eff8 100644
— a/gps/loc_api/ds_api/Android.mk
+++ b/gps/loc_api/ds_api/Android.mk
@@ -26,10 +26,7 @@ LOCAL_CFLAGS +=
-fno-short-enums
-D_ANDROID_

-LOCAL_COPY_HEADERS_TO:= libloc_ds_api/
-
-LOCAL_COPY_HEADERS:= \
-    ds_client.h
+LOCAL_EXPORT_C_INCLUDE_DIRS := $(LOCAL_PATH)

 LOCAL_LDFLAGS += -Wl,--export-dynamic

Yes, I have used the latest one from Pie(for which the base is Android 6).

I would strongly suggest. Because, if not for all then at least for netmgrd(I understand that we’ve taken from oppo_msm8974 but still it would be better if we have FP’s blobs.

Hence I request if anybody can confirm if everything is working in the shared build.

Thanks.

I don’t know why your build is broken. I see no one else changed this, but it’s true the LOCAL_COPY_HEADERS is deprecated. Can you post your build commands and the error message?

Chris

I upgraded without wiping data, and everything seems to work :smiley:

  • reboot to TWRP
  • flash LOS-18.1 zip
  • flash opengapps-pico-11-test zip
  • clear Dalvik/ Cache
  • reboot to system

Trust complained that image is signed with public keys, but that’s all (I could dismiss this message in Trust options)

Thants to every contributor <3

EDIT: seems that Magisk didn’t survive the upgrade, but Manager is still installed so I can reinstall 21.4 from there :slight_smile:
EDIT2: not possible from the Manager, so I flashed it with TWRP:

  • flash Magisk 21.4 zip
4 Likes

Thank both of you so much for (yet again) keeping the FP2 alive on the software side! :tada:
Would you recommend to install this test build as daily driver? Would it be possible to update to the official build after final release?

Or is it similar to the test builds for LOS17.1?

Looking forward to testing :star_struck: