English

Lineage-16.0 (Android Pie) Nightly

Tags: #<Tag:0x00007f05df9b9a10>

Can anyone confirm or deny “Wizards Unite” working on LOS16? Doesn’t work on LOS14.1 for me, so this might be the kick to upgrade for me :slight_smile:

You can follow this documentation, it’s fairly well made:

https://wiki.lineageos.org/devices/FP2/install

Dirty flashed today and was amazed that everything just worked!

Flashed June 22 and then June 23 and had no problems. But suddenly after powering it on again, I could not log in again.

  1. Put in pattern
  2. Screen is black
  3. Lockscreen is showing again

I found some errors in the logcat (attached):

  • java.security.InvalidKeyException: Only SecretKey is supported
  • java.lang.RuntimeException: Failed to decrypt blob

Logcat: https://pastebin.com/KggPP8h0

A few Pie ROMs for other devices seemed to have this problem too. I would like to know if it only happens when dirty flashing.

I was able to fix it by deleting the lock files in /data/system.
After setting up a new lockpattern, it seemed to work. I removed it, in fear the problem could come back (I don’t own the phone and cannot fix it again if it should happen)

Edit: Elaborate on dirty flash
I flashed LOS16 and Gapps on top of the stock 7.1 Fairphone Firmware (newest one).

What exactly is “dirty flashing”?

Flashing a new system without wiping all the data first.

I flashed LOS16 on top of the Stock Rom (Android 7.1.2 Fairphone OS) without wiping the data.

Everything worked (to my surprise) until the lockscreen issue.

2 Likes

Hi, after being away for some time and now doing a lot of reading I have one major question:

The issue of TRWP+LOS16+Encryption still persists?
So I have to more or less choose (simply speaking) between working backups (via twrp) or having an encrypted phone?
Is there any chance that there will be a new version anytime soon which can handle encryption? (I didn’t find any info on the TWRP page.)

Yes.

Depends.

  1. You can try a custom TWRP build which attempts to decrypt Android 8/9 encryption and see whether you’re lucky and it works for you. It has been seen working here and there, but not reliably for everybody.
  2. TWRP backups are working, but if TWRP can’t access the data partition, then the data partition will not be part of a TWRP backup. Be aware that TWRP doesn’t backup the whole data partition anyway, even if it has access to it.
    A backup of the files in an encrypted data partition can be made using other means while Android is running. ADB backup is a simple way, but restoring is a mess. Titanium Backup gets mentioned quite often for any scenario.

I wouldn’t count on it, as currently two experienced community developers tried to get TWRP to decrypt Android 8/9 encryption on the Fairphone 2 and don’t know why it doesn’t work (reliably at least). It seems quite elusive.

3 Likes

Thanks for this extensive and quick answer. And thanks for the link to the twrp backup FAQ. I wasn’t aware of that.

Yes, Wizards Unite works for me, I’m on LOS 16 + OpenGApps pico + iSu (to hide root)
I’m curious why it doesn’t work for you. Do you have root? Is PokémonGo working and Wizards Unite no?

As the 16.0 isnt yet stable and there havent been any updates to 15.1 since the beginning of May, will there be any 15.1 builds with upto date security patches?

16.0 is official and works in general.
Which specific problem do you have or are you referring to?

In my understanding LineageOS officially only supports the current major version for a specific device, so … officially from LineageOS … no.

But it’s Open Source, enthusiasts may still build 15.1 themselves with whatever they are able to add to it.

2 Likes

WU runs fine on 14.1 now - at the time I wrote my question, it simply was not visible in the play store (and direct link just showed “not compatible”).
A few days later, I looked again and it showed and installed fine.
Same on a Galaxy S5 running LOS16 :slight_smile:

Just curious … You were running 15.1 already, did you downgrade to 14.1?

Did not know that official builds were not allowed once the version had been bumped. That’s a shame because 16.0 being official does not mean 100% finished, and “works in general” does not always mean daily driver. Is there a page which lists the current problems? Yes I am being cautious

It’s not so much a question of allowing it, it is just not being done by LineageOS themselves. I suspect reasons like resources and focus.
You are perfectly allowed to build your own LineageOS.

Almost no halfway current piece of software ever is 100% finished.

That’s why I asked for a specific problem, because quite a lot of users here use 16.0 as their daily driver, including me (LineageOS for microG, though, which is based on official LineageOS).

Cautious concerning a version jump, yes, but rather less cautious concerning security holes :wink: .
That’s legitimate of course, we all have our own priorities.

If it helps, I tend to check whether the basics work when I install a new build. You can have a look here.
If you miss a basic check you would like to see, feel free to tell, I’ll see what I can do.

3 Likes

does anyone here have the impression that the phone heats up more often than in LOS 15.1?

I do. I also have the impression that there is a memory leak, as it’s lagging more and more after a few days, and launcher seems to restart often. Maybe the patches from jul 1 (power profile) help a bit, but this week I’m on holidays and a bit cautious

1 Like

For me it does not heat up more than on the previous LOS builts. Although it gets pretty hot in general, as we all experienced.
I also have the impression, that LOS 16 is the smoothest of all LOS versions so far.
I do have no more reboots, and it is very stable and relative fast on this hardware.

1 Like

same here

using Microsoft launcher currently but it was quicker on LOS 15

Don’t remember that it heats up that quick when only reading in a single news app

I didn’t get this impression so far, but perhaps I’ll try to be more alert about this in the coming days.
At least I had no reason to look for something so far, phone runs totally fine.

I’m used to the phone heating up e.g. when using OsmAnd for navigation and when using JavaScript-heavy stuff in Firefox, especially in multiple tabs. This behaviour wasn’t introduced with 16.0 to me, I can’t even remember anymore when this would have been any different for me.

I can’t confirm this on my phone (LineageOS for microG, though).
Could GApps or Apps play a role?
Do you use Trebuchet (the stock launcher)?