English

Lineage-16.0 (Android Pie) Nightly

lineageos
Tags: #<Tag:0x00007fefc3707140>

#116

Yes, I did try to switch off and on again.

I don’t how to do that : \


#117

There are a lot of apps, like satstat from f-droid, or probably more or less anything that shows sensors. Or probably the faiphone checkup tool


#118

Thanks : )
I tried StaStat. This is the result:

And actually the automatic light sensor for the screen brightness doesn’t seem to work either.

And the calibration tool doesn’t seem compatible:


#119

This looks like your sensors are dead. Here are mine

Proximity sensor tool works, too


#120

Actually when I start the phone on another OS, the sensors are fine.


#121

Did you upgrade from LineageOS 15.1 to 16.0, or did you install 16.0 from scratch (wiping the whole phone from everything and setting it up completely from the start)?


#122

I did the upgrade. I guess you’d suggest “wiping the whole phone from everything and setting it up completely from the start” ; )


#123

As a fallback plan or last resort, yes.
For the moment it just serves as a reminder that there would still be something you could do if this doesn’t get resolved otherwise :wink: .


#124

I tried to install it as indicated here:
https://wiki.lineageos.org/devices/FP2/install
but got the same problem : \


#125

To my surprise Battery Saving Location is working now :slight_smile:

Here is what I did:

  • I updated Lineage to the latest version from June 7 via TWRP and also reinstalled unifiednlp_2018-08-17.zip (that shouldn’t be necessary but also shouldn’t harm I thought …)
  • Rebooted to Lineage
  • Tested if Battery Saving Location is working now - it didn’t work.
  • Switched the FP2 off and removed one of the two SIM cards.
  • Started the FP2 with only one SIM card.
  • Tested if Battery Saving Location is working now - it worked!
  • Switched the FP2 off and added the second SIM card again.
  • Started the FP2 with two SIM cards.
  • Tested if Battery Saving Location is working- it was still working.

Now I wonder which of these steps made it work (I didn’t do anything else in between with the FP2)?


#126

I agree. It’s too bright for me, too.

My current workaround: Go to
Settings > Display > LiveDisplay > Color calibration
and reduce the Red, Green and Blue values (to e.g. 50%).
Downside of this solution is that the display may now be too dark in bright environments like outside in the sun.

It would be great if only the minimum brightness value could be reduced without changing the maximum brightness value. Is there a way to do this with Lineage 16?


#127

I found an app called “Brightness tweak” that hacked the minimum brightness back to 1 when it detected the system minimum was set (which is 10, I don’t know where it got that value from).

It’s crashing quite often but it gave some useful information, namely the path to control the brightness.

So I created a script that I run each time I want to set the brightness to the lowest level (at night):

echo 1 > /sys/devices/mdp.0/qcom,mdss_fb_primary.171/leds/lcd-backlight/brightness

I use the app “SH Script runner” to run it (with root) whenever I need. But I’d rather have the system minimum set to 1, instead of 10…


#129

Thanks :slight_smile:

Since I prefer apps from F-Droid, I use Termux and the Termux widget to run the script. Works well so far.

In case anyone wants to to the same, more info can be found here and here. The content of my script is just this:

#!/bin/sh
su -c "echo 1 > /sys/devices/mdp.0/qcom,mdss_fb_primary.171/leds/lcd-backlight/brightness"

Of course you need root for this.