English

Is there any alternative to the default Dialer app - that works on FP3?

Tags: #<Tag:0x00007f05d90de428> #<Tag:0x00007f05d90de2e8>

Hi.

TL;DR; Is there a working FOSS alternative to the system dialer on FP3? Which Dialer did OpenFP2 OS use? Is it available anywhere?

Long story:

I noticed - after installing NetGuard, that a lot of the preinstalled system apps on FP3 phone home to big brother google, even those you would not expect to.

I successfully replaced Contacts, SMS/Messenger, Calendar, The Launcher, Keyboard, Gallery and Music player with FOSS variants from F-DROID.

This leaves the system Dialer app, responsible for making outgoing and receiving incoming phone calls. According to NetGuard this app tries to connect to various obscure domain names
(such as
fra15s12-in-x0a.1e100.net, fra16s20.in,f10.1e100.net, …)
both domain and resolving IPv4 and IPv6 addresses belong to GOOGLE INC

Naturally I don’t want the system dialer to call home, especially when its in the background and I’m not even WANT to make any calls.

I tried installing the Open Source Emerald Dialer, and replace the default. But with that its not possible to receive any calls. (The phone rings, but there’s no UI element to take the call. It IS possible to make outgoing calls, but only when the screen is rotated landscape, in portrait mode the app crashes)

I couldn’t find any other FOSS dialer apps, is there anything out there that works on FP3?

4 Likes

According to


In Android 9 the dialer app is responsible for in call UI and receiving calls / accept UI.

This was not the case in earlier Android versions and as such this dialer doesn’t have it yet and the phone breaks.

Would the FP2 dialer be an option? where can I get it?

1 Like

How about LineageOS Apps for a try? Most of them should be AOSP …

https://www.apkmirror.com/uploads/?q=lineageos

(I just use the Email App for now, because I’m used to it from my LineageOSed Fairphone 2, I didn’t try anything else.)

5 Likes

Wow, you’ve just made my day!
I was missing the Lineage email app a lot!

1 Like

Which app would be the call UI alternative. Is it the “Phone Services” app?
Google’s dialer is on of the few apps I can’t get rid of, as yet.

It seems to be the " Lineage OS Phone".
I have tried it. Here it crashes when I try to open the dial pad…

I have tried “Open Contacts” (f-droid) too. It only shows an informational message about an incoming call and number but couldn’t answer.

“Simple Contacts” (f-droid) doesn’t show up at all, when a call comes in. The phone rings in the background without the opportunity to answer the call.

2 Likes

I just tried it in the version "Lineage OS Phone 19.0 (250000) " in the version from September 21 2018 - size 32 951 659 bytes
md5 8fdfeb93f527eb3…07c5
https://www.apkmirror.com/apk/lineageos/lineage-os-phone/lineage-os-phone-19-0-release/lineage-os-phone-19-0-android-apk-download/

instead of the preinstalled phone app. (I deactivated the preinstalled app)

So far it worked, I can accept calls, and I can make calls and the new dialer app is used as in-call UI. I can also use it to make calls or use the API to “ask to make a call” from OpenContacts

I have not tried yet if it also works after a device reboot. (Which was an issue with the replacement keyboard app)

5 Likes

Addition. My suspicion was spot on. If you replace the preinstalled dialer system app with the above app and reboot the phone, then receive a phone call BEFORE you first log in, you cannot accept the phone call. It keeps ringing, you can click it away with power or volume buttons to dismiss, but you can’t accept it.
If you unlock the phone once, then lock it again, the app will work and you can receive calls normally.

By the looks this seems to be a general restriction of Android 9. After a reboot, before the first unlock, NO apps installed by the user will work, but preinstalled system apps disabled by the user will be DISABLED. This applies to vital system apps such as dialer (needed to receive calls) or the keyboard (potentially needed to unlock the phone if password protected)

This is IMHO a serious issue of Android 9, and something that needs to be addressed, either in a patch/update for Fairphone’s stock OS, or a FOSS version for FP3 for the hardcore users. ( don’t think Google would address this, I bet this is a “feature” for them as it makes it harder to replace their stuff with 3rd party apps)

5 Likes

Thank you,
Disabled the Google one and I tried the app just there, it worked.
I had to change settings to allow it display over apps and I allowed it to modify system settings too. This means the popup appears so I can see when a call is incoming.

Pleased with that :grin:

3 Likes

Great hint with the LineageOS App :+1: it seems to work well :sweat_smile:

Can I trust that the LineageOS phone app not to share my calls and contacts with google as both have the google privacy policy?
(I am not familiar with LineageOS so far).


I tried to replace the Google Phone app before, too.
Ended up with using Simple Contacts (F-Droid) as default phone app, and Open Contacts (F-Droid) to show call log and in-call notification (overlay with name).

My observations:

  • Even with Simple Contacts as default phone app the screen during outgoing and incoming calls looks the same as before.
  • With deactivated Google Phone app no screen at all apears to manage active calls.

Because of this I wonder whether Google Phone and LineageOS Phone using a different UI of the same system app like Call Management for example (similar logo)?
I am not sure which app @corvuscorax meant with system Dialer app?

As a consequence of this an emergency call isn’t possible at a locked phone with a deactived phone app?

It looks like the emergency call uses a different UI that’s part of the lock screen app. Even with a freshly rebooted phone, I can still enter an emergency number. I never tried it past the “the inserted number is not an emergency number” error message though, as there’s a fine here for placing unnecessary emergency calls.

Similarly, incoming calls still ring, you just don’t have a button to accept them (but denying the call via power button works) - so it looks like it really is just the user Interface component that’s missing.

I’ll try to confirm that with an emulated Android device.

3 Likes

yes, it looks like placing emergency calls (at least simulated emergency calls in AVD android emulator) even without the dialer app (com.google.android.dialer) (named “Phone”)

by the looks of it however you can not hang up once the call has started :wink:

1 Like

Your emulator fits my observation that you can place and receive calls without the preinstalled or any Phone app, but without a User Interface to end or receive the call.

comprising the topic:

  • preinstalled Google Phone app = com.google.android.dialer
  • equivalent and compatible Phone replacement: LineageOS Phone
  • my observation: without Google or LineageOS Phone app outbound call is possible but no UI to end the call
  • special condition: when reboot phone (before enter PIN) only preinstalled apps work (LineageOS Phone doesn’t until enter PIN once after reboot)
    educated guess: dialing emergency number works, but you can’t stop it (for me this rare usecase is acceptable)
2 Likes

Regarding

Trust has to be earned :wink: The app that came with FP3 is called “Phone” (com.google.android.dialer) and actively tried to make a network connection to a Google IP address, which was intercepted and prevented by the Firewall App I installed, NetGuard.

The app from LineageOS is also called “Phone”, but designated com.android.dialer instead. This app so far has not tried to connect to anything in the 2 days since I installed it. It made 0 connection attempts (as it should)

Now that does not guarantee that it never will, nor that it won’t include code that tries something crazy if triggered by some rare event, but if it does, it still has to get past the firewall, which will prevent it, log it, and rest assured, I will update this thread accordingly if it does.

It’s called “dialer” since it doesn’t handle the call itself - this is handled by device drivers of the GSM modem and the audio stack, and partially in hardware. The dialer would likely just make an API call to send the “AP” commands to the modem to make a call and/or accept one. In newer Android version it also displays how long the call has been going (in call UI) and allows to initiate a hang up. (Which would again be a driver command to the GSM/UMTS/LTE/… modem)

As soon as one of the few FOSS apps has been updated to include the Android9 and higher in-call UI the Dialer now needs to provide in order to accept calls, it can again be replaced by such open source app. (Unless there’s sources for LineageOS, is there?)

4 Likes

Thanks for this info. Had problems after removing com.google.android.dialer via adb before too. I will try the solution with the LineageOS Dialer later.

This probably would be considered not a bug but a “feature” by every major phone manufacturer, since it is generally recommended to never ever end emergency calls and rather let the assistant hang up on you. So totally fine with me either :woman_shrugging:

Does this occur only after a reboot, or every time you initiate an emergency call from lock screen?

Besides, did you or somebody else manage to work around the problem with the keyboard and password-input on reboot? It’s unfortunately the only reason for me to keep the google gboard on my phone.

1 Like

The issue is only when the phone has been booted but not unlocked yet. Once you unlock and re-lock everything works. (That’s also why you will only notice the issue after a reboot)

My solution to get rid of google gboard was to change the lock from “password” to “pin” and use a long custom pin for unlocking. Unlike passwords, for which the lock screen invokes the system keyboard, for pins, it uses its own pin entry interface (and it also does for emergency numbers and for SIM pins if the SIM is locked with a pin)

in my case, after a cold reboot, I need to enter 3 pins. The pin for the 1st SIM, the pin for the 2nd SIM, and the PIN that phone is locked with.

On standby the SIM’s don’t need unlocking, so I only enter the phone PIN.

I worked around the reduced security of having only 10 digits by chosing a really long PIN.

2 Likes

Thanks, good to know.
When you are in the lockscreen options and try to set a PIN it shows the keyboard-symbol in the lower right corner of the screen, which you can tap on and select between gboard and others. So I didn’t invest more time in this topic and thought that you need gboard for PIN too.

PIN is fine for me. Didn’t want to use Pattern, because of the arrangement of the dots in the middle of the screen, hence its unergonomic design.

The newest version has bugs. When I click on the textfield for looking for contacts it crashes. In addition, I cannot answer calls when phone is locked.

However, September 21, 2018 version solves these issues.

Edit: I refer to the apk of Lineage OS Phone 19.0 in apkmirror.com

I am not able to use the Lineage OS Phone application from Simple Contacts Pro to make calls: If I press on the calling button in the entry of a contact then I can choose between a Dialer app, with the orange icon of Simple Contacts Pro, and a Phone application that is not the Lineage OS one but a Google one which icon is a blue 3D phone with no background. When using the orange Dialer I get no calling UI so I cannot finish the call nor entering digits, which is specially bad if the automatic answering machine of the other person wants me to record a message.

On the other hand, selecting a contact directly in the contacts tab of the Lineage OS Phone application redirect me to the Simple Contacts entry of the contact, so I cannot make the call. The only solution I found is to enter the name of the contact in the Search contact text field in the part of above of the Lineage OS Phone app. When pressing the contact that way, a call is succesfully done, including the UI.

In addition, introducion manually the number in the pad of Lineage OS Phone or pressing the phone icon at the right of the entries in the history calls tab also work.